%global _empty_manifest_terminate_build 0
Name: python-swaggerpy
Version: 0.2.1
Release: 1
Summary: Library for accessing Swagger-enabled API's
License: BSD 3-Clause License
URL: https://github.com/digium/swagger-py
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/84/b9/158f0f2f11a61ec5b64c39cf0a70007f5b44773d6bbf8a10c73e36ce88af/swaggerpy-0.2.1.tar.gz
BuildArch: noarch
%description
Swagger.py is a Python library for using
`Swagger `__ defined API's.
Swagger itself is best described on the Swagger home page:
Swagger is a specification and complete framework implementation for
describing, producing, consuming, and visualizing RESTful web
services.
The `Swagger
specification `__ defines
how API's may be described using Swagger.
Swagger.py also supports a WebSocket extension, allowing a WebSocket to
be documented, and auto-generated WebSocket client code.
%package -n python3-swaggerpy
Summary: Library for accessing Swagger-enabled API's
Provides: python-swaggerpy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-swaggerpy
Swagger.py is a Python library for using
`Swagger `__ defined API's.
Swagger itself is best described on the Swagger home page:
Swagger is a specification and complete framework implementation for
describing, producing, consuming, and visualizing RESTful web
services.
The `Swagger
specification `__ defines
how API's may be described using Swagger.
Swagger.py also supports a WebSocket extension, allowing a WebSocket to
be documented, and auto-generated WebSocket client code.
%package help
Summary: Development documents and examples for swaggerpy
Provides: python3-swaggerpy-doc
%description help
Swagger.py is a Python library for using
`Swagger `__ defined API's.
Swagger itself is best described on the Swagger home page:
Swagger is a specification and complete framework implementation for
describing, producing, consuming, and visualizing RESTful web
services.
The `Swagger
specification `__ defines
how API's may be described using Swagger.
Swagger.py also supports a WebSocket extension, allowing a WebSocket to
be documented, and auto-generated WebSocket client code.
%prep
%autosetup -n swaggerpy-0.2.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-swaggerpy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.2.1-1
- Package Spec generated