%global _empty_manifest_terminate_build 0
Name:		python-amulog
Version:	0.3.9
Release:	1
Summary:	A system log management tool with automatically generated log templates.
License:	The 3-Clause BSD License
URL:		https://github.com/cpflat/amulog/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/36/05/048d3d4db355417510bde80e4a7cb1f961483c9319cf8798fd952f274646/amulog-0.3.9.tar.gz
BuildArch:	noarch


%description
- Support multiple databases: sqlite and mysql
- Smart log segmentation with `log2seq <https://github.com/amulog/log2seq>`_
- Multiple template generation algorithms such as: Drain, SHISO, LenMa, FT-tree, Dlog, etc.
- Support Online (incremental) and Offline (hindsight) use
- Suspend and resume the template generation process
- Import and Export log templates if you need
- Edit log templates manually if you need
- Search API with datetime, hostname and log template IDs

%package -n python3-amulog
Summary:	A system log management tool with automatically generated log templates.
Provides:	python-amulog
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-amulog
- Support multiple databases: sqlite and mysql
- Smart log segmentation with `log2seq <https://github.com/amulog/log2seq>`_
- Multiple template generation algorithms such as: Drain, SHISO, LenMa, FT-tree, Dlog, etc.
- Support Online (incremental) and Offline (hindsight) use
- Suspend and resume the template generation process
- Import and Export log templates if you need
- Edit log templates manually if you need
- Search API with datetime, hostname and log template IDs

%package help
Summary:	Development documents and examples for amulog
Provides:	python3-amulog-doc
%description help
- Support multiple databases: sqlite and mysql
- Smart log segmentation with `log2seq <https://github.com/amulog/log2seq>`_
- Multiple template generation algorithms such as: Drain, SHISO, LenMa, FT-tree, Dlog, etc.
- Support Online (incremental) and Offline (hindsight) use
- Suspend and resume the template generation process
- Import and Export log templates if you need
- Edit log templates manually if you need
- Search API with datetime, hostname and log template IDs

%prep
%autosetup -n amulog-0.3.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-amulog -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.9-1
- Package Spec generated