%global _empty_manifest_terminate_build 0
Name: python-octomap-python
Version: 1.8.0.post12
Release: 1
Summary: Python binding of the OctoMap library.
License: BSD
URL: https://github.com/wkentaro/octomap-python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/49/ca/68fb8e17256e07b81647ccc002f4f7d2d7f784e330d776bbc96be25b87bb/octomap-python-1.8.0.post12.tar.gz
BuildArch: noarch
%description
# octomap-python
[![PyPI Version](https://img.shields.io/pypi/v/octomap-python.svg)](https://pypi.python.org/pypi/octomap-python)
[![Python Versions](https://img.shields.io/pypi/pyversions/octomap-python.svg)](https://pypi.org/project/octomap-python)
[![Build Status](https://travis-ci.com/wkentaro/octomap-python.svg?branch=master)](https://travis-ci.com/wkentaro/octomap-python)
Python binding of [the OctoMap library](https://github.com/OctoMap/octomap).
## Installation
```bash
pip install octomap-python
```
## Example
```bash
git clone https://github.com/wkentaro/octomap-python.git && cd octomap-python
pip install -e '.[example]'
cd examples
python insertPointCloud.py
```
## Acknowledgement
This is a fork of [neka-nat/python-octomap](https://github.com/neka-nat/python-octomap).
%package -n python3-octomap-python
Summary: Python binding of the OctoMap library.
Provides: python-octomap-python
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-octomap-python
# octomap-python
[![PyPI Version](https://img.shields.io/pypi/v/octomap-python.svg)](https://pypi.python.org/pypi/octomap-python)
[![Python Versions](https://img.shields.io/pypi/pyversions/octomap-python.svg)](https://pypi.org/project/octomap-python)
[![Build Status](https://travis-ci.com/wkentaro/octomap-python.svg?branch=master)](https://travis-ci.com/wkentaro/octomap-python)
Python binding of [the OctoMap library](https://github.com/OctoMap/octomap).
## Installation
```bash
pip install octomap-python
```
## Example
```bash
git clone https://github.com/wkentaro/octomap-python.git && cd octomap-python
pip install -e '.[example]'
cd examples
python insertPointCloud.py
```
## Acknowledgement
This is a fork of [neka-nat/python-octomap](https://github.com/neka-nat/python-octomap).
%package help
Summary: Development documents and examples for octomap-python
Provides: python3-octomap-python-doc
%description help
# octomap-python
[![PyPI Version](https://img.shields.io/pypi/v/octomap-python.svg)](https://pypi.python.org/pypi/octomap-python)
[![Python Versions](https://img.shields.io/pypi/pyversions/octomap-python.svg)](https://pypi.org/project/octomap-python)
[![Build Status](https://travis-ci.com/wkentaro/octomap-python.svg?branch=master)](https://travis-ci.com/wkentaro/octomap-python)
Python binding of [the OctoMap library](https://github.com/OctoMap/octomap).
## Installation
```bash
pip install octomap-python
```
## Example
```bash
git clone https://github.com/wkentaro/octomap-python.git && cd octomap-python
pip install -e '.[example]'
cd examples
python insertPointCloud.py
```
## Acknowledgement
This is a fork of [neka-nat/python-octomap](https://github.com/neka-nat/python-octomap).
%prep
%autosetup -n octomap-python-1.8.0.post12
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-octomap-python -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.8.0.post12-1
- Package Spec generated