%global _empty_manifest_terminate_build 0
Name: python-dpys
Version: 5.5.8
Release: 1
Summary: A library to simplify discord.py
License: MIT
URL: https://jgltechnologies.com/dpys
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4f/a5/f0b92412edcc3798e25a8f701df68ad0866045449de68b104291965dff6a/dpys-5.5.8.tar.gz
BuildArch: noarch
%description
# DPYS
## The goal of DPYS is to make basic functionalities that every good bot needs easy to implement for beginners.
A big update was just released that added disnake support. If there are any bugs please report
them here.
[DPYS](https://jgltechnologies.com/dpys) is a library that makes functionalites such as warnings, curse filter, reaction
roles, anti mute evade, and many more easy to add to your bot. All DPYS databases use
the [aiosqlite library](https://aiosqlite.omnilib.dev/en/latest/). Support for DPYS can be given
in [our Discord server](https://jgltechnologies.com/disnake). If you see any problems in the code or want to add a
feature, create a pull request on [our Github repository](https://jgltechnologies.com/dpys/src).
Install from pypi
```
python -m pip install dpys
```
Install from github
```
python -m pip install git+https://github.com/JGLTechnologies/dpys
```
Setup
```python
import dpys
from disnake.ext import commands
bot = commands.AutoShardedBot(command_prefix="!")
TOKEN = "Your Token
bot.loop.create_task(dpys.setup(bot, DIR))
bot.run()
```
Reaction role example
```python
import dpys
from disnake.ext import commands
import disnake
bot = commands.AutoShardedBot(command_prefix="!")
TOKEN = "Your Token"
# Do not type hint disnake.Role for the role argument
# Command to create the reaction role
@bot.slash_command(name="rr")
async def reaction_role_command(inter: disnake.ApplicationCommandInteraction, emoji: str = commands.Param(
description="An emoji or list of emojis"),
role: str = commands.Param(
description="a Role or list of roles."),
title: str = commands.Param(description="The title for the embed"),
description: str = commands.Param(description="The description for the embed")):
"""
It is used like this
/rr emoji @role