%global _empty_manifest_terminate_build 0
Name:		python-sidpy
Version:	0.11.2
Release:	1
Summary:	Python utilities for storing, visualizing, and processing Spectroscopic and Imaging Data (SID)
License:	MIT
URL:		https://pycroscopy.github.io/sidpy/about.html
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/46/49/ffec018e20f83d6430dfa07eb868a3ec26b0d889ffab5179c8c64a76681a/sidpy-0.11.2.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-toolz
Requires:	python3-cytoolz
Requires:	python3-dask
Requires:	python3-h5py
Requires:	python3-matplotlib
Requires:	python3-distributed
Requires:	python3-psutil
Requires:	python3-six
Requires:	python3-joblib
Requires:	python3-ipywidgets
Requires:	python3-scikit-learn
Requires:	python3-scipy
Requires:	python3-ase
Requires:	python3-ipython
Requires:	python3-ipython
Requires:	python3-pyqt5
Requires:	python3-mpi4py

%description
Python utilities for storing and visualizing Spectroscopic and Imaging Data (SID)
Please see our `website <https://pycroscopy.github.io/sidpy/index.html>`_ for more information.

%package -n python3-sidpy
Summary:	Python utilities for storing, visualizing, and processing Spectroscopic and Imaging Data (SID)
Provides:	python-sidpy
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sidpy
Python utilities for storing and visualizing Spectroscopic and Imaging Data (SID)
Please see our `website <https://pycroscopy.github.io/sidpy/index.html>`_ for more information.

%package help
Summary:	Development documents and examples for sidpy
Provides:	python3-sidpy-doc
%description help
Python utilities for storing and visualizing Spectroscopic and Imaging Data (SID)
Please see our `website <https://pycroscopy.github.io/sidpy/index.html>`_ for more information.

%prep
%autosetup -n sidpy-0.11.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sidpy -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.11.2-1
- Package Spec generated