%global _empty_manifest_terminate_build 0
Name: python-fpl
Version: 0.6.34
Release: 1
Summary: A Python wrapper for the Fantasy Premier League API
License: MIT
URL: https://github.com/amosbastian/fpl
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0b/d4/9a37219f92c8a4222410a4e96acbed474c20d65583526d115275e177abba/fpl-0.6.34.tar.gz
BuildArch: noarch
Requires: python3-certifi
Requires: python3-Click
Requires: python3-colorama
Requires: python3-codecov
Requires: python3-PTable
Requires: python3-appdirs
Requires: python3-aiohttp
Requires: python3-pytest-aiohttp
Requires: python3-pytest-cov
Requires: python3-pytest-mock
Requires: python3-pytest
%description
A Python wrapper around the Fantasy Premier League API
Join the [Discord server](https://discord.gg/cjY37fv) or submit [an issue](https://github.com/amosbastian/fpl/issues) for help and / or suggestions!
## Installing fpl
The recommended way to install fpl is via `pip`.
pip install fpl
To install it directly from GitHub you can do the following:
git clone git://github.com/amosbastian/fpl.git
You can also install a [.tar file](https://github.com/amosbastian/fpl/tarball/master)
or [.zip file](https://github.com/amosbastian/fpl/tarball/master)
curl -OL https://github.com/amosbastian/fpl/tarball/master
curl -OL https://github.com/amosbastian/fpl/zipball/master # Windows
Once it has been downloaded you can easily install it using `pip`:
cd fpl
pip install .
## Contributing
1. Fork the repository on GitHub.
2. Create a `credentials.cfg` file with your FPL login and password (see [example](docs/_static/example-credentials-file.cfg)).
3. Run the tests with `pytest tests/` to confirm they all pass on your system.
If the tests fail, then try and find out why this is happening. If you aren't
able to do this yourself, then don't hesitate to either create an issue on
GitHub, contact me on Discord or send an email to [amosbastian@gmail.com](mailto:amosbastian@gmail.com>).
3. Either create your feature and then write tests for it, or do this the other
way around.
4. Run all tests again with with `pytest tests/` to confirm that everything
still passes, including your newly added test(s).
5. Create a pull request for the main repository's `master` branch.
For more information on how to contribute to **fpl** see [the contributing guide](https://fpl.readthedocs.io/en/latest/contributing/contributing.html).
## Documentation
Documentation and examples for **fpl** can be found at http://fpl.readthedocs.io/en/latest/.
%package -n python3-fpl
Summary: A Python wrapper for the Fantasy Premier League API
Provides: python-fpl
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fpl
A Python wrapper around the Fantasy Premier League API
Join the [Discord server](https://discord.gg/cjY37fv) or submit [an issue](https://github.com/amosbastian/fpl/issues) for help and / or suggestions!
## Installing fpl
The recommended way to install fpl is via `pip`.
pip install fpl
To install it directly from GitHub you can do the following:
git clone git://github.com/amosbastian/fpl.git
You can also install a [.tar file](https://github.com/amosbastian/fpl/tarball/master)
or [.zip file](https://github.com/amosbastian/fpl/tarball/master)
curl -OL https://github.com/amosbastian/fpl/tarball/master
curl -OL https://github.com/amosbastian/fpl/zipball/master # Windows
Once it has been downloaded you can easily install it using `pip`:
cd fpl
pip install .
## Contributing
1. Fork the repository on GitHub.
2. Create a `credentials.cfg` file with your FPL login and password (see [example](docs/_static/example-credentials-file.cfg)).
3. Run the tests with `pytest tests/` to confirm they all pass on your system.
If the tests fail, then try and find out why this is happening. If you aren't
able to do this yourself, then don't hesitate to either create an issue on
GitHub, contact me on Discord or send an email to [amosbastian@gmail.com](mailto:amosbastian@gmail.com>).
3. Either create your feature and then write tests for it, or do this the other
way around.
4. Run all tests again with with `pytest tests/` to confirm that everything
still passes, including your newly added test(s).
5. Create a pull request for the main repository's `master` branch.
For more information on how to contribute to **fpl** see [the contributing guide](https://fpl.readthedocs.io/en/latest/contributing/contributing.html).
## Documentation
Documentation and examples for **fpl** can be found at http://fpl.readthedocs.io/en/latest/.
%package help
Summary: Development documents and examples for fpl
Provides: python3-fpl-doc
%description help
A Python wrapper around the Fantasy Premier League API
Join the [Discord server](https://discord.gg/cjY37fv) or submit [an issue](https://github.com/amosbastian/fpl/issues) for help and / or suggestions!
## Installing fpl
The recommended way to install fpl is via `pip`.
pip install fpl
To install it directly from GitHub you can do the following:
git clone git://github.com/amosbastian/fpl.git
You can also install a [.tar file](https://github.com/amosbastian/fpl/tarball/master)
or [.zip file](https://github.com/amosbastian/fpl/tarball/master)
curl -OL https://github.com/amosbastian/fpl/tarball/master
curl -OL https://github.com/amosbastian/fpl/zipball/master # Windows
Once it has been downloaded you can easily install it using `pip`:
cd fpl
pip install .
## Contributing
1. Fork the repository on GitHub.
2. Create a `credentials.cfg` file with your FPL login and password (see [example](docs/_static/example-credentials-file.cfg)).
3. Run the tests with `pytest tests/` to confirm they all pass on your system.
If the tests fail, then try and find out why this is happening. If you aren't
able to do this yourself, then don't hesitate to either create an issue on
GitHub, contact me on Discord or send an email to [amosbastian@gmail.com](mailto:amosbastian@gmail.com>).
3. Either create your feature and then write tests for it, or do this the other
way around.
4. Run all tests again with with `pytest tests/` to confirm that everything
still passes, including your newly added test(s).
5. Create a pull request for the main repository's `master` branch.
For more information on how to contribute to **fpl** see [the contributing guide](https://fpl.readthedocs.io/en/latest/contributing/contributing.html).
## Documentation
Documentation and examples for **fpl** can be found at http://fpl.readthedocs.io/en/latest/.
%prep
%autosetup -n fpl-0.6.34
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fpl -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.6.34-1
- Package Spec generated