%global _empty_manifest_terminate_build 0 Name: python-AN-DiscordBot Version: 3.9.4 Release: 1 Summary: A highly customisable Discord bot License: GPL-3.0 URL: https://github.com/aditya-nugraha-bot Source0: https://mirrors.nju.edu.cn/pypi/web/packages/73/82/f6bbed5f242132cecf2fa03137c1eb16e54430fc90e1affb49eb9a78c4b4/AN-DiscordBot-3.9.4.tar.gz BuildArch: noarch %description


AN - Discord Bot
AN Discord Bot

Music, Moderation, Trivia, Stream Alerts and Fully Modular.

Discord Server Support Red on Patreon! Made with Python 3.7 Localized with Crowdin

Code Style: Black

OverviewInstallationDocumentationPluginsCommunityLicense

# Overview AN is a fully modular bot – meaning all features and commands can be enabled/disabled to your liking, making it completely customizable. This is also a *self-hosted bot* – meaning you will need to host and maintain your own instance. You can turn AN into an admin bot, music bot, trivia bot, new best friend or all of these together! [Installation](#installation) is easy, and you do **NOT** need to know anything about coding! Aside from installation and updating, every part of the bot can be controlled from within Discord. **The default set of modules includes and is not limited to:** - Customisable command permissions **Additionally, other [plugins](#plugins) (cogs) can be easily found and added from our growing community of cog repositories.** # Installation **The following platforms are officially supported:** - Later # Plugins AN is fully modular, allowing you to load and unload plugins of your choice, and install 3rd party plugins directly from Discord! A few examples are: - Cleverbot integration (talk to Red and she talks back) - Ban sync - Welcome messages - Casino - Reaction roles - Slow Mode - Anilist - And much, much more! Feel free to take a [peek](https://cogboard.red/t/approved-repositories/210) at a list of available 3rd party cogs! # Join the community! **AN** is in continuous development, and it’s supported by an active community which produces new content (cogs/plugins) for everyone to enjoy. New features are constantly added. Join us on our [Official Discord Server](https://discord.gg/WEMJKXY)! # License Released under the [GNU GPL v3](https://www.gnu.org/licenses/gpl-3.0.en.html) license. Red is named after the main character of "Transistor", a video game by [Super Giant Games](https://www.supergiantgames.com/games/transistor/). Artwork created by [Sinlaire](https://sinlaire.deviantart.com/) on Deviant Art for the Red Discord Bot Project. %package -n python3-AN-DiscordBot Summary: A highly customisable Discord bot Provides: python-AN-DiscordBot BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-AN-DiscordBot


AN - Discord Bot
AN Discord Bot

Music, Moderation, Trivia, Stream Alerts and Fully Modular.

Discord Server Support Red on Patreon! Made with Python 3.7 Localized with Crowdin

Code Style: Black

OverviewInstallationDocumentationPluginsCommunityLicense

# Overview AN is a fully modular bot – meaning all features and commands can be enabled/disabled to your liking, making it completely customizable. This is also a *self-hosted bot* – meaning you will need to host and maintain your own instance. You can turn AN into an admin bot, music bot, trivia bot, new best friend or all of these together! [Installation](#installation) is easy, and you do **NOT** need to know anything about coding! Aside from installation and updating, every part of the bot can be controlled from within Discord. **The default set of modules includes and is not limited to:** - Customisable command permissions **Additionally, other [plugins](#plugins) (cogs) can be easily found and added from our growing community of cog repositories.** # Installation **The following platforms are officially supported:** - Later # Plugins AN is fully modular, allowing you to load and unload plugins of your choice, and install 3rd party plugins directly from Discord! A few examples are: - Cleverbot integration (talk to Red and she talks back) - Ban sync - Welcome messages - Casino - Reaction roles - Slow Mode - Anilist - And much, much more! Feel free to take a [peek](https://cogboard.red/t/approved-repositories/210) at a list of available 3rd party cogs! # Join the community! **AN** is in continuous development, and it’s supported by an active community which produces new content (cogs/plugins) for everyone to enjoy. New features are constantly added. Join us on our [Official Discord Server](https://discord.gg/WEMJKXY)! # License Released under the [GNU GPL v3](https://www.gnu.org/licenses/gpl-3.0.en.html) license. Red is named after the main character of "Transistor", a video game by [Super Giant Games](https://www.supergiantgames.com/games/transistor/). Artwork created by [Sinlaire](https://sinlaire.deviantart.com/) on Deviant Art for the Red Discord Bot Project. %package help Summary: Development documents and examples for AN-DiscordBot Provides: python3-AN-DiscordBot-doc %description help


AN - Discord Bot
AN Discord Bot

Music, Moderation, Trivia, Stream Alerts and Fully Modular.

Discord Server Support Red on Patreon! Made with Python 3.7 Localized with Crowdin

Code Style: Black

OverviewInstallationDocumentationPluginsCommunityLicense

# Overview AN is a fully modular bot – meaning all features and commands can be enabled/disabled to your liking, making it completely customizable. This is also a *self-hosted bot* – meaning you will need to host and maintain your own instance. You can turn AN into an admin bot, music bot, trivia bot, new best friend or all of these together! [Installation](#installation) is easy, and you do **NOT** need to know anything about coding! Aside from installation and updating, every part of the bot can be controlled from within Discord. **The default set of modules includes and is not limited to:** - Customisable command permissions **Additionally, other [plugins](#plugins) (cogs) can be easily found and added from our growing community of cog repositories.** # Installation **The following platforms are officially supported:** - Later # Plugins AN is fully modular, allowing you to load and unload plugins of your choice, and install 3rd party plugins directly from Discord! A few examples are: - Cleverbot integration (talk to Red and she talks back) - Ban sync - Welcome messages - Casino - Reaction roles - Slow Mode - Anilist - And much, much more! Feel free to take a [peek](https://cogboard.red/t/approved-repositories/210) at a list of available 3rd party cogs! # Join the community! **AN** is in continuous development, and it’s supported by an active community which produces new content (cogs/plugins) for everyone to enjoy. New features are constantly added. Join us on our [Official Discord Server](https://discord.gg/WEMJKXY)! # License Released under the [GNU GPL v3](https://www.gnu.org/licenses/gpl-3.0.en.html) license. Red is named after the main character of "Transistor", a video game by [Super Giant Games](https://www.supergiantgames.com/games/transistor/). Artwork created by [Sinlaire](https://sinlaire.deviantart.com/) on Deviant Art for the Red Discord Bot Project. %prep %autosetup -n AN-DiscordBot-3.9.4 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-AN-DiscordBot -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue May 30 2023 Python_Bot - 3.9.4-1 - Package Spec generated