%global _empty_manifest_terminate_build 0
Name:		python-django-shell-plus
Version:	1.1.7
Release:	1
Summary:	django-admin.py shell+  <- shell with models auto-imported
License:	UNKNOWN
URL:		http://bitbucket.org/schinckel/django-shell+/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/54/ee/0c1da6ed7fc3fa59edd15729651d158acec48c3e615ff4bd0ef17101e91a/django-shell-plus-1.1.7.tar.gz
BuildArch:	noarch


%description
A management command to start a shell, and auto-import all models, and the datetime module.
Usage::
    $ django-admin.py shell+
or::
    $ ./manage.py shell+
Also included: a command to update permissions.
    $ django-admin.py update_permissions
Installation::
    $ pip install django-shell-plus
And then add `shell_plus` to your `settings.INSTALLED_APPS`.

%package -n python3-django-shell-plus
Summary:	django-admin.py shell+  <- shell with models auto-imported
Provides:	python-django-shell-plus
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-shell-plus
A management command to start a shell, and auto-import all models, and the datetime module.
Usage::
    $ django-admin.py shell+
or::
    $ ./manage.py shell+
Also included: a command to update permissions.
    $ django-admin.py update_permissions
Installation::
    $ pip install django-shell-plus
And then add `shell_plus` to your `settings.INSTALLED_APPS`.

%package help
Summary:	Development documents and examples for django-shell-plus
Provides:	python3-django-shell-plus-doc
%description help
A management command to start a shell, and auto-import all models, and the datetime module.
Usage::
    $ django-admin.py shell+
or::
    $ ./manage.py shell+
Also included: a command to update permissions.
    $ django-admin.py update_permissions
Installation::
    $ pip install django-shell-plus
And then add `shell_plus` to your `settings.INSTALLED_APPS`.

%prep
%autosetup -n django-shell-plus-1.1.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-shell-plus -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.7-1
- Package Spec generated