%global _empty_manifest_terminate_build 0
Name: python-coal-mine
Version: 0.6.1
Release: 1
Summary: Coal Mine - Periodic task execution monitor
License: Apache 2.0
URL: https://github.com/quantopian/coal-mine
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/63/26/bcf6d7e4a2795a6da366cd6c2940a3db2ed0ddab2dd0c75f9e8abb0609dc/coal_mine-0.6.1.tar.gz
BuildArch: noarch
Requires: python3-certifi
Requires: python3-dnspython
Requires: python3-idna
Requires: python3-urllib3
Requires: python3-crontab
Requires: python3-logbook
Requires: python3-pymongo
Requires: python3-charset-normalizer
Requires: python3-requests
%description
Home page is `on Github `__.
Releases are available `in
PyPI `__.
%package -n python3-coal-mine
Summary: Coal Mine - Periodic task execution monitor
Provides: python-coal-mine
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-coal-mine
Home page is `on Github `__.
Releases are available `in
PyPI `__.
%package help
Summary: Development documents and examples for coal-mine
Provides: python3-coal-mine-doc
%description help
Home page is `on Github `__.
Releases are available `in
PyPI `__.
%prep
%autosetup -n coal-mine-0.6.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-coal-mine -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.6.1-1
- Package Spec generated