%global _empty_manifest_terminate_build 0
Name:		python-trytond-sale-opportunity
Version:	6.8.0
Release:	1
Summary:	Tryton module with leads and opportunities
License:	GPL-3
URL:		http://www.tryton.org/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a4/d2/d935c40fab8c4d2c2b4873d16bda2d0d23dbcf1a6c867c507f610802f257/trytond_sale_opportunity-6.8.0.tar.gz
BuildArch:	noarch

Requires:	python3-sql
Requires:	python3-dateutil
Requires:	python3-trytond-account
Requires:	python3-trytond-account-invoice
Requires:	python3-trytond-company
Requires:	python3-trytond-currency
Requires:	python3-trytond-party
Requires:	python3-trytond-product
Requires:	python3-trytond-sale
Requires:	python3-trytond-stock
Requires:	python3-trytond
Requires:	python3-pygal
Requires:	python3-proteus

%description
Sale Opportunity Module
#######################

The sale_opportunity module defines the lead/opportunity model.

Lead/Opportunity
****************

The lead and opportunity are defined by the same record but with different state.
Depending on the state, fields of the record become mandatory. Here is the
extensive list of the fields, most of them are optional:

- Party: The customer.
- Contact: The contact who placed the order.
- Address: The main address of the customer.
- Description: The description of the lead/opportunity.
- Number: The internal reference of the lead/opportunity (will be generated
  automatically at creation).
- Reference: The optional external reference of the order.
- Amount: The estimated revenue amount.
- Currency: Define the currency of the amount.
- Probability: The probability of conversion.
- Company: The company which issue the lead/opportunity.
- Employee: The employee responsible of the lead/opportunity.
- Start Date: When the lead started.
- End Date: When the lead ends (automatically set on win, cancel or lost).
- Payment Term: Define which payment term will be used for the future invoice.
- Comment: A text field to add custom comments.
- State: The state of the lead/opportunity. May take one of the following
  values:

    - Lead
    - Opportunity
    - Converted
    - Won
    - Cancelled
    - Lost

- Lines: A list of *Lead/Opportunity* line
- Sales: The list of sales converted from this opportunity.
- History: The list of changes made over time to the lead/opportunity.

The first time an opportunity is converted, a sale is created base on the
information of the opportunity and the lines.
The amount of the opportunity is later updated with the sales amount.
Once all the sales of an opportunity are confirmed (or cancelled with at least
one confirmed), the opportunity is won.
If all the sales of an opportunity are cancelled than the opportunity is lost.

Lead/Opportunity Line
*********************

A lead/opportunity line define a quantity of product that are expected to be sold.

Reports
*******

The sale_opportunity module defines also some reports:

- Opportunities per Employee.
- Opportunities per Month.
- Opportunities per Employee per Month.

which all show:

- The number of leads/opportunities.
- The number of converted opportunities.
- The convertion rate.
- The number of won opportunities.
- The winning rate.
- The number of lost opportunities.

- The total amount of leads/opportunities.
- The total amount of converted opportunities.
- The convertion amount rate.
- The total amount of won opportunities.
- The winning amount rate.


%package -n python3-trytond-sale-opportunity
Summary:	Tryton module with leads and opportunities
Provides:	python-trytond-sale-opportunity
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-trytond-sale-opportunity
Sale Opportunity Module
#######################

The sale_opportunity module defines the lead/opportunity model.

Lead/Opportunity
****************

The lead and opportunity are defined by the same record but with different state.
Depending on the state, fields of the record become mandatory. Here is the
extensive list of the fields, most of them are optional:

- Party: The customer.
- Contact: The contact who placed the order.
- Address: The main address of the customer.
- Description: The description of the lead/opportunity.
- Number: The internal reference of the lead/opportunity (will be generated
  automatically at creation).
- Reference: The optional external reference of the order.
- Amount: The estimated revenue amount.
- Currency: Define the currency of the amount.
- Probability: The probability of conversion.
- Company: The company which issue the lead/opportunity.
- Employee: The employee responsible of the lead/opportunity.
- Start Date: When the lead started.
- End Date: When the lead ends (automatically set on win, cancel or lost).
- Payment Term: Define which payment term will be used for the future invoice.
- Comment: A text field to add custom comments.
- State: The state of the lead/opportunity. May take one of the following
  values:

    - Lead
    - Opportunity
    - Converted
    - Won
    - Cancelled
    - Lost

- Lines: A list of *Lead/Opportunity* line
- Sales: The list of sales converted from this opportunity.
- History: The list of changes made over time to the lead/opportunity.

The first time an opportunity is converted, a sale is created base on the
information of the opportunity and the lines.
The amount of the opportunity is later updated with the sales amount.
Once all the sales of an opportunity are confirmed (or cancelled with at least
one confirmed), the opportunity is won.
If all the sales of an opportunity are cancelled than the opportunity is lost.

Lead/Opportunity Line
*********************

A lead/opportunity line define a quantity of product that are expected to be sold.

Reports
*******

The sale_opportunity module defines also some reports:

- Opportunities per Employee.
- Opportunities per Month.
- Opportunities per Employee per Month.

which all show:

- The number of leads/opportunities.
- The number of converted opportunities.
- The convertion rate.
- The number of won opportunities.
- The winning rate.
- The number of lost opportunities.

- The total amount of leads/opportunities.
- The total amount of converted opportunities.
- The convertion amount rate.
- The total amount of won opportunities.
- The winning amount rate.


%package help
Summary:	Development documents and examples for trytond-sale-opportunity
Provides:	python3-trytond-sale-opportunity-doc
%description help
Sale Opportunity Module
#######################

The sale_opportunity module defines the lead/opportunity model.

Lead/Opportunity
****************

The lead and opportunity are defined by the same record but with different state.
Depending on the state, fields of the record become mandatory. Here is the
extensive list of the fields, most of them are optional:

- Party: The customer.
- Contact: The contact who placed the order.
- Address: The main address of the customer.
- Description: The description of the lead/opportunity.
- Number: The internal reference of the lead/opportunity (will be generated
  automatically at creation).
- Reference: The optional external reference of the order.
- Amount: The estimated revenue amount.
- Currency: Define the currency of the amount.
- Probability: The probability of conversion.
- Company: The company which issue the lead/opportunity.
- Employee: The employee responsible of the lead/opportunity.
- Start Date: When the lead started.
- End Date: When the lead ends (automatically set on win, cancel or lost).
- Payment Term: Define which payment term will be used for the future invoice.
- Comment: A text field to add custom comments.
- State: The state of the lead/opportunity. May take one of the following
  values:

    - Lead
    - Opportunity
    - Converted
    - Won
    - Cancelled
    - Lost

- Lines: A list of *Lead/Opportunity* line
- Sales: The list of sales converted from this opportunity.
- History: The list of changes made over time to the lead/opportunity.

The first time an opportunity is converted, a sale is created base on the
information of the opportunity and the lines.
The amount of the opportunity is later updated with the sales amount.
Once all the sales of an opportunity are confirmed (or cancelled with at least
one confirmed), the opportunity is won.
If all the sales of an opportunity are cancelled than the opportunity is lost.

Lead/Opportunity Line
*********************

A lead/opportunity line define a quantity of product that are expected to be sold.

Reports
*******

The sale_opportunity module defines also some reports:

- Opportunities per Employee.
- Opportunities per Month.
- Opportunities per Employee per Month.

which all show:

- The number of leads/opportunities.
- The number of converted opportunities.
- The convertion rate.
- The number of won opportunities.
- The winning rate.
- The number of lost opportunities.

- The total amount of leads/opportunities.
- The total amount of converted opportunities.
- The convertion amount rate.
- The total amount of won opportunities.
- The winning amount rate.


%prep
%autosetup -n trytond-sale-opportunity-6.8.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-trytond-sale-opportunity -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 6.8.0-1
- Package Spec generated