%global _empty_manifest_terminate_build 0
Name:		python-anybox.recipe.openerp
Version:	1.9.1
Release:	1
Summary:	A buildout recipe to install and configure OpenERP
License:	AGPLv3+
URL:		https://launchpad.net/anybox.recipe.openerp
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/57/b2/49465b1b0457deb3bcd9bf70f3bb44c19423fbc17c96cc0172c52b0c8e84/anybox.recipe.openerp-1.9.1.tar.gz
BuildArch:	noarch


%description
This recipe for `Buildout <https://github.com/buildout/buildout>`_ is
a fully featured tool allowing you to define and deploy quickly
OpenERP installations of any kinds, ranging from development setups to
fully automated production deployments or continuous integration.
Some of its main features include:
* uniformity across OpenERP versions (from 5.0 onwards)
* installation of OpenERP server and, if meaningful, GTK and web clients.
* retrieval of main software and addons from various sources,
  including the major version control systems
* ability to pinpoint everything for replayability
* management of OpenERP configuration
* dedicated scripts creation for easy integration of external tools,
  such as test launchers
* packaging: creation of self-contained equivalents for easy
  deployment in tightly controlled hosting environmenents.
All these to be considered together with zc.buildout‘s general
properties, such as an extensible configuration file format for easy
variation or separation of concerns, native Python distributions
installation, and of course the huge ecosystem of other recipes.
The `full documentation
<http://pythonhosted.org/anybox.recipe.openerp>`_
is written with `Sphinx
<http://sphinx-doc.org>`_, built continuously and
uploaded to http://docs.anybox.fr/anybox.recipe.openerp by Anybox' public
buildbot.
The Sphinx source tree is to be found under the ``doc`` subdirectory
of this project.
The latest released version of the documentation is uploaded to PyPI
alongside with the package. See `PyPIDocumentationHosting
<https://wiki.python.org/moin/PyPiDocumentationHosting>`_ for details.
Bug reports and Feedback
~~~~~~~~~~~~~~~~~~~~~~~~
Please don't hesitate to give feedback and especially report bugs or
ask for new features through launchpad at this URL:
https://bugs.launchpad.net/anybox.recipe.openerp/+bugs
Useful links
~~~~~~~~~~~~
* Code repository and bug tracker: https://launchpad.net/anybox.recipe.openerp
* PyPI page: http://pypi.python.org/pypi/anybox.recipe.openerp
* Main documentation: http://docs.anybox.fr/anybox.recipe.openerp
Contributors information
~~~~~~~~~~~~~~~~~~~~~~~~
See `the latest version of the contributors documentation
<http://docs.anybox.fr/anybox.recipe.openerp/trunk/contributing.html>`_.
Credits
~~~~~~~
Authors:
 * Christophe Combelles
 * Georges Racinet
Contributors:
 * Jean-Sébastien Suzanne
 * Yannick Vaucher
 * Jacques-Etienne Baudoux
 * Laurent Mignon
 * Leonardo Pistone
 * Stefan Rijnhart
 * Stéphane Bidoul
 * Sebastian Kennedy
 * Laetitia Gangloff
 * Sandy Carter
Changes
~~~~~~~
The 1.9 series of anybox.recipe.openerp are stable versions, while
their counterparts are currently considered unstable.
Changes displayed as "unreleased" in the stable series are released
with any higher released unstable versions.
This is because for now anybox.recipe.openerp is considered to be
upstream of anybox.recipe.odoo, and will change in the future.

%package -n python3-anybox.recipe.openerp
Summary:	A buildout recipe to install and configure OpenERP
Provides:	python-anybox.recipe.openerp
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-anybox.recipe.openerp
This recipe for `Buildout <https://github.com/buildout/buildout>`_ is
a fully featured tool allowing you to define and deploy quickly
OpenERP installations of any kinds, ranging from development setups to
fully automated production deployments or continuous integration.
Some of its main features include:
* uniformity across OpenERP versions (from 5.0 onwards)
* installation of OpenERP server and, if meaningful, GTK and web clients.
* retrieval of main software and addons from various sources,
  including the major version control systems
* ability to pinpoint everything for replayability
* management of OpenERP configuration
* dedicated scripts creation for easy integration of external tools,
  such as test launchers
* packaging: creation of self-contained equivalents for easy
  deployment in tightly controlled hosting environmenents.
All these to be considered together with zc.buildout‘s general
properties, such as an extensible configuration file format for easy
variation or separation of concerns, native Python distributions
installation, and of course the huge ecosystem of other recipes.
The `full documentation
<http://pythonhosted.org/anybox.recipe.openerp>`_
is written with `Sphinx
<http://sphinx-doc.org>`_, built continuously and
uploaded to http://docs.anybox.fr/anybox.recipe.openerp by Anybox' public
buildbot.
The Sphinx source tree is to be found under the ``doc`` subdirectory
of this project.
The latest released version of the documentation is uploaded to PyPI
alongside with the package. See `PyPIDocumentationHosting
<https://wiki.python.org/moin/PyPiDocumentationHosting>`_ for details.
Bug reports and Feedback
~~~~~~~~~~~~~~~~~~~~~~~~
Please don't hesitate to give feedback and especially report bugs or
ask for new features through launchpad at this URL:
https://bugs.launchpad.net/anybox.recipe.openerp/+bugs
Useful links
~~~~~~~~~~~~
* Code repository and bug tracker: https://launchpad.net/anybox.recipe.openerp
* PyPI page: http://pypi.python.org/pypi/anybox.recipe.openerp
* Main documentation: http://docs.anybox.fr/anybox.recipe.openerp
Contributors information
~~~~~~~~~~~~~~~~~~~~~~~~
See `the latest version of the contributors documentation
<http://docs.anybox.fr/anybox.recipe.openerp/trunk/contributing.html>`_.
Credits
~~~~~~~
Authors:
 * Christophe Combelles
 * Georges Racinet
Contributors:
 * Jean-Sébastien Suzanne
 * Yannick Vaucher
 * Jacques-Etienne Baudoux
 * Laurent Mignon
 * Leonardo Pistone
 * Stefan Rijnhart
 * Stéphane Bidoul
 * Sebastian Kennedy
 * Laetitia Gangloff
 * Sandy Carter
Changes
~~~~~~~
The 1.9 series of anybox.recipe.openerp are stable versions, while
their counterparts are currently considered unstable.
Changes displayed as "unreleased" in the stable series are released
with any higher released unstable versions.
This is because for now anybox.recipe.openerp is considered to be
upstream of anybox.recipe.odoo, and will change in the future.

%package help
Summary:	Development documents and examples for anybox.recipe.openerp
Provides:	python3-anybox.recipe.openerp-doc
%description help
This recipe for `Buildout <https://github.com/buildout/buildout>`_ is
a fully featured tool allowing you to define and deploy quickly
OpenERP installations of any kinds, ranging from development setups to
fully automated production deployments or continuous integration.
Some of its main features include:
* uniformity across OpenERP versions (from 5.0 onwards)
* installation of OpenERP server and, if meaningful, GTK and web clients.
* retrieval of main software and addons from various sources,
  including the major version control systems
* ability to pinpoint everything for replayability
* management of OpenERP configuration
* dedicated scripts creation for easy integration of external tools,
  such as test launchers
* packaging: creation of self-contained equivalents for easy
  deployment in tightly controlled hosting environmenents.
All these to be considered together with zc.buildout‘s general
properties, such as an extensible configuration file format for easy
variation or separation of concerns, native Python distributions
installation, and of course the huge ecosystem of other recipes.
The `full documentation
<http://pythonhosted.org/anybox.recipe.openerp>`_
is written with `Sphinx
<http://sphinx-doc.org>`_, built continuously and
uploaded to http://docs.anybox.fr/anybox.recipe.openerp by Anybox' public
buildbot.
The Sphinx source tree is to be found under the ``doc`` subdirectory
of this project.
The latest released version of the documentation is uploaded to PyPI
alongside with the package. See `PyPIDocumentationHosting
<https://wiki.python.org/moin/PyPiDocumentationHosting>`_ for details.
Bug reports and Feedback
~~~~~~~~~~~~~~~~~~~~~~~~
Please don't hesitate to give feedback and especially report bugs or
ask for new features through launchpad at this URL:
https://bugs.launchpad.net/anybox.recipe.openerp/+bugs
Useful links
~~~~~~~~~~~~
* Code repository and bug tracker: https://launchpad.net/anybox.recipe.openerp
* PyPI page: http://pypi.python.org/pypi/anybox.recipe.openerp
* Main documentation: http://docs.anybox.fr/anybox.recipe.openerp
Contributors information
~~~~~~~~~~~~~~~~~~~~~~~~
See `the latest version of the contributors documentation
<http://docs.anybox.fr/anybox.recipe.openerp/trunk/contributing.html>`_.
Credits
~~~~~~~
Authors:
 * Christophe Combelles
 * Georges Racinet
Contributors:
 * Jean-Sébastien Suzanne
 * Yannick Vaucher
 * Jacques-Etienne Baudoux
 * Laurent Mignon
 * Leonardo Pistone
 * Stefan Rijnhart
 * Stéphane Bidoul
 * Sebastian Kennedy
 * Laetitia Gangloff
 * Sandy Carter
Changes
~~~~~~~
The 1.9 series of anybox.recipe.openerp are stable versions, while
their counterparts are currently considered unstable.
Changes displayed as "unreleased" in the stable series are released
with any higher released unstable versions.
This is because for now anybox.recipe.openerp is considered to be
upstream of anybox.recipe.odoo, and will change in the future.

%prep
%autosetup -n anybox.recipe.openerp-1.9.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-anybox.recipe.openerp -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.9.1-1
- Package Spec generated