%global _empty_manifest_terminate_build 0
Name:		python-bay
Version:	2.19.0
Release:	1
Summary:	Docker-based development workflow tooling
License:	Apache Software License
URL:		https://pypi.org/project/bay/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ce/fd/fa6df5a7a4595bb8e609383cd7738f4f66de2188c38bbdf7e11be91f9154/bay-2.19.0.tar.gz
BuildArch:	noarch


%description
Bay is a tool for assisting creation and management of Docker containers for development use.  It allows you to supplement a Dockerfile with additional information on how to run and link containers together. 

For more, see http://github.com/eventbrite/bay/

%package -n python3-bay
Summary:	Docker-based development workflow tooling
Provides:	python-bay
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-bay
Bay is a tool for assisting creation and management of Docker containers for development use.  It allows you to supplement a Dockerfile with additional information on how to run and link containers together. 

For more, see http://github.com/eventbrite/bay/

%package help
Summary:	Development documents and examples for bay
Provides:	python3-bay-doc
%description help
Bay is a tool for assisting creation and management of Docker containers for development use.  It allows you to supplement a Dockerfile with additional information on how to run and link containers together. 

For more, see http://github.com/eventbrite/bay/

%prep
%autosetup -n bay-2.19.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-bay -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 2.19.0-1
- Package Spec generated