%global _empty_manifest_terminate_build 0
Name: python-shortcodes
Version: 5.4.0
Release: 1
Summary: A library for parsing customizable WordPress-style shortcodes.
License: Public Domain
URL: https://github.com/dmulholl/shortcodes
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/00/91/8331b970558348d9d346df4cdb0ab058e159cd0b1ba5245464df02a5502b/shortcodes-5.4.0.tar.gz
BuildArch: noarch
%description
A library for parsing customizable WordPress-style shortcodes. Useful as a
drop-in component in text-processing applications.
Supports shortcodes with space-separated positional and keyword arguments::
[% tag arg1 "arg 2" key1=arg3 key2="arg 4" %]
Shortcodes can be atomic or block-scoped and can be nested to any depth.
Innermost shortcodes are processed first::
[% tag %] ... content with [% more %] shortcodes ... [% endtag %]
Shortcode syntax is customizable::
...
See the project's `Github homepage `_
for further details.
Note that this package requires Python 3.
%package -n python3-shortcodes
Summary: A library for parsing customizable WordPress-style shortcodes.
Provides: python-shortcodes
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-shortcodes
A library for parsing customizable WordPress-style shortcodes. Useful as a
drop-in component in text-processing applications.
Supports shortcodes with space-separated positional and keyword arguments::
[% tag arg1 "arg 2" key1=arg3 key2="arg 4" %]
Shortcodes can be atomic or block-scoped and can be nested to any depth.
Innermost shortcodes are processed first::
[% tag %] ... content with [% more %] shortcodes ... [% endtag %]
Shortcode syntax is customizable::
...
See the project's `Github homepage `_
for further details.
Note that this package requires Python 3.
%package help
Summary: Development documents and examples for shortcodes
Provides: python3-shortcodes-doc
%description help
A library for parsing customizable WordPress-style shortcodes. Useful as a
drop-in component in text-processing applications.
Supports shortcodes with space-separated positional and keyword arguments::
[% tag arg1 "arg 2" key1=arg3 key2="arg 4" %]
Shortcodes can be atomic or block-scoped and can be nested to any depth.
Innermost shortcodes are processed first::
[% tag %] ... content with [% more %] shortcodes ... [% endtag %]
Shortcode syntax is customizable::
...
See the project's `Github homepage `_
for further details.
Note that this package requires Python 3.
%prep
%autosetup -n shortcodes-5.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-shortcodes -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 5.4.0-1
- Package Spec generated