%global _empty_manifest_terminate_build 0
Name: python-atomate
Version: 1.0.3
Release: 1
Summary: atomate has implementations of FireWorks workflows for Materials Science
License: modified BSD
URL: https://github.com/hackingmaterials/atomate
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/97/1a/30242bbf8944fc1df7ddfe3ecd7bdae993e457dfe21d29912002442eb249/atomate-1.0.3.tar.gz
BuildArch: noarch
%description
#
[![Tests](https://github.com/hackingmaterials/atomate/actions/workflows/test.yml/badge.svg)](https://github.com/hackingmaterials/atomate/actions/workflows/test.yml)
[![PyPI Downloads](https://img.shields.io/pypi/dm/atomate?label=PyPI%20Downloads)](https://pypi.org/project/atomate)
[![PyPI](https://img.shields.io/pypi/v/atomate?label=PyPI%20Release)](https://pypi.org/project/atomate)
[![Requires Python 3.8+](https://img.shields.io/badge/Python-3.8+-blue.svg?label=Requires%20Python)](https://python.org/downloads)
atomate is a software for computational materials science that contains pre-built workflows to compute and analyze the properties of materials.
- **Website (including documentation):** https://hackingmaterials.github.io/atomate/
- **Help/Support:** https://discuss.matsci.org/c/atomate
- **Source:** https://github.com/hackingmaterials/atomate
If you find atomate useful, please encourage its development by citing the following paper in your research output:
```txt
Mathew, K., Montoya, J. H., Faghaninia, A., Dwarakanath, S., Aykol,
M., Tang, H., Chu, I., Smidt, T., Bocklund, B., Horton, M., Dagdelen,
J., Wood, B., Liu, Z.-K., Neaton, J., Ong, S. P., Persson, K., Jain,
A., Atomate: A high-level interface to generate, execute, and analyze
computational materials science workflows. Comput. Mater. Sci. 139,
140-152 (2017).
```
%package -n python3-atomate
Summary: atomate has implementations of FireWorks workflows for Materials Science
Provides: python-atomate
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-atomate
#
[![Tests](https://github.com/hackingmaterials/atomate/actions/workflows/test.yml/badge.svg)](https://github.com/hackingmaterials/atomate/actions/workflows/test.yml)
[![PyPI Downloads](https://img.shields.io/pypi/dm/atomate?label=PyPI%20Downloads)](https://pypi.org/project/atomate)
[![PyPI](https://img.shields.io/pypi/v/atomate?label=PyPI%20Release)](https://pypi.org/project/atomate)
[![Requires Python 3.8+](https://img.shields.io/badge/Python-3.8+-blue.svg?label=Requires%20Python)](https://python.org/downloads)
atomate is a software for computational materials science that contains pre-built workflows to compute and analyze the properties of materials.
- **Website (including documentation):** https://hackingmaterials.github.io/atomate/
- **Help/Support:** https://discuss.matsci.org/c/atomate
- **Source:** https://github.com/hackingmaterials/atomate
If you find atomate useful, please encourage its development by citing the following paper in your research output:
```txt
Mathew, K., Montoya, J. H., Faghaninia, A., Dwarakanath, S., Aykol,
M., Tang, H., Chu, I., Smidt, T., Bocklund, B., Horton, M., Dagdelen,
J., Wood, B., Liu, Z.-K., Neaton, J., Ong, S. P., Persson, K., Jain,
A., Atomate: A high-level interface to generate, execute, and analyze
computational materials science workflows. Comput. Mater. Sci. 139,
140-152 (2017).
```
%package help
Summary: Development documents and examples for atomate
Provides: python3-atomate-doc
%description help
#
[![Tests](https://github.com/hackingmaterials/atomate/actions/workflows/test.yml/badge.svg)](https://github.com/hackingmaterials/atomate/actions/workflows/test.yml)
[![PyPI Downloads](https://img.shields.io/pypi/dm/atomate?label=PyPI%20Downloads)](https://pypi.org/project/atomate)
[![PyPI](https://img.shields.io/pypi/v/atomate?label=PyPI%20Release)](https://pypi.org/project/atomate)
[![Requires Python 3.8+](https://img.shields.io/badge/Python-3.8+-blue.svg?label=Requires%20Python)](https://python.org/downloads)
atomate is a software for computational materials science that contains pre-built workflows to compute and analyze the properties of materials.
- **Website (including documentation):** https://hackingmaterials.github.io/atomate/
- **Help/Support:** https://discuss.matsci.org/c/atomate
- **Source:** https://github.com/hackingmaterials/atomate
If you find atomate useful, please encourage its development by citing the following paper in your research output:
```txt
Mathew, K., Montoya, J. H., Faghaninia, A., Dwarakanath, S., Aykol,
M., Tang, H., Chu, I., Smidt, T., Bocklund, B., Horton, M., Dagdelen,
J., Wood, B., Liu, Z.-K., Neaton, J., Ong, S. P., Persson, K., Jain,
A., Atomate: A high-level interface to generate, execute, and analyze
computational materials science workflows. Comput. Mater. Sci. 139,
140-152 (2017).
```
%prep
%autosetup -n atomate-1.0.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-atomate -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.0.3-1
- Package Spec generated