%global _empty_manifest_terminate_build 0
Name:		python-ffwd
Version:	0.0.2
Release:	1
Summary:	A Python client for FFWD
License:	Apache 2.0
URL:		UNKNOWN
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/08/62/55b6ecc62d5f25fbc4dfbc76d4a5390cf2085042c9a0550ab147b00ff157/ffwd-0.0.2.tar.gz
BuildArch:	noarch


%description
# ffwd-client-python

[FFWD](https://github.com/spotify/ffwd-java) client for Python.

See [examples](./examples) for usage examples.

## Installation

Install from PYPI:

```
$> pip install --user ffwd
```


%package -n python3-ffwd
Summary:	A Python client for FFWD
Provides:	python-ffwd
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ffwd
# ffwd-client-python

[FFWD](https://github.com/spotify/ffwd-java) client for Python.

See [examples](./examples) for usage examples.

## Installation

Install from PYPI:

```
$> pip install --user ffwd
```


%package help
Summary:	Development documents and examples for ffwd
Provides:	python3-ffwd-doc
%description help
# ffwd-client-python

[FFWD](https://github.com/spotify/ffwd-java) client for Python.

See [examples](./examples) for usage examples.

## Installation

Install from PYPI:

```
$> pip install --user ffwd
```


%prep
%autosetup -n ffwd-0.0.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ffwd -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.2-1
- Package Spec generated