%global _empty_manifest_terminate_build 0
Name:		python-Loglan-DB
Version:	0.1.21
Release:	1
Summary:	Loglan Dictionary Database Model for SQLAlchemy
License:	MIT
URL:		https://github.com/torrua/loglan_db
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/8c/9c/cd43cea827f8c136cf7d44e43235e875b9eba8bd814ed99811a01ffd83c7/Loglan-DB-0.1.21.tar.gz
BuildArch:	noarch

Requires:	python3-flask
Requires:	python3-sqlalchemy
Requires:	python3-flask-sqlalchemy
Requires:	python3-psycopg2

%description
# Loglan-DB
Loglan Dictionary Database Model for SQLAlchemy

[![Download Loglan-DB](https://img.shields.io/pypi/v/loglan_db.svg)](https://pypi.org/project/Loglan-DB/)
![PyPI - Downloads](https://img.shields.io/pypi/dm/Loglan-DB?color=light-green)
[![Build Status](https://scrutinizer-ci.com/g/torrua/loglan_db/badges/build.png?b=main)](https://scrutinizer-ci.com/g/torrua/loglan_db/build-status/main)
[![CodeQL](https://github.com/torrua/loglan_db/actions/workflows/codeql-analysis.yml/badge.svg)](https://github.com/torrua/loglan_db/actions/workflows/codeql-analysis.yml)
[![Scrutinizer Code Quality](https://scrutinizer-ci.com/g/torrua/loglan_db/badges/quality-score.png?b=main)](https://scrutinizer-ci.com/g/torrua/loglan_db/?branch=main)
[![codecov](https://codecov.io/gh/torrua/loglan_db/branch/main/graph/badge.svg?token=10O3OAC180)](https://codecov.io/gh/torrua/loglan_db)
[![GitHub license](https://img.shields.io/github/license/torrua/loglan_db)](https://github.com/torrua/loglan_db/blob/master/LICENSE)

This package is designed to generate SQL database for Loglan dictionary.

More documentation is available here:
https://torrua.github.io/loglan_db/


%package -n python3-Loglan-DB
Summary:	Loglan Dictionary Database Model for SQLAlchemy
Provides:	python-Loglan-DB
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Loglan-DB
# Loglan-DB
Loglan Dictionary Database Model for SQLAlchemy

[![Download Loglan-DB](https://img.shields.io/pypi/v/loglan_db.svg)](https://pypi.org/project/Loglan-DB/)
![PyPI - Downloads](https://img.shields.io/pypi/dm/Loglan-DB?color=light-green)
[![Build Status](https://scrutinizer-ci.com/g/torrua/loglan_db/badges/build.png?b=main)](https://scrutinizer-ci.com/g/torrua/loglan_db/build-status/main)
[![CodeQL](https://github.com/torrua/loglan_db/actions/workflows/codeql-analysis.yml/badge.svg)](https://github.com/torrua/loglan_db/actions/workflows/codeql-analysis.yml)
[![Scrutinizer Code Quality](https://scrutinizer-ci.com/g/torrua/loglan_db/badges/quality-score.png?b=main)](https://scrutinizer-ci.com/g/torrua/loglan_db/?branch=main)
[![codecov](https://codecov.io/gh/torrua/loglan_db/branch/main/graph/badge.svg?token=10O3OAC180)](https://codecov.io/gh/torrua/loglan_db)
[![GitHub license](https://img.shields.io/github/license/torrua/loglan_db)](https://github.com/torrua/loglan_db/blob/master/LICENSE)

This package is designed to generate SQL database for Loglan dictionary.

More documentation is available here:
https://torrua.github.io/loglan_db/


%package help
Summary:	Development documents and examples for Loglan-DB
Provides:	python3-Loglan-DB-doc
%description help
# Loglan-DB
Loglan Dictionary Database Model for SQLAlchemy

[![Download Loglan-DB](https://img.shields.io/pypi/v/loglan_db.svg)](https://pypi.org/project/Loglan-DB/)
![PyPI - Downloads](https://img.shields.io/pypi/dm/Loglan-DB?color=light-green)
[![Build Status](https://scrutinizer-ci.com/g/torrua/loglan_db/badges/build.png?b=main)](https://scrutinizer-ci.com/g/torrua/loglan_db/build-status/main)
[![CodeQL](https://github.com/torrua/loglan_db/actions/workflows/codeql-analysis.yml/badge.svg)](https://github.com/torrua/loglan_db/actions/workflows/codeql-analysis.yml)
[![Scrutinizer Code Quality](https://scrutinizer-ci.com/g/torrua/loglan_db/badges/quality-score.png?b=main)](https://scrutinizer-ci.com/g/torrua/loglan_db/?branch=main)
[![codecov](https://codecov.io/gh/torrua/loglan_db/branch/main/graph/badge.svg?token=10O3OAC180)](https://codecov.io/gh/torrua/loglan_db)
[![GitHub license](https://img.shields.io/github/license/torrua/loglan_db)](https://github.com/torrua/loglan_db/blob/master/LICENSE)

This package is designed to generate SQL database for Loglan dictionary.

More documentation is available here:
https://torrua.github.io/loglan_db/


%prep
%autosetup -n Loglan-DB-0.1.21

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Loglan-DB -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.21-1
- Package Spec generated