%global _empty_manifest_terminate_build 0 Name: python-Flask-Datepicker Version: 0.14 Release: 1 Summary: A Flask extension for jQueryUI DatePicker. License: MIT URL: https://github.com/mrf345/flask_datepicker/ Source0: https://mirrors.nju.edu.cn/pypi/web/packages/82/4b/9eb873caf0dc03a1b18c3d8051e64a32d708e1dcdba614676c49a7eafcd7/Flask-Datepicker-0.14.tar.gz BuildArch: noarch Requires: python3-Flask Requires: python3-Flask-Bootstrap %description

Flask-Datepicker

Latest Release
Coverage Status Code Style Number of downloads

A Flask extension for jQueryUI DatePicker, it makes adding and customizing multiple date pickers simpler and less time consuming.

## Install: #### - With pip - `pip install Flask-Datepicker`
#### - From the source: - `git clone https://github.com/mrf345/flask_datepicker.git`
- `cd flask_datepicker`
- `python setup.py install` ## Setup: #### - Inside Flask app: ```python from flask import Flask, render_template from flask_bootstrap import Bootstrap from flask_datepicker import datepicker app = Flask(__name__) Bootstrap(app) datepicker(app) ``` #### - Inside jinja template: ```jinja {% extends 'bootstrap/base.html' %} {% block scripts %} {{ super() }} {{ datepicker.loader() }} {# to load jQuery-ui #} {{ datepicker.picker(id=".dp") }} {% endblock %} {% block content %}
{% endblock %} ``` ## Settings: #### - Options: the accepted arguments to be passed to the `datepicker.picker()`: ```python def picker(id=".datepicker", # identifier will be passed to Jquery to select element dateFormat='yy-mm-dd', # can't be explained more ! maxDate='2018-12-30', # maximum date to select from. Make sure to follow the same format yy-mm-dd minDate='2017-12-01', # minimum date btnsId='.btnId' # id assigned to instigating buttons if needed ): ``` ##### - Themes `datepicker.loader()` allows you to select a specific theme of your choice via: ```python datepicker.loader(theme="base") ``` _If there is not a theme selected, the extension will select a new random theme with each reload of the page to be used. To make it remember the random choice, pass :_ ```python datepicker.loader(random_remember=True) ``` _List of available themes :_
` ['base', 'black-tie', 'blitzer' 'cupertino','dark-hive', 'dot-luv', 'eggplant', 'excite-bike', 'flick', 'hot-sneaks', 'humanity', 'le-frog','mint-choc', 'overcast', 'pepper-grinder', 'redmond','smoothness', 'south-street', 'start', 'sunny','swanky-purse', 'trontastic', 'ui-darkness','ui-lightness', 'vader'] ` #### - Local source: by default the extension will load jQueryUI plugin from [a remote CDN][25530337]. Although you can configure that to be locally through passing a list of two files .js and .css into the datepicker module like such: ```python datepicker(app=app, local=['static/js/jquery-ui.js', 'static/css/jquery-ui.css']) ``` [25530337]: https://code.jquery.com/ui/ "Jquery-ui CDN" ## Credit: > - [Datepicker][1311353e]: jQuery-ui date picker. [1311353e]: https://jqueryui.com/datepicker/ "jQuery-UI website" %package -n python3-Flask-Datepicker Summary: A Flask extension for jQueryUI DatePicker. Provides: python-Flask-Datepicker BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-Flask-Datepicker

Flask-Datepicker

Latest Release
Coverage Status Code Style Number of downloads

A Flask extension for jQueryUI DatePicker, it makes adding and customizing multiple date pickers simpler and less time consuming.

## Install: #### - With pip - `pip install Flask-Datepicker`
#### - From the source: - `git clone https://github.com/mrf345/flask_datepicker.git`
- `cd flask_datepicker`
- `python setup.py install` ## Setup: #### - Inside Flask app: ```python from flask import Flask, render_template from flask_bootstrap import Bootstrap from flask_datepicker import datepicker app = Flask(__name__) Bootstrap(app) datepicker(app) ``` #### - Inside jinja template: ```jinja {% extends 'bootstrap/base.html' %} {% block scripts %} {{ super() }} {{ datepicker.loader() }} {# to load jQuery-ui #} {{ datepicker.picker(id=".dp") }} {% endblock %} {% block content %}
{% endblock %} ``` ## Settings: #### - Options: the accepted arguments to be passed to the `datepicker.picker()`: ```python def picker(id=".datepicker", # identifier will be passed to Jquery to select element dateFormat='yy-mm-dd', # can't be explained more ! maxDate='2018-12-30', # maximum date to select from. Make sure to follow the same format yy-mm-dd minDate='2017-12-01', # minimum date btnsId='.btnId' # id assigned to instigating buttons if needed ): ``` ##### - Themes `datepicker.loader()` allows you to select a specific theme of your choice via: ```python datepicker.loader(theme="base") ``` _If there is not a theme selected, the extension will select a new random theme with each reload of the page to be used. To make it remember the random choice, pass :_ ```python datepicker.loader(random_remember=True) ``` _List of available themes :_
` ['base', 'black-tie', 'blitzer' 'cupertino','dark-hive', 'dot-luv', 'eggplant', 'excite-bike', 'flick', 'hot-sneaks', 'humanity', 'le-frog','mint-choc', 'overcast', 'pepper-grinder', 'redmond','smoothness', 'south-street', 'start', 'sunny','swanky-purse', 'trontastic', 'ui-darkness','ui-lightness', 'vader'] ` #### - Local source: by default the extension will load jQueryUI plugin from [a remote CDN][25530337]. Although you can configure that to be locally through passing a list of two files .js and .css into the datepicker module like such: ```python datepicker(app=app, local=['static/js/jquery-ui.js', 'static/css/jquery-ui.css']) ``` [25530337]: https://code.jquery.com/ui/ "Jquery-ui CDN" ## Credit: > - [Datepicker][1311353e]: jQuery-ui date picker. [1311353e]: https://jqueryui.com/datepicker/ "jQuery-UI website" %package help Summary: Development documents and examples for Flask-Datepicker Provides: python3-Flask-Datepicker-doc %description help

Flask-Datepicker

Latest Release
Coverage Status Code Style Number of downloads

A Flask extension for jQueryUI DatePicker, it makes adding and customizing multiple date pickers simpler and less time consuming.

## Install: #### - With pip - `pip install Flask-Datepicker`
#### - From the source: - `git clone https://github.com/mrf345/flask_datepicker.git`
- `cd flask_datepicker`
- `python setup.py install` ## Setup: #### - Inside Flask app: ```python from flask import Flask, render_template from flask_bootstrap import Bootstrap from flask_datepicker import datepicker app = Flask(__name__) Bootstrap(app) datepicker(app) ``` #### - Inside jinja template: ```jinja {% extends 'bootstrap/base.html' %} {% block scripts %} {{ super() }} {{ datepicker.loader() }} {# to load jQuery-ui #} {{ datepicker.picker(id=".dp") }} {% endblock %} {% block content %}
{% endblock %} ``` ## Settings: #### - Options: the accepted arguments to be passed to the `datepicker.picker()`: ```python def picker(id=".datepicker", # identifier will be passed to Jquery to select element dateFormat='yy-mm-dd', # can't be explained more ! maxDate='2018-12-30', # maximum date to select from. Make sure to follow the same format yy-mm-dd minDate='2017-12-01', # minimum date btnsId='.btnId' # id assigned to instigating buttons if needed ): ``` ##### - Themes `datepicker.loader()` allows you to select a specific theme of your choice via: ```python datepicker.loader(theme="base") ``` _If there is not a theme selected, the extension will select a new random theme with each reload of the page to be used. To make it remember the random choice, pass :_ ```python datepicker.loader(random_remember=True) ``` _List of available themes :_
` ['base', 'black-tie', 'blitzer' 'cupertino','dark-hive', 'dot-luv', 'eggplant', 'excite-bike', 'flick', 'hot-sneaks', 'humanity', 'le-frog','mint-choc', 'overcast', 'pepper-grinder', 'redmond','smoothness', 'south-street', 'start', 'sunny','swanky-purse', 'trontastic', 'ui-darkness','ui-lightness', 'vader'] ` #### - Local source: by default the extension will load jQueryUI plugin from [a remote CDN][25530337]. Although you can configure that to be locally through passing a list of two files .js and .css into the datepicker module like such: ```python datepicker(app=app, local=['static/js/jquery-ui.js', 'static/css/jquery-ui.css']) ``` [25530337]: https://code.jquery.com/ui/ "Jquery-ui CDN" ## Credit: > - [Datepicker][1311353e]: jQuery-ui date picker. [1311353e]: https://jqueryui.com/datepicker/ "jQuery-UI website" %prep %autosetup -n Flask-Datepicker-0.14 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-Flask-Datepicker -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue May 30 2023 Python_Bot - 0.14-1 - Package Spec generated