%global _empty_manifest_terminate_build 0
Name:		python-Manteia
Version:	0.0.41
Release:	1
Summary:	deep learning,NLP,classification,text,bert,distilbert,albert,xlnet,roberta,gpt2,torch,pytorch,active learning,augmentation,data
License:	MIT License
URL:		https://pypi.org/project/Manteia/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/6b/f9/66fae5f7d919d35fa8b246b6d51e95bd5b6bf4093b91974b5ad44fd959d3/Manteia-0.0.41.tar.gz
BuildArch:	noarch


%description
Designing your neural network to natural language processing. Deep learning has been used extensively in natural language processing (NLP) because
it is well suited for learning the complex underlying structure of a sentence and semantic proximity of various words.
Data cleaning, construction model (Bert, Roberta, Distilbert, XLNet, Albert, GPT, GPT2),
quality measurement training and finally visualization of your results on several dataset ( 20newsgroups, SST-2, PubMed_20k_RCT, DBPedia, Amazon Review Full, Amazon Review Polarity).
You can install it with pip :
     __pip install Manteia__
[Pretraitement]( https://raw.githubusercontent.com/ym001/Manteia/master/docs/images/boxplot.png)
[Training]( https://raw.githubusercontent.com/ym001/Manteia/master/docs/images/train.png)
For use with GPU and cuda we recommend the use of [Anaconda](https://www.anaconda.com/open-source) :
     __conda create -n manteia_env python=3.7__
     __conda activate manteia_env__
     __conda install pytorch__
     __pip install manteia__
Example of use Classification :
	from Manteia.Classification import Classification 
	from Manteia.Model import Model 
	documents = ['What should you do before criticizing Pac-Man? WAKA WAKA WAKA mile in his shoe.','What did Arnold Schwarzenegger say at the abortion clinic? Hasta last vista, baby.']
	labels = ['funny','not funny']
	model = Model(model_name ='roberta')
	cl=Classification(model,documents,labels,process_classif=True)
[NoteBook](https://github.com/ym001/Manteia/blob/master/notebook/notebook_Manteia_presentation1.ipynb)
Example of use Generation :
	from Manteia.Generation import Generation 
	from Manteia.Dataset import Dataset
	from Manteia.Model import *
	ds=Dataset('Short_Jokes')
	model       = Model(model_name ='gpt2')
	text_loader = Create_DataLoader_generation(ds.documents_train[:10000],batch_size=32)
	model.load_type()
	model.load_tokenizer()
	model.load_class()
	model.devices()
	model.configuration(text_loader)
	gn=Generation(model)
	gn.model.fit_generation(text_loader)
	output      = model.predict_generation('What did you expect ?')
	output_text = decode_text(output,model.tokenizer)
	print(output_text)
[NoteBook](https://github.com/ym001/Manteia/blob/master/notebook/notebook_Manteia_presentation2.ipynb)
[Documentation](https://manteia.readthedocs.io/en/latest/#)
[Pypi](https://pypi.org/project/Manteia/)
[Source](https://github.com/ym001/Manteia)
This code is licensed under MIT.

%package -n python3-Manteia
Summary:	deep learning,NLP,classification,text,bert,distilbert,albert,xlnet,roberta,gpt2,torch,pytorch,active learning,augmentation,data
Provides:	python-Manteia
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Manteia
Designing your neural network to natural language processing. Deep learning has been used extensively in natural language processing (NLP) because
it is well suited for learning the complex underlying structure of a sentence and semantic proximity of various words.
Data cleaning, construction model (Bert, Roberta, Distilbert, XLNet, Albert, GPT, GPT2),
quality measurement training and finally visualization of your results on several dataset ( 20newsgroups, SST-2, PubMed_20k_RCT, DBPedia, Amazon Review Full, Amazon Review Polarity).
You can install it with pip :
     __pip install Manteia__
[Pretraitement]( https://raw.githubusercontent.com/ym001/Manteia/master/docs/images/boxplot.png)
[Training]( https://raw.githubusercontent.com/ym001/Manteia/master/docs/images/train.png)
For use with GPU and cuda we recommend the use of [Anaconda](https://www.anaconda.com/open-source) :
     __conda create -n manteia_env python=3.7__
     __conda activate manteia_env__
     __conda install pytorch__
     __pip install manteia__
Example of use Classification :
	from Manteia.Classification import Classification 
	from Manteia.Model import Model 
	documents = ['What should you do before criticizing Pac-Man? WAKA WAKA WAKA mile in his shoe.','What did Arnold Schwarzenegger say at the abortion clinic? Hasta last vista, baby.']
	labels = ['funny','not funny']
	model = Model(model_name ='roberta')
	cl=Classification(model,documents,labels,process_classif=True)
[NoteBook](https://github.com/ym001/Manteia/blob/master/notebook/notebook_Manteia_presentation1.ipynb)
Example of use Generation :
	from Manteia.Generation import Generation 
	from Manteia.Dataset import Dataset
	from Manteia.Model import *
	ds=Dataset('Short_Jokes')
	model       = Model(model_name ='gpt2')
	text_loader = Create_DataLoader_generation(ds.documents_train[:10000],batch_size=32)
	model.load_type()
	model.load_tokenizer()
	model.load_class()
	model.devices()
	model.configuration(text_loader)
	gn=Generation(model)
	gn.model.fit_generation(text_loader)
	output      = model.predict_generation('What did you expect ?')
	output_text = decode_text(output,model.tokenizer)
	print(output_text)
[NoteBook](https://github.com/ym001/Manteia/blob/master/notebook/notebook_Manteia_presentation2.ipynb)
[Documentation](https://manteia.readthedocs.io/en/latest/#)
[Pypi](https://pypi.org/project/Manteia/)
[Source](https://github.com/ym001/Manteia)
This code is licensed under MIT.

%package help
Summary:	Development documents and examples for Manteia
Provides:	python3-Manteia-doc
%description help
Designing your neural network to natural language processing. Deep learning has been used extensively in natural language processing (NLP) because
it is well suited for learning the complex underlying structure of a sentence and semantic proximity of various words.
Data cleaning, construction model (Bert, Roberta, Distilbert, XLNet, Albert, GPT, GPT2),
quality measurement training and finally visualization of your results on several dataset ( 20newsgroups, SST-2, PubMed_20k_RCT, DBPedia, Amazon Review Full, Amazon Review Polarity).
You can install it with pip :
     __pip install Manteia__
[Pretraitement]( https://raw.githubusercontent.com/ym001/Manteia/master/docs/images/boxplot.png)
[Training]( https://raw.githubusercontent.com/ym001/Manteia/master/docs/images/train.png)
For use with GPU and cuda we recommend the use of [Anaconda](https://www.anaconda.com/open-source) :
     __conda create -n manteia_env python=3.7__
     __conda activate manteia_env__
     __conda install pytorch__
     __pip install manteia__
Example of use Classification :
	from Manteia.Classification import Classification 
	from Manteia.Model import Model 
	documents = ['What should you do before criticizing Pac-Man? WAKA WAKA WAKA mile in his shoe.','What did Arnold Schwarzenegger say at the abortion clinic? Hasta last vista, baby.']
	labels = ['funny','not funny']
	model = Model(model_name ='roberta')
	cl=Classification(model,documents,labels,process_classif=True)
[NoteBook](https://github.com/ym001/Manteia/blob/master/notebook/notebook_Manteia_presentation1.ipynb)
Example of use Generation :
	from Manteia.Generation import Generation 
	from Manteia.Dataset import Dataset
	from Manteia.Model import *
	ds=Dataset('Short_Jokes')
	model       = Model(model_name ='gpt2')
	text_loader = Create_DataLoader_generation(ds.documents_train[:10000],batch_size=32)
	model.load_type()
	model.load_tokenizer()
	model.load_class()
	model.devices()
	model.configuration(text_loader)
	gn=Generation(model)
	gn.model.fit_generation(text_loader)
	output      = model.predict_generation('What did you expect ?')
	output_text = decode_text(output,model.tokenizer)
	print(output_text)
[NoteBook](https://github.com/ym001/Manteia/blob/master/notebook/notebook_Manteia_presentation2.ipynb)
[Documentation](https://manteia.readthedocs.io/en/latest/#)
[Pypi](https://pypi.org/project/Manteia/)
[Source](https://github.com/ym001/Manteia)
This code is licensed under MIT.

%prep
%autosetup -n Manteia-0.0.41

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Manteia -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.41-1
- Package Spec generated