%global _empty_manifest_terminate_build 0
Name:		python-cppstd
Version:	1.0.0
Release:	1
Summary:	Partial port of C++ standard library.
License:	MIT License
URL:		https://github.com/lycantropos/cppstd/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/3e/70/357c5c1defb10b2fc96a2e52b6bd2818cadf2c5dc08eccdc9407512fb554/cppstd-1.0.0.tar.gz

Requires:	python3-reprit
Requires:	python3-typing-extensions

%description
[![](https://travis-ci.com/lycantropos/cppstd.svg?branch=master)](https://travis-ci.com/lycantropos/cppstd "Travis CI")
[![](https://dev.azure.com/lycantropos/cppstd/_apis/build/status/lycantropos.cppstd?branchName=master)](https://dev.azure.com/lycantropos/cppstd/_build/latest?definitionId=30&branchName=master "Azure Pipelines")
[![](https://codecov.io/gh/lycantropos/cppstd/branch/master/graph/badge.svg)](https://codecov.io/gh/lycantropos/cppstd "Codecov")
[![](https://img.shields.io/github/license/lycantropos/cppstd.svg)](https://github.com/lycantropos/cppstd/blob/master/LICENSE "License")
[![](https://badge.fury.io/py/cppstd.svg)](https://badge.fury.io/py/cppstd "PyPI")
In what follows `python` is an alias for `python3.5` or any later
version (`python3.6` and so on).

%package -n python3-cppstd
Summary:	Partial port of C++ standard library.
Provides:	python-cppstd
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-cffi
BuildRequires:	gcc
BuildRequires:	gdb
%description -n python3-cppstd
[![](https://travis-ci.com/lycantropos/cppstd.svg?branch=master)](https://travis-ci.com/lycantropos/cppstd "Travis CI")
[![](https://dev.azure.com/lycantropos/cppstd/_apis/build/status/lycantropos.cppstd?branchName=master)](https://dev.azure.com/lycantropos/cppstd/_build/latest?definitionId=30&branchName=master "Azure Pipelines")
[![](https://codecov.io/gh/lycantropos/cppstd/branch/master/graph/badge.svg)](https://codecov.io/gh/lycantropos/cppstd "Codecov")
[![](https://img.shields.io/github/license/lycantropos/cppstd.svg)](https://github.com/lycantropos/cppstd/blob/master/LICENSE "License")
[![](https://badge.fury.io/py/cppstd.svg)](https://badge.fury.io/py/cppstd "PyPI")
In what follows `python` is an alias for `python3.5` or any later
version (`python3.6` and so on).

%package help
Summary:	Development documents and examples for cppstd
Provides:	python3-cppstd-doc
%description help
[![](https://travis-ci.com/lycantropos/cppstd.svg?branch=master)](https://travis-ci.com/lycantropos/cppstd "Travis CI")
[![](https://dev.azure.com/lycantropos/cppstd/_apis/build/status/lycantropos.cppstd?branchName=master)](https://dev.azure.com/lycantropos/cppstd/_build/latest?definitionId=30&branchName=master "Azure Pipelines")
[![](https://codecov.io/gh/lycantropos/cppstd/branch/master/graph/badge.svg)](https://codecov.io/gh/lycantropos/cppstd "Codecov")
[![](https://img.shields.io/github/license/lycantropos/cppstd.svg)](https://github.com/lycantropos/cppstd/blob/master/LICENSE "License")
[![](https://badge.fury.io/py/cppstd.svg)](https://badge.fury.io/py/cppstd "PyPI")
In what follows `python` is an alias for `python3.5` or any later
version (`python3.6` and so on).

%prep
%autosetup -n cppstd-1.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-cppstd -f filelist.lst
%dir %{python3_sitearch}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
- Package Spec generated