%global _empty_manifest_terminate_build 0
Name:		python-reflux
Version:	1.1.0
Release:	1
Summary:	Extensive styling and theming functionality for Replit.
License:	MIT
URL:		https://github.com/frissyn/Reflux
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/8f/04/a5d517e6933bab17e8913dc8e4e2115b565928c48a8420b08913284f7f7d/reflux-1.1.0.tar.gz
BuildArch:	noarch

Requires:	python3-pyyaml

%description
# Reflux <img src="https://img.shields.io/badge/license-MIT-blue.svg?style=flat-square"> <a href="https://github.com/frissyn/Reflux/releases"><img src="https://img.shields.io/github/release/frissyn/Reflux.svg?style=flat-square"></a> <img src="https://img.shields.io/uptimerobot/ratio/m789613888-63da553f1a743d8870946ed3?style=flat-square">

Reflux is a third-party tool for creating and publishing site-wide style themes to Replit! Using Reflux, users can easily change Replit's default CSS variables, and share thier created themes with other users via the [marketplace](https://market.reflux.repl.co/). Find the quickstart example [here](https://replit.com/@reflux/template). Fork it and follow the guide to get started using Reflux and creating themes on Replit!

### Showcase

![image](https://storage.googleapis.com/replit/images/1635881358588_fb0b7e55745d4ffcdfce7ec2f5c33fd7.png)

![image](https://storage.googleapis.com/replit/images/1635881352143_96390d7d5b4809e8ef1f83a9e2bf8355.png)

### Installation

|Manager          |Command                                       |
|:----------------|:---------------------------------------------|
|**pip**          |`pip install reflux`                          |
|**poetry**       |`python -m poetry add reflux`                 |
|**replit**       |Search `reflux` in the Packages tab and `+` it|

### Documentation

Find extensive documentation on Reflux and it uses [here](https://github.com/frissyn/Reflux/tree/master/docs).

### Contributing

1. Fork the repository: [`Fork`](https://github.com/frissyn/Reflux/fork)
2. Clone locally (`git clone https://github.com/<username>/Reflux.git`)
3. Create your feature branch (`git checkout -b my-new-feature`)
4. Commit your changes (`git commit -a -m 'Add some feature'`)
5. Push to the branch (`git push origin my-new-feature`)
6. Create a new Pull Request! 🎉

**Local Developement:**

In order to properly test the Reflux package locally run `bash bin/local` in the project directory. `bash bin/clean` will delete the tarball and build directories.



%package -n python3-reflux
Summary:	Extensive styling and theming functionality for Replit.
Provides:	python-reflux
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-reflux
# Reflux <img src="https://img.shields.io/badge/license-MIT-blue.svg?style=flat-square"> <a href="https://github.com/frissyn/Reflux/releases"><img src="https://img.shields.io/github/release/frissyn/Reflux.svg?style=flat-square"></a> <img src="https://img.shields.io/uptimerobot/ratio/m789613888-63da553f1a743d8870946ed3?style=flat-square">

Reflux is a third-party tool for creating and publishing site-wide style themes to Replit! Using Reflux, users can easily change Replit's default CSS variables, and share thier created themes with other users via the [marketplace](https://market.reflux.repl.co/). Find the quickstart example [here](https://replit.com/@reflux/template). Fork it and follow the guide to get started using Reflux and creating themes on Replit!

### Showcase

![image](https://storage.googleapis.com/replit/images/1635881358588_fb0b7e55745d4ffcdfce7ec2f5c33fd7.png)

![image](https://storage.googleapis.com/replit/images/1635881352143_96390d7d5b4809e8ef1f83a9e2bf8355.png)

### Installation

|Manager          |Command                                       |
|:----------------|:---------------------------------------------|
|**pip**          |`pip install reflux`                          |
|**poetry**       |`python -m poetry add reflux`                 |
|**replit**       |Search `reflux` in the Packages tab and `+` it|

### Documentation

Find extensive documentation on Reflux and it uses [here](https://github.com/frissyn/Reflux/tree/master/docs).

### Contributing

1. Fork the repository: [`Fork`](https://github.com/frissyn/Reflux/fork)
2. Clone locally (`git clone https://github.com/<username>/Reflux.git`)
3. Create your feature branch (`git checkout -b my-new-feature`)
4. Commit your changes (`git commit -a -m 'Add some feature'`)
5. Push to the branch (`git push origin my-new-feature`)
6. Create a new Pull Request! 🎉

**Local Developement:**

In order to properly test the Reflux package locally run `bash bin/local` in the project directory. `bash bin/clean` will delete the tarball and build directories.



%package help
Summary:	Development documents and examples for reflux
Provides:	python3-reflux-doc
%description help
# Reflux <img src="https://img.shields.io/badge/license-MIT-blue.svg?style=flat-square"> <a href="https://github.com/frissyn/Reflux/releases"><img src="https://img.shields.io/github/release/frissyn/Reflux.svg?style=flat-square"></a> <img src="https://img.shields.io/uptimerobot/ratio/m789613888-63da553f1a743d8870946ed3?style=flat-square">

Reflux is a third-party tool for creating and publishing site-wide style themes to Replit! Using Reflux, users can easily change Replit's default CSS variables, and share thier created themes with other users via the [marketplace](https://market.reflux.repl.co/). Find the quickstart example [here](https://replit.com/@reflux/template). Fork it and follow the guide to get started using Reflux and creating themes on Replit!

### Showcase

![image](https://storage.googleapis.com/replit/images/1635881358588_fb0b7e55745d4ffcdfce7ec2f5c33fd7.png)

![image](https://storage.googleapis.com/replit/images/1635881352143_96390d7d5b4809e8ef1f83a9e2bf8355.png)

### Installation

|Manager          |Command                                       |
|:----------------|:---------------------------------------------|
|**pip**          |`pip install reflux`                          |
|**poetry**       |`python -m poetry add reflux`                 |
|**replit**       |Search `reflux` in the Packages tab and `+` it|

### Documentation

Find extensive documentation on Reflux and it uses [here](https://github.com/frissyn/Reflux/tree/master/docs).

### Contributing

1. Fork the repository: [`Fork`](https://github.com/frissyn/Reflux/fork)
2. Clone locally (`git clone https://github.com/<username>/Reflux.git`)
3. Create your feature branch (`git checkout -b my-new-feature`)
4. Commit your changes (`git commit -a -m 'Add some feature'`)
5. Push to the branch (`git push origin my-new-feature`)
6. Create a new Pull Request! 🎉

**Local Developement:**

In order to properly test the Reflux package locally run `bash bin/local` in the project directory. `bash bin/clean` will delete the tarball and build directories.



%prep
%autosetup -n reflux-1.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-reflux -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.0-1
- Package Spec generated