%global _empty_manifest_terminate_build 0
Name:		python-bdd-coder
Version:	2.2.1
Release:	1
Summary:	Gherkin language in class-based tests - test suite blueprinting
License:	MIT License
URL:		https://bitbucket.org/coleopter/bdd-coder
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/bc/8e/218f66c9568b1a7398be1db8c2c4f4d753a03c2cde9eb49c5e6872bed856/bdd-coder-2.2.1.tar.gz
BuildArch:	noarch

Requires:	python3-flake8
Requires:	python3-pygments
Requires:	python3-pytest
Requires:	python3-pyyaml
Requires:	python3-simple-cmd
Requires:	python3-ipdb
Requires:	python3-ipython
Requires:	python3-Twisted
Requires:	python3-freezegun
Requires:	python3-pytest-cov
Requires:	python3-pytest-twisted

%description
platform [...]
collecting ... collected 2 items
example/tests/test_stories.py::TestClearBoard::test_odd_boards PASSED    [ 50%]

%package -n python3-bdd-coder
Summary:	Gherkin language in class-based tests - test suite blueprinting
Provides:	python-bdd-coder
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-bdd-coder
platform [...]
collecting ... collected 2 items
example/tests/test_stories.py::TestClearBoard::test_odd_boards PASSED    [ 50%]

%package help
Summary:	Development documents and examples for bdd-coder
Provides:	python3-bdd-coder-doc
%description help
platform [...]
collecting ... collected 2 items
example/tests/test_stories.py::TestClearBoard::test_odd_boards PASSED    [ 50%]

%prep
%autosetup -n bdd-coder-2.2.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-bdd-coder -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 2.2.1-1
- Package Spec generated