%global _empty_manifest_terminate_build 0
Name: python-stix2-elevator
Version: 4.1.7
Release: 1
Summary: Utility to upgrade STIX 1.X and CybOX content to STIX 2.X
License: BSD License
URL: https://oasis-open.github.io/cti-documentation/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ac/a7/3762b048580d4dc247a0489e830987ed4f693ad21f1bac17452a2aeec176/stix2-elevator-4.1.7.tar.gz
BuildArch: noarch
Requires: python3-maec
Requires: python3-netaddr
Requires: python3-pycountry
Requires: python3-pluralizer
Requires: python3-stix
Requires: python3-stix2
Requires: python3-stix2-validator
Requires: python3-stixmarx
Requires: python3-stix-edh
Requires: python3-bumpversion
Requires: python3-pre-commit
Requires: python3-sphinx
Requires: python3-sphinx-prompt
Requires: python3-coverage
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-tox
%description
NOTE: This is an `OASIS TC Open
Repository `_.
See the `Governance`_ section for more information.
The stix2-elevator is a software tool for converting STIX 1.x XML to
STIX
2.0 or 2.1 JSON. Due to the differences between STIX 1.x and STIX 2.x, this
conversion is best-effort only. During the conversion, stix2-
elevator
provides information on the assumptions it needs to make to produce
valid STIX
2.x JSON, and what information was not able to be converted.
To convert STIX 2.x JSON back to STIX 1.x XML use the `stix2-slider`
The stix2-elevator is a "best-effort" attempt to convert STIX 1.x content to STIX 2.x content.
**Caution should be taken if the elevator is to be used in a production environment as warnings
concerning the conversion are often generated.** Users should determine which warnings are
acceptable and use the --disable option in conjunction with the –error-policy option only to produce
results when no other warnings are emitted.
**STIX 1.x Composite Indicator Expressions and CybOX 2.x Composite
Observable Expressions allow a level of flexibility not present in
STIX
2 patterns. These composite expressions can frequently have ambiguous
interpretations, so STIX 2 Indicators created by the stix2-elevator
from
STIX 1.x Indicators containing composite expressions should be
inspected
to ensure the STIX 2 Indicator has the intended meaning.**
For more information, see `the
documentation `__ on
ReadTheDocs.
Please enter any comments on how to improve the elevator into the issue tracker.
%package -n python3-stix2-elevator
Summary: Utility to upgrade STIX 1.X and CybOX content to STIX 2.X
Provides: python-stix2-elevator
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-stix2-elevator
NOTE: This is an `OASIS TC Open
Repository `_.
See the `Governance`_ section for more information.
The stix2-elevator is a software tool for converting STIX 1.x XML to
STIX
2.0 or 2.1 JSON. Due to the differences between STIX 1.x and STIX 2.x, this
conversion is best-effort only. During the conversion, stix2-
elevator
provides information on the assumptions it needs to make to produce
valid STIX
2.x JSON, and what information was not able to be converted.
To convert STIX 2.x JSON back to STIX 1.x XML use the `stix2-slider`
The stix2-elevator is a "best-effort" attempt to convert STIX 1.x content to STIX 2.x content.
**Caution should be taken if the elevator is to be used in a production environment as warnings
concerning the conversion are often generated.** Users should determine which warnings are
acceptable and use the --disable option in conjunction with the –error-policy option only to produce
results when no other warnings are emitted.
**STIX 1.x Composite Indicator Expressions and CybOX 2.x Composite
Observable Expressions allow a level of flexibility not present in
STIX
2 patterns. These composite expressions can frequently have ambiguous
interpretations, so STIX 2 Indicators created by the stix2-elevator
from
STIX 1.x Indicators containing composite expressions should be
inspected
to ensure the STIX 2 Indicator has the intended meaning.**
For more information, see `the
documentation `__ on
ReadTheDocs.
Please enter any comments on how to improve the elevator into the issue tracker.
%package help
Summary: Development documents and examples for stix2-elevator
Provides: python3-stix2-elevator-doc
%description help
NOTE: This is an `OASIS TC Open
Repository `_.
See the `Governance`_ section for more information.
The stix2-elevator is a software tool for converting STIX 1.x XML to
STIX
2.0 or 2.1 JSON. Due to the differences between STIX 1.x and STIX 2.x, this
conversion is best-effort only. During the conversion, stix2-
elevator
provides information on the assumptions it needs to make to produce
valid STIX
2.x JSON, and what information was not able to be converted.
To convert STIX 2.x JSON back to STIX 1.x XML use the `stix2-slider`
The stix2-elevator is a "best-effort" attempt to convert STIX 1.x content to STIX 2.x content.
**Caution should be taken if the elevator is to be used in a production environment as warnings
concerning the conversion are often generated.** Users should determine which warnings are
acceptable and use the --disable option in conjunction with the –error-policy option only to produce
results when no other warnings are emitted.
**STIX 1.x Composite Indicator Expressions and CybOX 2.x Composite
Observable Expressions allow a level of flexibility not present in
STIX
2 patterns. These composite expressions can frequently have ambiguous
interpretations, so STIX 2 Indicators created by the stix2-elevator
from
STIX 1.x Indicators containing composite expressions should be
inspected
to ensure the STIX 2 Indicator has the intended meaning.**
For more information, see `the
documentation `__ on
ReadTheDocs.
Please enter any comments on how to improve the elevator into the issue tracker.
%prep
%autosetup -n stix2-elevator-4.1.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-stix2-elevator -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 4.1.7-1
- Package Spec generated