%global _empty_manifest_terminate_build 0
Name:		python-b3j0f.aop
Version:	0.8.4
Release:	1
Summary:	Python Aspect Oriented Programming
License:	MIT License
URL:		https://github.com/b3j0f/aop
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/22/53/260e141bd3288104a583b8a04bfc8d01ac46b526bbd26865a68dc29a3683/b3j0f.aop-0.8.4.tar.bz2
BuildArch:	noarch


%description
This project is an Aspect Oriented Programming library for python with reflective concerns.

%package -n python3-b3j0f.aop
Summary:	Python Aspect Oriented Programming
Provides:	python-b3j0f.aop
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-b3j0f.aop
This project is an Aspect Oriented Programming library for python with reflective concerns.

%package help
Summary:	Development documents and examples for b3j0f.aop
Provides:	python3-b3j0f.aop-doc
%description help
This project is an Aspect Oriented Programming library for python with reflective concerns.

%prep
%autosetup -n b3j0f.aop-0.8.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-b3j0f.aop -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.4-1
- Package Spec generated