%global _empty_manifest_terminate_build 0
Name:		python-servox
Version:	2.2.4
Release:	1
Summary:	Opsani Servo: The Next Generation
License:	Apache-2.0
URL:		https://opsani.com/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/3d/25/69a99af99a226637480b5466ebb80d1f0642d3fd13868856c5e733b2da54/servox-2.2.4.tar.gz
BuildArch:	noarch

Requires:	python3-pydantic
Requires:	python3-loguru
Requires:	python3-httpx
Requires:	python3-dotenv
Requires:	python3-semver
Requires:	python3-pyaml
Requires:	python3-tabulate
Requires:	python3-pygments
Requires:	python3-devtools
Requires:	python3-backoff
Requires:	python3-typer
Requires:	python3-bullet
Requires:	python3-jsonschema
Requires:	python3-timeago
Requires:	python3-orjson
Requires:	python3-uvloop
Requires:	python3-pytz
Requires:	python3-toml
Requires:	python3-colorama
Requires:	python3-pyfiglet
Requires:	python3-curlify2
Requires:	python3-kubernetes_asyncio
Requires:	python3-aiofiles
Requires:	python3-dateutil
Requires:	python3-Authlib
Requires:	python3-watchfiles

%description
optimizer:
  id: newco.com/awesome-app1
  token: 00000000-0000-0000-0000-000000000000
connectors: [vegeta]
vegeta:
  duration: 5m
  rate: 50/1s

%package -n python3-servox
Summary:	Opsani Servo: The Next Generation
Provides:	python-servox
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-servox
optimizer:
  id: newco.com/awesome-app1
  token: 00000000-0000-0000-0000-000000000000
connectors: [vegeta]
vegeta:
  duration: 5m
  rate: 50/1s

%package help
Summary:	Development documents and examples for servox
Provides:	python3-servox-doc
%description help
optimizer:
  id: newco.com/awesome-app1
  token: 00000000-0000-0000-0000-000000000000
connectors: [vegeta]
vegeta:
  duration: 5m
  rate: 50/1s

%prep
%autosetup -n servox-2.2.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-servox -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 2.2.4-1
- Package Spec generated