%global _empty_manifest_terminate_build 0
Name:		python-jupyterhub-naasauthenticator
Version:	0.7.2
Release:	1
Summary:	JupyterHub Native Authenticator
License:	3 Clause BSD
URL:		https://github.com/cashstory/naasauthenticator
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/0d/24/5a0f17f8f57d7c24989901a7279a98c717669e91fc170f8573e5109e4a94/jupyterhub-naasauthenticator-0.7.2.tar.gz
BuildArch:	noarch


%description
# Naas Authenticator

Naas Authenticator provides the following features:

* New users can signup on the system;
* New users can be blocked of accessing the system and need an admin authorization;
* Option of increase password security by avoiding common passwords or minimum password length;
* Option to block users after a number attempts of login;
* Option of open signup and no need for initial authorization;
* Option of open change password (open_change_password);
* Option of adding more information about users on signup.


## Documentation

Documentation is available [here](https://naas-authenticator.readthedocs.io)


## Running tests

To run the tests locally, you can install the development dependencies:

`$ pip install -e '.[dev]'`

Then run tests with pytest:

`$ pytest`

%package -n python3-jupyterhub-naasauthenticator
Summary:	JupyterHub Native Authenticator
Provides:	python-jupyterhub-naasauthenticator
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-jupyterhub-naasauthenticator
# Naas Authenticator

Naas Authenticator provides the following features:

* New users can signup on the system;
* New users can be blocked of accessing the system and need an admin authorization;
* Option of increase password security by avoiding common passwords or minimum password length;
* Option to block users after a number attempts of login;
* Option of open signup and no need for initial authorization;
* Option of open change password (open_change_password);
* Option of adding more information about users on signup.


## Documentation

Documentation is available [here](https://naas-authenticator.readthedocs.io)


## Running tests

To run the tests locally, you can install the development dependencies:

`$ pip install -e '.[dev]'`

Then run tests with pytest:

`$ pytest`

%package help
Summary:	Development documents and examples for jupyterhub-naasauthenticator
Provides:	python3-jupyterhub-naasauthenticator-doc
%description help
# Naas Authenticator

Naas Authenticator provides the following features:

* New users can signup on the system;
* New users can be blocked of accessing the system and need an admin authorization;
* Option of increase password security by avoiding common passwords or minimum password length;
* Option to block users after a number attempts of login;
* Option of open signup and no need for initial authorization;
* Option of open change password (open_change_password);
* Option of adding more information about users on signup.


## Documentation

Documentation is available [here](https://naas-authenticator.readthedocs.io)


## Running tests

To run the tests locally, you can install the development dependencies:

`$ pip install -e '.[dev]'`

Then run tests with pytest:

`$ pytest`

%prep
%autosetup -n jupyterhub-naasauthenticator-0.7.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-jupyterhub-naasauthenticator -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.2-1
- Package Spec generated