%global _empty_manifest_terminate_build 0
Name:		python-islatu
Version:	1.0.7
Release:	1
Summary:	A package for the reduction of reflectometry data.
License:	MIT
URL:		https://pypi.org/project/islatu/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/35/50/0d17fc7d6544f4801b06147602904c96df7c92bef3efe0ac33bfe84089a9/islatu-1.0.7.tar.gz
BuildArch:	noarch

Requires:	python3-wheel
Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-coverage
Requires:	python3-pandas
Requires:	python3-pyyaml
Requires:	python3-nexusformat
Requires:	python3-pytest
Requires:	python3-pytest-lazy-fixture
Requires:	python3-nbsphinx
Requires:	python3-jupyter-sphinx
Requires:	python3-jupyterlab
Requires:	python3-ipywidgets
Requires:	python3-pytest-cov

%description
# islatu

X-ray reflectometry reduction from Diamond Light Source

[![codecov](https://codecov.io/gh/RBrearton/islatu/branch/master/graph/badge.svg?token=FGIV0MVHS8)](https://codecov.io/gh/RBrearton/islatu)
[![Actions Status](https://github.com/RBrearton/islatu/workflows/pytest/badge.svg)](https://github.com/pytest/islatu/actions)
[![Documentation Status](https://readthedocs.org/projects/islatu/badge/?version=latest)](https://islatu.readthedocs.io/en/latest/?badge=latest)

### Install

This package can be easily installed using `pip install islatu`.

### Installation from source

To install in a fresh environment, first ensure that pip is available. For
example, using conda:

```
conda create --name islatu
conda activate islatu
conda install pip
```

Assuming that pip is available, installation of the library from source can be
done by cloning this repository. Navigate to its directory and use pip to
install this package and its dependencies as follows:

```
python -m pip install . -r requirements.txt
```

Make sure that your installation is functioning by running `pytest`.

### Documentation

The documentation for this package can be found at https://islatu.readthedocs.io/en/latest/

An example of a typical data reduction workflow can be found at https://islatu.readthedocs.io/en/latest/i07_reflectivity.html

To build the documentation, make sure you have sphinx installed on your system.
Go to the docs directory and run

```
make html
```


%package -n python3-islatu
Summary:	A package for the reduction of reflectometry data.
Provides:	python-islatu
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-islatu
# islatu

X-ray reflectometry reduction from Diamond Light Source

[![codecov](https://codecov.io/gh/RBrearton/islatu/branch/master/graph/badge.svg?token=FGIV0MVHS8)](https://codecov.io/gh/RBrearton/islatu)
[![Actions Status](https://github.com/RBrearton/islatu/workflows/pytest/badge.svg)](https://github.com/pytest/islatu/actions)
[![Documentation Status](https://readthedocs.org/projects/islatu/badge/?version=latest)](https://islatu.readthedocs.io/en/latest/?badge=latest)

### Install

This package can be easily installed using `pip install islatu`.

### Installation from source

To install in a fresh environment, first ensure that pip is available. For
example, using conda:

```
conda create --name islatu
conda activate islatu
conda install pip
```

Assuming that pip is available, installation of the library from source can be
done by cloning this repository. Navigate to its directory and use pip to
install this package and its dependencies as follows:

```
python -m pip install . -r requirements.txt
```

Make sure that your installation is functioning by running `pytest`.

### Documentation

The documentation for this package can be found at https://islatu.readthedocs.io/en/latest/

An example of a typical data reduction workflow can be found at https://islatu.readthedocs.io/en/latest/i07_reflectivity.html

To build the documentation, make sure you have sphinx installed on your system.
Go to the docs directory and run

```
make html
```


%package help
Summary:	Development documents and examples for islatu
Provides:	python3-islatu-doc
%description help
# islatu

X-ray reflectometry reduction from Diamond Light Source

[![codecov](https://codecov.io/gh/RBrearton/islatu/branch/master/graph/badge.svg?token=FGIV0MVHS8)](https://codecov.io/gh/RBrearton/islatu)
[![Actions Status](https://github.com/RBrearton/islatu/workflows/pytest/badge.svg)](https://github.com/pytest/islatu/actions)
[![Documentation Status](https://readthedocs.org/projects/islatu/badge/?version=latest)](https://islatu.readthedocs.io/en/latest/?badge=latest)

### Install

This package can be easily installed using `pip install islatu`.

### Installation from source

To install in a fresh environment, first ensure that pip is available. For
example, using conda:

```
conda create --name islatu
conda activate islatu
conda install pip
```

Assuming that pip is available, installation of the library from source can be
done by cloning this repository. Navigate to its directory and use pip to
install this package and its dependencies as follows:

```
python -m pip install . -r requirements.txt
```

Make sure that your installation is functioning by running `pytest`.

### Documentation

The documentation for this package can be found at https://islatu.readthedocs.io/en/latest/

An example of a typical data reduction workflow can be found at https://islatu.readthedocs.io/en/latest/i07_reflectivity.html

To build the documentation, make sure you have sphinx installed on your system.
Go to the docs directory and run

```
make html
```


%prep
%autosetup -n islatu-1.0.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-islatu -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.7-1
- Package Spec generated