%global _empty_manifest_terminate_build 0
Name:		python-matchms
Version:	0.19.0
Release:	1
Summary:	Python library for large-scale comparisons and processing of tandem mass spectral data
License:	Apache Software License 2.0
URL:		https://github.com/matchms/matchms
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/3e/c3/880004c8039f2b609463e84f37e3841ddeab34d71b3a65b26cc5551cde33/matchms-0.19.0.tar.gz
BuildArch:	noarch

Requires:	python3-deprecated
Requires:	python3-lxml
Requires:	python3-matplotlib
Requires:	python3-networkx
Requires:	python3-numba
Requires:	python3-numpy
Requires:	python3-pickydict
Requires:	python3-pillow
Requires:	python3-pyteomics
Requires:	python3-requests
Requires:	python3-scipy
Requires:	python3-sparsestack
Requires:	python3-tqdm
Requires:	python3-rdkit
Requires:	python3-bump2version
Requires:	python3-decorator
Requires:	python3-isort
Requires:	python3-pylint
Requires:	python3-prospector[with_pyroma]
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-sphinx
Requires:	python3-sphinx-rtd-theme
Requires:	python3-sphinxcontrib-apidoc
Requires:	python3-testfixtures
Requires:	python3-yapf

%description
To make typical matchms workflows (data import, processing, score computations) more accessible to users, matchms now offers a `Pipeline` class to handle complex workflows. This also allows to define, import, export, or modify workflows using yaml files. See code examples below (and soon: updated tutorial).

%package -n python3-matchms
Summary:	Python library for large-scale comparisons and processing of tandem mass spectral data
Provides:	python-matchms
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-matchms
To make typical matchms workflows (data import, processing, score computations) more accessible to users, matchms now offers a `Pipeline` class to handle complex workflows. This also allows to define, import, export, or modify workflows using yaml files. See code examples below (and soon: updated tutorial).

%package help
Summary:	Development documents and examples for matchms
Provides:	python3-matchms-doc
%description help
To make typical matchms workflows (data import, processing, score computations) more accessible to users, matchms now offers a `Pipeline` class to handle complex workflows. This also allows to define, import, export, or modify workflows using yaml files. See code examples below (and soon: updated tutorial).

%prep
%autosetup -n matchms-0.19.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-matchms -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.19.0-1
- Package Spec generated