%global _empty_manifest_terminate_build 0
Name: python-ridgeplot
Version: 0.1.21
Release: 1
Summary: Beautiful ridgeline plots in python
License: MIT
URL: https://github.com/tpvasconcelos/ridgeplot
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/53/26/69baca59a24b98054a742575b24c064bca717a30134401bceecae4c14564/ridgeplot-0.1.21.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-plotly
Requires: python3-statsmodels
%description
ridgeplot: beautiful ridgeline plots in Python
______________________________________________________________________
The `ridgeplot` python library aims at providing a simple API for plotting beautiful
[ridgeline plots](https://www.data-to-viz.com/graph/ridgeline.html) within the extensive
[Plotly](https://plotly.com/python/) interactive graphing environment.
Bumper stickers:
- Do one thing, and do it well!
- Use sensible defaults, but allow for extensive configuration!
## How to get it?
The source code is currently hosted on GitHub at:
Install and update using [pip](https://pip.pypa.io/en/stable/quickstart/):
```shell
pip install -U ridgeplot
```
### Dependencies
- [plotly](https://plotly.com/) - the interactive graphing backend that powers `ridgeplot`
- [statsmodels](https://www.statsmodels.org/) - Used for Kernel Density Estimation (KDE)
- [numpy](https://numpy.org/) - Supporting library for multi-dimensional array manipulations
## How to use it?
The official docs can be found at: https://ridgeplot.readthedocs.io/en/stable/
### Sensible defaults
```python
import numpy as np
from ridgeplot import ridgeplot
# Put your real samples here...
np.random.seed(0)
synthetic_samples = [np.random.normal(n / 1.2, size=600) for n in range(9, 0, -1)]
# Call the `ridgeplot()` helper, packed with sensible defaults
fig = ridgeplot(samples=synthetic_samples)
# The returned Plotly `Figure` is still fully customizable
fig.update_layout(height=500, width=800)
# show us the work!
fig.show()
```
![ridgeline plot example using the ridgeplot Python library](docs/_static/img/example_simple.png)
### Fully configurable
In this example, we will be replicating the first ridgeline plot example in
[this _from Data to Viz_ post](https://www.data-to-viz.com/graph/ridgeline.html), which uses the
_probly_ dataset. You can find the _plobly_ dataset on multiple sources like in the
[bokeh](https://raw.githubusercontent.com/bokeh/bokeh/17a0b288052afac80ebcf0aa74e3915452fce3ca/src/bokeh/sampledata/_data/probly.csv)
python interactive visualization library. I'll be using the
[same source](https://raw.githubusercontent.com/zonination/perceptions/51207062aa173777264d3acce0131e1e2456d966/probly.csv)
used in the original post.
```python
import numpy as np
from ridgeplot import ridgeplot
from ridgeplot.datasets import load_probly
# Load the probly dataset
df = load_probly()
# Let's grab only the subset of columns displayed in the example
column_names = [
"Almost Certainly", "Very Good Chance", "We Believe", "Likely",
"About Even", "Little Chance", "Chances Are Slight", "Almost No Chance",
] # fmt: skip
df = df[column_names]
# Not only does 'ridgeplot(...)' come configured with sensible defaults
# but is also fully configurable to your own style and preference!
fig = ridgeplot(
samples=df.values.T,
bandwidth=4,
kde_points=np.linspace(-12.5, 112.5, 400),
colorscale="viridis",
colormode="index",
coloralpha=0.6,
labels=column_names,
spacing=5 / 9,
)
# Again, update the figure layout to your liking here
fig.update_layout(
title="What probability would you assign to the phrase “Highly likely”?",
height=650,
width=800,
plot_bgcolor="rgba(255, 255, 255, 0.0)",
xaxis_gridcolor="rgba(0, 0, 0, 0.1)",
yaxis_gridcolor="rgba(0, 0, 0, 0.1)",
yaxis_title="Assigned Probability (%)",
)
fig.show()
```
![ridgeline plot of the probly dataset using the ridgeplot Python library](docs/_static/img/example_probly.png)
%package -n python3-ridgeplot
Summary: Beautiful ridgeline plots in python
Provides: python-ridgeplot
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ridgeplot
ridgeplot: beautiful ridgeline plots in Python
______________________________________________________________________
The `ridgeplot` python library aims at providing a simple API for plotting beautiful
[ridgeline plots](https://www.data-to-viz.com/graph/ridgeline.html) within the extensive
[Plotly](https://plotly.com/python/) interactive graphing environment.
Bumper stickers:
- Do one thing, and do it well!
- Use sensible defaults, but allow for extensive configuration!
## How to get it?
The source code is currently hosted on GitHub at:
Install and update using [pip](https://pip.pypa.io/en/stable/quickstart/):
```shell
pip install -U ridgeplot
```
### Dependencies
- [plotly](https://plotly.com/) - the interactive graphing backend that powers `ridgeplot`
- [statsmodels](https://www.statsmodels.org/) - Used for Kernel Density Estimation (KDE)
- [numpy](https://numpy.org/) - Supporting library for multi-dimensional array manipulations
## How to use it?
The official docs can be found at: https://ridgeplot.readthedocs.io/en/stable/
### Sensible defaults
```python
import numpy as np
from ridgeplot import ridgeplot
# Put your real samples here...
np.random.seed(0)
synthetic_samples = [np.random.normal(n / 1.2, size=600) for n in range(9, 0, -1)]
# Call the `ridgeplot()` helper, packed with sensible defaults
fig = ridgeplot(samples=synthetic_samples)
# The returned Plotly `Figure` is still fully customizable
fig.update_layout(height=500, width=800)
# show us the work!
fig.show()
```
![ridgeline plot example using the ridgeplot Python library](docs/_static/img/example_simple.png)
### Fully configurable
In this example, we will be replicating the first ridgeline plot example in
[this _from Data to Viz_ post](https://www.data-to-viz.com/graph/ridgeline.html), which uses the
_probly_ dataset. You can find the _plobly_ dataset on multiple sources like in the
[bokeh](https://raw.githubusercontent.com/bokeh/bokeh/17a0b288052afac80ebcf0aa74e3915452fce3ca/src/bokeh/sampledata/_data/probly.csv)
python interactive visualization library. I'll be using the
[same source](https://raw.githubusercontent.com/zonination/perceptions/51207062aa173777264d3acce0131e1e2456d966/probly.csv)
used in the original post.
```python
import numpy as np
from ridgeplot import ridgeplot
from ridgeplot.datasets import load_probly
# Load the probly dataset
df = load_probly()
# Let's grab only the subset of columns displayed in the example
column_names = [
"Almost Certainly", "Very Good Chance", "We Believe", "Likely",
"About Even", "Little Chance", "Chances Are Slight", "Almost No Chance",
] # fmt: skip
df = df[column_names]
# Not only does 'ridgeplot(...)' come configured with sensible defaults
# but is also fully configurable to your own style and preference!
fig = ridgeplot(
samples=df.values.T,
bandwidth=4,
kde_points=np.linspace(-12.5, 112.5, 400),
colorscale="viridis",
colormode="index",
coloralpha=0.6,
labels=column_names,
spacing=5 / 9,
)
# Again, update the figure layout to your liking here
fig.update_layout(
title="What probability would you assign to the phrase “Highly likely”?",
height=650,
width=800,
plot_bgcolor="rgba(255, 255, 255, 0.0)",
xaxis_gridcolor="rgba(0, 0, 0, 0.1)",
yaxis_gridcolor="rgba(0, 0, 0, 0.1)",
yaxis_title="Assigned Probability (%)",
)
fig.show()
```
![ridgeline plot of the probly dataset using the ridgeplot Python library](docs/_static/img/example_probly.png)
%package help
Summary: Development documents and examples for ridgeplot
Provides: python3-ridgeplot-doc
%description help
ridgeplot: beautiful ridgeline plots in Python
______________________________________________________________________
The `ridgeplot` python library aims at providing a simple API for plotting beautiful
[ridgeline plots](https://www.data-to-viz.com/graph/ridgeline.html) within the extensive
[Plotly](https://plotly.com/python/) interactive graphing environment.
Bumper stickers:
- Do one thing, and do it well!
- Use sensible defaults, but allow for extensive configuration!
## How to get it?
The source code is currently hosted on GitHub at:
Install and update using [pip](https://pip.pypa.io/en/stable/quickstart/):
```shell
pip install -U ridgeplot
```
### Dependencies
- [plotly](https://plotly.com/) - the interactive graphing backend that powers `ridgeplot`
- [statsmodels](https://www.statsmodels.org/) - Used for Kernel Density Estimation (KDE)
- [numpy](https://numpy.org/) - Supporting library for multi-dimensional array manipulations
## How to use it?
The official docs can be found at: https://ridgeplot.readthedocs.io/en/stable/
### Sensible defaults
```python
import numpy as np
from ridgeplot import ridgeplot
# Put your real samples here...
np.random.seed(0)
synthetic_samples = [np.random.normal(n / 1.2, size=600) for n in range(9, 0, -1)]
# Call the `ridgeplot()` helper, packed with sensible defaults
fig = ridgeplot(samples=synthetic_samples)
# The returned Plotly `Figure` is still fully customizable
fig.update_layout(height=500, width=800)
# show us the work!
fig.show()
```
![ridgeline plot example using the ridgeplot Python library](docs/_static/img/example_simple.png)
### Fully configurable
In this example, we will be replicating the first ridgeline plot example in
[this _from Data to Viz_ post](https://www.data-to-viz.com/graph/ridgeline.html), which uses the
_probly_ dataset. You can find the _plobly_ dataset on multiple sources like in the
[bokeh](https://raw.githubusercontent.com/bokeh/bokeh/17a0b288052afac80ebcf0aa74e3915452fce3ca/src/bokeh/sampledata/_data/probly.csv)
python interactive visualization library. I'll be using the
[same source](https://raw.githubusercontent.com/zonination/perceptions/51207062aa173777264d3acce0131e1e2456d966/probly.csv)
used in the original post.
```python
import numpy as np
from ridgeplot import ridgeplot
from ridgeplot.datasets import load_probly
# Load the probly dataset
df = load_probly()
# Let's grab only the subset of columns displayed in the example
column_names = [
"Almost Certainly", "Very Good Chance", "We Believe", "Likely",
"About Even", "Little Chance", "Chances Are Slight", "Almost No Chance",
] # fmt: skip
df = df[column_names]
# Not only does 'ridgeplot(...)' come configured with sensible defaults
# but is also fully configurable to your own style and preference!
fig = ridgeplot(
samples=df.values.T,
bandwidth=4,
kde_points=np.linspace(-12.5, 112.5, 400),
colorscale="viridis",
colormode="index",
coloralpha=0.6,
labels=column_names,
spacing=5 / 9,
)
# Again, update the figure layout to your liking here
fig.update_layout(
title="What probability would you assign to the phrase “Highly likely”?",
height=650,
width=800,
plot_bgcolor="rgba(255, 255, 255, 0.0)",
xaxis_gridcolor="rgba(0, 0, 0, 0.1)",
yaxis_gridcolor="rgba(0, 0, 0, 0.1)",
yaxis_title="Assigned Probability (%)",
)
fig.show()
```
![ridgeline plot of the probly dataset using the ridgeplot Python library](docs/_static/img/example_probly.png)
%prep
%autosetup -n ridgeplot-0.1.21
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ridgeplot -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.1.21-1
- Package Spec generated