%global _empty_manifest_terminate_build 0
Name:		python-django-sp
Version:	1.17.0
Release:	1
Summary:	Django application for custom Social Profile Auth and User model.
License:	MIT License
URL:		https://github.com/DLRSP/django-sp
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/9b/bc/9c0e5b43a7406bf92eb5fea14a9d795d583628ee677d216a196f18c0d281/django-sp-1.17.0.tar.gz
BuildArch:	noarch

Requires:	python3-django-errors
Requires:	python3-social-auth
Requires:	python3-social-auth-app-django
Requires:	python3-django-otp
Requires:	python3-django-two-factor-auth
Requires:	python3-django-oauth-toolkit
Requires:	python3-djangorestframework
Requires:	python3-easy-thumbnails
Requires:	python3-django-cors-headers
Requires:	python3-geoip2
Requires:	python3-django-user-sessions
Requires:	python3-django-axes
Requires:	python3-phonenumbers
Requires:	python3-django-phonenumber-field
Requires:	python3-django-image-cropping
Requires:	python3-django-countries
Requires:	python3-django-crispy-forms
Requires:	python3-sweetify
Requires:	python3-flake8
Requires:	python3-pylint
Requires:	python3-coverage
Requires:	python3-codecov

%description
# django-sp [![PyPi license](https://img.shields.io/pypi/l/django-sp.svg)](https://pypi.python.org/pypi/django_sp)

## Pypi [![PyPi status](https://img.shields.io/pypi/status/django-sp.svg)](https://pypi.python.org/pypi/django_ps) [![PyPi version](https://img.shields.io/pypi/v/django-sp.svg)](https://pypi.python.org/pypi/django_sp) [![PyPi python version](https://img.shields.io/pypi/pyversions/django-sp.svg)](https://pypi.python.org/pypi/django_sp) [![PyPi downloads](https://img.shields.io/pypi/dm/django-sp.svg)](https://pypi.python.org/pypi/django_sp) [![PyPi downloads](https://img.shields.io/pypi/dw/django-sp.svg)](https://pypi.python.org/pypi/django_sp) [![PyPi downloads](https://img.shields.io/pypi/dd/django-sp.svg)](https://pypi.python.org/pypi/django_sp)

	$ pip install django-sp

## GitHub ![GitHub release](https://img.shields.io/github/tag/DLRSP/django-sp.svg) ![GitHub release](https://img.shields.io/github/release/DLRSP/django-sp.svg)

## Test [![codecov.io](https://codecov.io/github/DLRSP/django-sp/coverage.svg?branch=master)](https://codecov.io/github/DLRSP/django-sp?branch=master)

Report Issues with [***waffle.io***](https://waffle.io/DLRSP/django-sp/join)

## Run Example Project

	$ git clone https://github.com/DLRSP/example -b django-sp
	$ cd example
	$ python manage.py runserver

Now you browser the app @ http://127.0.0.1:8000


%package -n python3-django-sp
Summary:	Django application for custom Social Profile Auth and User model.
Provides:	python-django-sp
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-sp
# django-sp [![PyPi license](https://img.shields.io/pypi/l/django-sp.svg)](https://pypi.python.org/pypi/django_sp)

## Pypi [![PyPi status](https://img.shields.io/pypi/status/django-sp.svg)](https://pypi.python.org/pypi/django_ps) [![PyPi version](https://img.shields.io/pypi/v/django-sp.svg)](https://pypi.python.org/pypi/django_sp) [![PyPi python version](https://img.shields.io/pypi/pyversions/django-sp.svg)](https://pypi.python.org/pypi/django_sp) [![PyPi downloads](https://img.shields.io/pypi/dm/django-sp.svg)](https://pypi.python.org/pypi/django_sp) [![PyPi downloads](https://img.shields.io/pypi/dw/django-sp.svg)](https://pypi.python.org/pypi/django_sp) [![PyPi downloads](https://img.shields.io/pypi/dd/django-sp.svg)](https://pypi.python.org/pypi/django_sp)

	$ pip install django-sp

## GitHub ![GitHub release](https://img.shields.io/github/tag/DLRSP/django-sp.svg) ![GitHub release](https://img.shields.io/github/release/DLRSP/django-sp.svg)

## Test [![codecov.io](https://codecov.io/github/DLRSP/django-sp/coverage.svg?branch=master)](https://codecov.io/github/DLRSP/django-sp?branch=master)

Report Issues with [***waffle.io***](https://waffle.io/DLRSP/django-sp/join)

## Run Example Project

	$ git clone https://github.com/DLRSP/example -b django-sp
	$ cd example
	$ python manage.py runserver

Now you browser the app @ http://127.0.0.1:8000


%package help
Summary:	Development documents and examples for django-sp
Provides:	python3-django-sp-doc
%description help
# django-sp [![PyPi license](https://img.shields.io/pypi/l/django-sp.svg)](https://pypi.python.org/pypi/django_sp)

## Pypi [![PyPi status](https://img.shields.io/pypi/status/django-sp.svg)](https://pypi.python.org/pypi/django_ps) [![PyPi version](https://img.shields.io/pypi/v/django-sp.svg)](https://pypi.python.org/pypi/django_sp) [![PyPi python version](https://img.shields.io/pypi/pyversions/django-sp.svg)](https://pypi.python.org/pypi/django_sp) [![PyPi downloads](https://img.shields.io/pypi/dm/django-sp.svg)](https://pypi.python.org/pypi/django_sp) [![PyPi downloads](https://img.shields.io/pypi/dw/django-sp.svg)](https://pypi.python.org/pypi/django_sp) [![PyPi downloads](https://img.shields.io/pypi/dd/django-sp.svg)](https://pypi.python.org/pypi/django_sp)

	$ pip install django-sp

## GitHub ![GitHub release](https://img.shields.io/github/tag/DLRSP/django-sp.svg) ![GitHub release](https://img.shields.io/github/release/DLRSP/django-sp.svg)

## Test [![codecov.io](https://codecov.io/github/DLRSP/django-sp/coverage.svg?branch=master)](https://codecov.io/github/DLRSP/django-sp?branch=master)

Report Issues with [***waffle.io***](https://waffle.io/DLRSP/django-sp/join)

## Run Example Project

	$ git clone https://github.com/DLRSP/example -b django-sp
	$ cd example
	$ python manage.py runserver

Now you browser the app @ http://127.0.0.1:8000


%prep
%autosetup -n django-sp-1.17.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-sp -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 1.17.0-1
- Package Spec generated