%global _empty_manifest_terminate_build 0
Name: python-Airshare
Version: 0.1.6
Release: 1
Summary: Cross-platform content sharing in a local network.
License: MIT License
URL: https://github.com/KuroLabs/airshare
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cb/a2/d59c18cd6a143bf860c29acb70552b7351fd7e0f56213be86b624601106b/Airshare-0.1.6.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-asyncio
Requires: python3-click
Requires: python3-colorama
Requires: python3-humanize
Requires: python3-pyperclip
Requires: python3-requests
Requires: python3-requests-toolbelt
Requires: python3-termcolor
Requires: python3-tqdm
Requires: python3-zeroconf
%description
Airshare
Cross-platform content sharing in a local network.
Airshare is a Python-based CLI tool and module that lets you transfer data between two machines in a local network, P2P, using Multicast-DNS. It also opens an HTTP gateway for other non-CLI external interfaces. It works completely offline! Built with aiohttp and zeroconf.
## Features
* Blazing fast content transfer within a local network.
* Lets you transfer plain text, send from or receive into your clipboard.
* Supports transfer of multiple files, directories and large files - content is sent chun$
* Lets you send files whose paths have been copied into the clipboard (more details in th$
* Cross-platform, works on Linux, Windows and Mac (CLI and Web Interface), and also suppo$
* Uses Multicast-DNS service registration and discovery - so you can access content with $
* Can be used as a module in other Python programs.
## Important Links
Source Code: https://github.com/KuroLabs/Airshare
Bug Reports: https://github.com/KuroLabs/Airshare/issues
Documentation: https://airshare.rtfd.io
PyPI: https://pypi.org/project/Airshare
## Installation
* Install using `pip`
```bash
$ pip install Airshare
```
* Install using `pipx`
```bash
$ pipx install Airshare
```
* Install using Homebrew
```bash
$ brew install airshare
```
## Example
Send and receive files and directories.
To send using the CLI,
```bash
$ airshare noobmaster requirements.txt
```
To receive using the CLI,
```bash
$ airshare noobmaster
```
or visit `http://noobmaster.local:8000` in the browser to download.
You can also `import airshare` in any Python program. Visit the documentation for detailed usage instructions.
## Known Issues
* Link-local Name Resolution (for the `.local` addresses) on non-Apple devices requires Avahi (on Linux) or Bonjour (on Windows). Chances are you already have them, but if you don't, do check the web on how to install them.
* Android browsers do not have inbuilt Multicast-DNS service discovery, and cannot resolve the `.local` addresses. For this reason, we included QR Code support, for you to visit the URLs easily.
* Windows users with Python < 3.8, use Ctrl + Break to quit, as Ctrl + C will not work. This is a known issue with `asyncio`, which has been fixed in Python 3.8. If you do not have a Break key, try using Ctrl + Fn + B, or check the web for other alternatives (depending on your PC).
## Contributing
Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.
## License
[MIT](https://github.com/KuroLabs/Airshare/blob/master/LICENSE.md) - Copyright (c) 2020 [Kandavel A](http://github.com/AK5123), [Mohanasundar M](https://github.com/mohanpierce99), [Nanda H Krishna](https://github.com/nandahkrishna)
## Acknowledgements
The Airshare logo was designed by [Siddique](https://dribbble.com/thesideeq).
The Airshare GIF was created by [Anam Saatvik](https://github.com/kalki7).
%package -n python3-Airshare
Summary: Cross-platform content sharing in a local network.
Provides: python-Airshare
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Airshare
Airshare
Cross-platform content sharing in a local network.
Airshare is a Python-based CLI tool and module that lets you transfer data between two machines in a local network, P2P, using Multicast-DNS. It also opens an HTTP gateway for other non-CLI external interfaces. It works completely offline! Built with aiohttp and zeroconf.
## Features
* Blazing fast content transfer within a local network.
* Lets you transfer plain text, send from or receive into your clipboard.
* Supports transfer of multiple files, directories and large files - content is sent chun$
* Lets you send files whose paths have been copied into the clipboard (more details in th$
* Cross-platform, works on Linux, Windows and Mac (CLI and Web Interface), and also suppo$
* Uses Multicast-DNS service registration and discovery - so you can access content with $
* Can be used as a module in other Python programs.
## Important Links
Source Code: https://github.com/KuroLabs/Airshare
Bug Reports: https://github.com/KuroLabs/Airshare/issues
Documentation: https://airshare.rtfd.io
PyPI: https://pypi.org/project/Airshare
## Installation
* Install using `pip`
```bash
$ pip install Airshare
```
* Install using `pipx`
```bash
$ pipx install Airshare
```
* Install using Homebrew
```bash
$ brew install airshare
```
## Example
Send and receive files and directories.
To send using the CLI,
```bash
$ airshare noobmaster requirements.txt
```
To receive using the CLI,
```bash
$ airshare noobmaster
```
or visit `http://noobmaster.local:8000` in the browser to download.
You can also `import airshare` in any Python program. Visit the documentation for detailed usage instructions.
## Known Issues
* Link-local Name Resolution (for the `.local` addresses) on non-Apple devices requires Avahi (on Linux) or Bonjour (on Windows). Chances are you already have them, but if you don't, do check the web on how to install them.
* Android browsers do not have inbuilt Multicast-DNS service discovery, and cannot resolve the `.local` addresses. For this reason, we included QR Code support, for you to visit the URLs easily.
* Windows users with Python < 3.8, use Ctrl + Break to quit, as Ctrl + C will not work. This is a known issue with `asyncio`, which has been fixed in Python 3.8. If you do not have a Break key, try using Ctrl + Fn + B, or check the web for other alternatives (depending on your PC).
## Contributing
Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.
## License
[MIT](https://github.com/KuroLabs/Airshare/blob/master/LICENSE.md) - Copyright (c) 2020 [Kandavel A](http://github.com/AK5123), [Mohanasundar M](https://github.com/mohanpierce99), [Nanda H Krishna](https://github.com/nandahkrishna)
## Acknowledgements
The Airshare logo was designed by [Siddique](https://dribbble.com/thesideeq).
The Airshare GIF was created by [Anam Saatvik](https://github.com/kalki7).
%package help
Summary: Development documents and examples for Airshare
Provides: python3-Airshare-doc
%description help
Airshare
Cross-platform content sharing in a local network.
Airshare is a Python-based CLI tool and module that lets you transfer data between two machines in a local network, P2P, using Multicast-DNS. It also opens an HTTP gateway for other non-CLI external interfaces. It works completely offline! Built with aiohttp and zeroconf.
## Features
* Blazing fast content transfer within a local network.
* Lets you transfer plain text, send from or receive into your clipboard.
* Supports transfer of multiple files, directories and large files - content is sent chun$
* Lets you send files whose paths have been copied into the clipboard (more details in th$
* Cross-platform, works on Linux, Windows and Mac (CLI and Web Interface), and also suppo$
* Uses Multicast-DNS service registration and discovery - so you can access content with $
* Can be used as a module in other Python programs.
## Important Links
Source Code: https://github.com/KuroLabs/Airshare
Bug Reports: https://github.com/KuroLabs/Airshare/issues
Documentation: https://airshare.rtfd.io
PyPI: https://pypi.org/project/Airshare
## Installation
* Install using `pip`
```bash
$ pip install Airshare
```
* Install using `pipx`
```bash
$ pipx install Airshare
```
* Install using Homebrew
```bash
$ brew install airshare
```
## Example
Send and receive files and directories.
To send using the CLI,
```bash
$ airshare noobmaster requirements.txt
```
To receive using the CLI,
```bash
$ airshare noobmaster
```
or visit `http://noobmaster.local:8000` in the browser to download.
You can also `import airshare` in any Python program. Visit the documentation for detailed usage instructions.
## Known Issues
* Link-local Name Resolution (for the `.local` addresses) on non-Apple devices requires Avahi (on Linux) or Bonjour (on Windows). Chances are you already have them, but if you don't, do check the web on how to install them.
* Android browsers do not have inbuilt Multicast-DNS service discovery, and cannot resolve the `.local` addresses. For this reason, we included QR Code support, for you to visit the URLs easily.
* Windows users with Python < 3.8, use Ctrl + Break to quit, as Ctrl + C will not work. This is a known issue with `asyncio`, which has been fixed in Python 3.8. If you do not have a Break key, try using Ctrl + Fn + B, or check the web for other alternatives (depending on your PC).
## Contributing
Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.
## License
[MIT](https://github.com/KuroLabs/Airshare/blob/master/LICENSE.md) - Copyright (c) 2020 [Kandavel A](http://github.com/AK5123), [Mohanasundar M](https://github.com/mohanpierce99), [Nanda H Krishna](https://github.com/nandahkrishna)
## Acknowledgements
The Airshare logo was designed by [Siddique](https://dribbble.com/thesideeq).
The Airshare GIF was created by [Anam Saatvik](https://github.com/kalki7).
%prep
%autosetup -n Airshare-0.1.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Airshare -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.1.6-1
- Package Spec generated