%global _empty_manifest_terminate_build 0
Name:		python-asbool
Version:	0.2
Release:	1
Summary:	simple converter from ``str`` to ``bool``
License:	MIT,
URL:		https://github.com/aodag/asbool
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/99/0e/2c40bf7909e2161c083081a19332bec8e882dc7161b0f47c08ca2c4e25e8/asbool-0.2.tar.gz
BuildArch:	noarch

Requires:	python3-six
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-pytest-randomly

%description


%package -n python3-asbool
Summary:	simple converter from ``str`` to ``bool``
Provides:	python-asbool
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-asbool


%package help
Summary:	Development documents and examples for asbool
Provides:	python3-asbool-doc
%description help


%prep
%autosetup -n asbool-0.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-asbool -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2-1
- Package Spec generated