%global _empty_manifest_terminate_build 0
Name:		python-vault-cli
Version:	3.1.0
Release:	1
Summary:	CLI tool for hashicorp vault
License:	Apache Software License
URL:		https://github.com/peopledoc/vault-cli
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/fe/12/1ec01a454b240c5bc43c574bd8062afdbdf741710eb0bcce1aba009cc964/vault-cli-3.1.0.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-Click
Requires:	python3-pyyaml
Requires:	python3-jinja2
Requires:	python3-hvac
Requires:	python3-tox
Requires:	python3-twine
Requires:	python3-black
Requires:	python3-isort
Requires:	python3-build
Requires:	python3-doc8
Requires:	python3-sphinx
Requires:	python3-sphinx-autodoc-typehints
Requires:	python3-sphinxcontrib-programoutput
Requires:	python3-sphinxcontrib-spelling
Requires:	python3-mypy
Requires:	python3-flake8
Requires:	python3-black
Requires:	python3-isort
Requires:	python3-types-PyYAML
Requires:	python3-types-requests
Requires:	python3-types-setuptools
Requires:	python3-types-toml
Requires:	python3-pytest
Requires:	python3-pytest-mock
Requires:	python3-requests-mock
Requires:	python3-pytest-cov
Requires:	python3-pytest-click
Requires:	python3-pytest

%description
``vault-cli`` is a Python 3.6+ tool that offers simple interactions to manipulate
secrets from `Hashicorp Vault`_. With ``vault-cli``, your secrets can be kept secret,
while following `12-factor`__ principles.

%package -n python3-vault-cli
Summary:	CLI tool for hashicorp vault
Provides:	python-vault-cli
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-vault-cli
``vault-cli`` is a Python 3.6+ tool that offers simple interactions to manipulate
secrets from `Hashicorp Vault`_. With ``vault-cli``, your secrets can be kept secret,
while following `12-factor`__ principles.

%package help
Summary:	Development documents and examples for vault-cli
Provides:	python3-vault-cli-doc
%description help
``vault-cli`` is a Python 3.6+ tool that offers simple interactions to manipulate
secrets from `Hashicorp Vault`_. With ``vault-cli``, your secrets can be kept secret,
while following `12-factor`__ principles.

%prep
%autosetup -n vault-cli-3.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-vault-cli -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 3.1.0-1
- Package Spec generated