%global _empty_manifest_terminate_build 0
Name: python-discord-slash-components-bridge
Version: 0.1.1
Release: 1
Summary: Library for discord-components and discord-py-interactions(discord-slash).
License: MIT License
URL: https://github.com/Damego/discord-py-slash-components-bridge
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/34/7c/ec7bf5fc10eaba5fe69427204b0900fb71460941a6eb9bfefa42590dc2d1/discord_slash_components_bridge-0.1.1.tar.gz
BuildArch: noarch
Requires: python3-discord-components
Requires: python3-discord-py-interactions
%description
discord-py-slash-components-bridge
Bridge for discord-interactions and discord-components
Welcome
[discord-interactions](https://github.com/goverfl0w/discord-interactions) and [discord-components](https://github.com/kiki7000/discord.py-components) are incompatible and this bridge can compatible these libs.
This lib overrides discord-interaction classes and methods for working with discord-components components(Selects and Buttons)
How to use?
```py
from discord.ext import commands
#from discord_slash import SlashCommand # No need anymore
from discord_slash_components_bridge import SlashCommand
bot = commands.Bot(...)
slash = SlashCommand(bot, ...)
```
Migration from discord-components
If you have used this, then I prepared for you some things.
- Events `button_click` and `select_option` have been saved.
- Event `interaction` now is `component`.
- `Interaction` is not available to use. Now it's `ComponentContext` and now you need use methods of `ComponentContext`
%package -n python3-discord-slash-components-bridge
Summary: Library for discord-components and discord-py-interactions(discord-slash).
Provides: python-discord-slash-components-bridge
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-discord-slash-components-bridge
discord-py-slash-components-bridge
Bridge for discord-interactions and discord-components
Welcome
[discord-interactions](https://github.com/goverfl0w/discord-interactions) and [discord-components](https://github.com/kiki7000/discord.py-components) are incompatible and this bridge can compatible these libs.
This lib overrides discord-interaction classes and methods for working with discord-components components(Selects and Buttons)
How to use?
```py
from discord.ext import commands
#from discord_slash import SlashCommand # No need anymore
from discord_slash_components_bridge import SlashCommand
bot = commands.Bot(...)
slash = SlashCommand(bot, ...)
```
Migration from discord-components
If you have used this, then I prepared for you some things.
- Events `button_click` and `select_option` have been saved.
- Event `interaction` now is `component`.
- `Interaction` is not available to use. Now it's `ComponentContext` and now you need use methods of `ComponentContext`
%package help
Summary: Development documents and examples for discord-slash-components-bridge
Provides: python3-discord-slash-components-bridge-doc
%description help
discord-py-slash-components-bridge
Bridge for discord-interactions and discord-components
Welcome
[discord-interactions](https://github.com/goverfl0w/discord-interactions) and [discord-components](https://github.com/kiki7000/discord.py-components) are incompatible and this bridge can compatible these libs.
This lib overrides discord-interaction classes and methods for working with discord-components components(Selects and Buttons)
How to use?
```py
from discord.ext import commands
#from discord_slash import SlashCommand # No need anymore
from discord_slash_components_bridge import SlashCommand
bot = commands.Bot(...)
slash = SlashCommand(bot, ...)
```
Migration from discord-components
If you have used this, then I prepared for you some things.
- Events `button_click` and `select_option` have been saved.
- Event `interaction` now is `component`.
- `Interaction` is not available to use. Now it's `ComponentContext` and now you need use methods of `ComponentContext`
%prep
%autosetup -n discord-slash-components-bridge-0.1.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-discord-slash-components-bridge -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.1.1-1
- Package Spec generated