%global _empty_manifest_terminate_build 0
Name:		python-nsone
Version:	0.9.100
Release:	1
Summary:	Legacy Python SDK for the NS1 DNS platform
License:	MIT
URL:		https://github.com/ns1/nsone-python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ce/e3/a112c8e8cb34e5d493f9e47c8133ef4f14ee6f233d6757dfae168688f35f/nsone-0.9.100.tar.gz
BuildArch:	noarch

Requires:	python3-ns1-python

%description
This SDK is deprecated in favor of `ns1-python <https://github.com/ns1/ns1-python>`_
and should not be used for new projects. The code in this repository provides
just a thin wrapper for the new SDK to allow easier migration.

%package -n python3-nsone
Summary:	Legacy Python SDK for the NS1 DNS platform
Provides:	python-nsone
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-nsone
This SDK is deprecated in favor of `ns1-python <https://github.com/ns1/ns1-python>`_
and should not be used for new projects. The code in this repository provides
just a thin wrapper for the new SDK to allow easier migration.

%package help
Summary:	Development documents and examples for nsone
Provides:	python3-nsone-doc
%description help
This SDK is deprecated in favor of `ns1-python <https://github.com/ns1/ns1-python>`_
and should not be used for new projects. The code in this repository provides
just a thin wrapper for the new SDK to allow easier migration.

%prep
%autosetup -n nsone-0.9.100

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-nsone -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.100-1
- Package Spec generated