%global _empty_manifest_terminate_build 0
Name:		python-turbinia
Version:	20230315
Release:	1
Summary:	Automation and Scaling of Digital Forensics Tools
License:	Apache License, Version 2.0
URL:		http://turbinia.plumbing/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/19/1e/a6239c2b177da7e3c277239d4dbe5a4b982681692125d9e774e3fb3157a4/turbinia-20230315.tar.gz
BuildArch:	noarch


%description
Turbinia is an open-source framework for deploying, managing, and runningforensic workloads on cloud platforms. It is intended to automate running of common forensic processing tools (i.e. Plaso, TSK, strings, etc) to help with processing evidence in the Cloud, scaling the processing of large amounts of evidence, and decreasing response time by parallelizingprocessing where possible.


%package -n python3-turbinia
Summary:	Automation and Scaling of Digital Forensics Tools
Provides:	python-turbinia
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-turbinia
Turbinia is an open-source framework for deploying, managing, and runningforensic workloads on cloud platforms. It is intended to automate running of common forensic processing tools (i.e. Plaso, TSK, strings, etc) to help with processing evidence in the Cloud, scaling the processing of large amounts of evidence, and decreasing response time by parallelizingprocessing where possible.


%package help
Summary:	Development documents and examples for turbinia
Provides:	python3-turbinia-doc
%description help
Turbinia is an open-source framework for deploying, managing, and runningforensic workloads on cloud platforms. It is intended to automate running of common forensic processing tools (i.e. Plaso, TSK, strings, etc) to help with processing evidence in the Cloud, scaling the processing of large amounts of evidence, and decreasing response time by parallelizingprocessing where possible.


%prep
%autosetup -n turbinia-20230315

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-turbinia -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 20230315-1
- Package Spec generated