%global _empty_manifest_terminate_build 0
Name:		python-SpliceV
Version:	0.2.0.0
Release:	1
Summary:	Visualize splice junctions, backsplice junctions (circleRNA) and coverage from RNA-Seq datasets
License:	GNU General Public License v3 (GPLv3)
URL:		https://github.com/flemingtonlab/SpliceV
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/37/33/e33fcc13b73fe050b5c315cdabe27798ce95285b54d2407090db7c5c1ef6/SpliceV-0.2.0.0.tar.gz
BuildArch:	noarch

Requires:	python3-matplotlib
Requires:	python3-numpy
Requires:	python3-pysam

%description
# SpliceV #
Visualize coverage, canonical, and backsplice junctions.

![Example plot](https://github.com/flemingtonlab/SpliceV/blob/master/etc/example.png)

## Documentation ##
See https://splicev.readthedocs.io/en/master/

## Example pipeline ##
See https://github.com/flemingtonlab/SpliceV/blob/master/docs/example.pdf

This will generate figure 1B and 1C from our manuscript (DOI pending)

## Requirements ##
SpliceV works with Python 2.7 and 3.0+.
## Dependencies ##
* Matplotlib
* Numpy
* pysam
## Installation ##
To install SpliceV:

```
pip install SpliceV
```

Or:

```
git clone https://github.com/flemingtonlab/SpliceV.git
```

## Example ##
To run the example dataset:

```
git clone https://github.com/flemingtonlab/SpliceV.git 

cd SpliceV/example 

python ../bin/SpliceV -b example.vta1.bam -gtf vta1.gtf -sj example.canonical.bed -bsj example.circles.bed -g VTA1 -f 3 -is 3

```

The sample data comes from Akata cells (a B Cell Lymphoma line) that were treated with the exonuclease RNase R prior to sequencing. RNase R exclusively digests RNA with a free end, helping enrich circularized RNA abundance in the sample. 

These example commands will generate the following plot:
![User example plot](https://github.com/flemingtonlab/SpliceV/blob/master/etc/vta1.png)

This plot reveals a prominant circle from exon 2 through exon 4 (evidenced by the back-splice junction reads which are plotted as curves below the axis. This is also demonstrated by the higher level of coverage in exon 2-4, shown by the relative intensity of color).

![User example plot explained](https://github.com/flemingtonlab/SpliceV/blob/master/etc/vta1_explained.png)

The major circularized isoform (exons 2-4; another less prevalent circle appears to include exon 5) is isolated below:


![User example circle](https://github.com/flemingtonlab/SpliceV/blob/master/etc/vta1_circ.png)

## Authors ##
Created by Nathan Ungerleider and Erik Flemington




%package -n python3-SpliceV
Summary:	Visualize splice junctions, backsplice junctions (circleRNA) and coverage from RNA-Seq datasets
Provides:	python-SpliceV
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-SpliceV
# SpliceV #
Visualize coverage, canonical, and backsplice junctions.

![Example plot](https://github.com/flemingtonlab/SpliceV/blob/master/etc/example.png)

## Documentation ##
See https://splicev.readthedocs.io/en/master/

## Example pipeline ##
See https://github.com/flemingtonlab/SpliceV/blob/master/docs/example.pdf

This will generate figure 1B and 1C from our manuscript (DOI pending)

## Requirements ##
SpliceV works with Python 2.7 and 3.0+.
## Dependencies ##
* Matplotlib
* Numpy
* pysam
## Installation ##
To install SpliceV:

```
pip install SpliceV
```

Or:

```
git clone https://github.com/flemingtonlab/SpliceV.git
```

## Example ##
To run the example dataset:

```
git clone https://github.com/flemingtonlab/SpliceV.git 

cd SpliceV/example 

python ../bin/SpliceV -b example.vta1.bam -gtf vta1.gtf -sj example.canonical.bed -bsj example.circles.bed -g VTA1 -f 3 -is 3

```

The sample data comes from Akata cells (a B Cell Lymphoma line) that were treated with the exonuclease RNase R prior to sequencing. RNase R exclusively digests RNA with a free end, helping enrich circularized RNA abundance in the sample. 

These example commands will generate the following plot:
![User example plot](https://github.com/flemingtonlab/SpliceV/blob/master/etc/vta1.png)

This plot reveals a prominant circle from exon 2 through exon 4 (evidenced by the back-splice junction reads which are plotted as curves below the axis. This is also demonstrated by the higher level of coverage in exon 2-4, shown by the relative intensity of color).

![User example plot explained](https://github.com/flemingtonlab/SpliceV/blob/master/etc/vta1_explained.png)

The major circularized isoform (exons 2-4; another less prevalent circle appears to include exon 5) is isolated below:


![User example circle](https://github.com/flemingtonlab/SpliceV/blob/master/etc/vta1_circ.png)

## Authors ##
Created by Nathan Ungerleider and Erik Flemington




%package help
Summary:	Development documents and examples for SpliceV
Provides:	python3-SpliceV-doc
%description help
# SpliceV #
Visualize coverage, canonical, and backsplice junctions.

![Example plot](https://github.com/flemingtonlab/SpliceV/blob/master/etc/example.png)

## Documentation ##
See https://splicev.readthedocs.io/en/master/

## Example pipeline ##
See https://github.com/flemingtonlab/SpliceV/blob/master/docs/example.pdf

This will generate figure 1B and 1C from our manuscript (DOI pending)

## Requirements ##
SpliceV works with Python 2.7 and 3.0+.
## Dependencies ##
* Matplotlib
* Numpy
* pysam
## Installation ##
To install SpliceV:

```
pip install SpliceV
```

Or:

```
git clone https://github.com/flemingtonlab/SpliceV.git
```

## Example ##
To run the example dataset:

```
git clone https://github.com/flemingtonlab/SpliceV.git 

cd SpliceV/example 

python ../bin/SpliceV -b example.vta1.bam -gtf vta1.gtf -sj example.canonical.bed -bsj example.circles.bed -g VTA1 -f 3 -is 3

```

The sample data comes from Akata cells (a B Cell Lymphoma line) that were treated with the exonuclease RNase R prior to sequencing. RNase R exclusively digests RNA with a free end, helping enrich circularized RNA abundance in the sample. 

These example commands will generate the following plot:
![User example plot](https://github.com/flemingtonlab/SpliceV/blob/master/etc/vta1.png)

This plot reveals a prominant circle from exon 2 through exon 4 (evidenced by the back-splice junction reads which are plotted as curves below the axis. This is also demonstrated by the higher level of coverage in exon 2-4, shown by the relative intensity of color).

![User example plot explained](https://github.com/flemingtonlab/SpliceV/blob/master/etc/vta1_explained.png)

The major circularized isoform (exons 2-4; another less prevalent circle appears to include exon 5) is isolated below:


![User example circle](https://github.com/flemingtonlab/SpliceV/blob/master/etc/vta1_circ.png)

## Authors ##
Created by Nathan Ungerleider and Erik Flemington




%prep
%autosetup -n SpliceV-0.2.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-SpliceV -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.0.0-1
- Package Spec generated