%global _empty_manifest_terminate_build 0
Name:		python-pgwidget
Version:	0.7.2
Release:	1
Summary:	Widgets for pygame
License:	MIT License
URL:		https://github.com/DovaX/pgwidget
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/fd/86/77434783fe33a044ae90bddd1c53f0b6d5d72f7367d49521ffad3eafc04b/pgwidget-0.7.2.tar.gz
BuildArch:	noarch

Requires:	python3-pygame
Requires:	python3-pandas
Requires:	python3-multinherit
Requires:	python3-doxyplot
Requires:	python3-remi

%description
# pgwidget

pgwidget is a Python library for easy creation of GUI widgets in pygame environment.

## Installation

Use the package manager [pip](https://pip.pypa.io/en/stable/) to install pgwidget.

```bash
pip install pgwidget
```

## Usage

```python
import pgwidget.pgwidget_core as pgw

buttons=pgw.PgWidget()
button1=pgw.Button([800,100],[80,20],"Submit")
buttons.elements.append(button1)

pgwidgets=[buttons]
pgw.main_program_loop(pgwidgets,None)
```

In examples folder you can get several GUI elements.
![alt text](https://github.com/dovax/pgwidget/blob/main/example1.png?raw=true)

## Contributing
Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.

## License
[MIT](https://choosealicense.com/licenses/mit/)

## Currently implemented

* Checkbox
* Radio button
* Button (image)
* Button (classical)
* Table (spreadsheet)




%package -n python3-pgwidget
Summary:	Widgets for pygame
Provides:	python-pgwidget
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pgwidget
# pgwidget

pgwidget is a Python library for easy creation of GUI widgets in pygame environment.

## Installation

Use the package manager [pip](https://pip.pypa.io/en/stable/) to install pgwidget.

```bash
pip install pgwidget
```

## Usage

```python
import pgwidget.pgwidget_core as pgw

buttons=pgw.PgWidget()
button1=pgw.Button([800,100],[80,20],"Submit")
buttons.elements.append(button1)

pgwidgets=[buttons]
pgw.main_program_loop(pgwidgets,None)
```

In examples folder you can get several GUI elements.
![alt text](https://github.com/dovax/pgwidget/blob/main/example1.png?raw=true)

## Contributing
Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.

## License
[MIT](https://choosealicense.com/licenses/mit/)

## Currently implemented

* Checkbox
* Radio button
* Button (image)
* Button (classical)
* Table (spreadsheet)




%package help
Summary:	Development documents and examples for pgwidget
Provides:	python3-pgwidget-doc
%description help
# pgwidget

pgwidget is a Python library for easy creation of GUI widgets in pygame environment.

## Installation

Use the package manager [pip](https://pip.pypa.io/en/stable/) to install pgwidget.

```bash
pip install pgwidget
```

## Usage

```python
import pgwidget.pgwidget_core as pgw

buttons=pgw.PgWidget()
button1=pgw.Button([800,100],[80,20],"Submit")
buttons.elements.append(button1)

pgwidgets=[buttons]
pgw.main_program_loop(pgwidgets,None)
```

In examples folder you can get several GUI elements.
![alt text](https://github.com/dovax/pgwidget/blob/main/example1.png?raw=true)

## Contributing
Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.

## License
[MIT](https://choosealicense.com/licenses/mit/)

## Currently implemented

* Checkbox
* Radio button
* Button (image)
* Button (classical)
* Table (spreadsheet)




%prep
%autosetup -n pgwidget-0.7.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pgwidget -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.2-1
- Package Spec generated