%global _empty_manifest_terminate_build 0
Name:		python-pyxel-sim
Version:	1.8
Release:	1
Summary:	Pyxel detector simulation framework.
License:	MIT
URL:		https://pypi.org/project/pyxel-sim/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/3b/05/dd7016e224627c7fab09b118a40fa102cf2ad503dea8d2d2214bd5900ab5/pyxel_sim-1.8.tar.gz
BuildArch:	noarch

Requires:	python3-numba
Requires:	python3-numpy
Requires:	python3-pandas
Requires:	python3-scipy
Requires:	python3-xarray
Requires:	python3-sep
Requires:	python3-matplotlib
Requires:	python3-seaborn
Requires:	python3-holoviews
Requires:	python3-bokeh
Requires:	python3-dask
Requires:	python3-distributed
Requires:	python3-ipywidgets
Requires:	python3-astropy
Requires:	python3-fsspec[http]
Requires:	python3-h5py
Requires:	python3-pyyaml
Requires:	python3-xlrd
Requires:	python3-openpyxl
Requires:	python3-netcdf4
Requires:	python3-attrs
Requires:	python3-click
Requires:	python3-tqdm
Requires:	python3-typing-extensions
Requires:	python3-pympler
Requires:	python3-pillow
Requires:	python3-scikit-image
Requires:	python3-pyxel-sim[calibration]
Requires:	python3-pyxel-sim[model]
Requires:	python3-pyxel-sim[io]
Requires:	python3-pygmo
Requires:	python3-asdf
Requires:	python3-poppy

%description
[![doi](https://zenodo.org/badge/DOI/10.1117/1.JATIS.8.4.048002.svg)](https://doi.org/10.1117/1.JATIS.8.4.048002)
[![ASCL](https://img.shields.io/badge/ascl-2301.002-blue.svg?colorB=262255)](https://ascl.net/2301.002)
[![docs](https://esa.gitlab.io/pyxel/documentation.svg)](https://esa.gitlab.io/pyxel/doc)
[![gitter](https://badges.gitter.im/pyxel-framework/community.svg)](https://gitter.im/pyxel-framework/community)
[![Google Group](https://img.shields.io/badge/Google%20Group-Pyxel%20Detector%20Framework-blue.svg)](https://groups.google.com/g/pyxel-detector-framework)
[![License](https://img.shields.io/badge/license-MIT-green.svg)](https://gitlab.com/esa/pyxel/blob/master/LICENSE.txt)
[![PyPI version](https://badge.fury.io/py/pyxel-sim.svg)](https://badge.fury.io/py/pyxel-sim)
[![conda](https://img.shields.io/conda/vn/conda-forge/pyxel-sim.svg)](https://anaconda.org/conda-forge/pyxel-sim)
[![Binder](https://mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gl/esa%2Fpyxel-data/HEAD?urlpath=lab)
[![pipeline status](https://gitlab.com/esa/pyxel/badges/master/pipeline.svg)](https://gitlab.com/esa/pyxel/-/pipelines)
[![coverage report](https://gitlab.com/esa/pyxel/badges/master/coverage.svg)](https://gitlab.com/esa/pyxel/-/commits/master)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![JSON Schema](https://img.shields.io/badge/JSON%20Schema-draft--07-green)](https://esa.gitlab.io/pyxel/pyxel_schema.json)
## What is it?
*Pyxel* is a general detector simulation framework.
An easy-to-use framework that can simulate a variety of imaging detector
effects combined on images (e.g. radiation and optical effects, noises)
made by CCD or CMOS-based detectors.
*Pyxel* is tested on Python 3.8+.
If you'd like to contribute to *Pyxel* you're most welcome.
Please read [the little guide](https://esa.gitlab.io/pyxel/doc/stable/references/contributing.html) to get you started.
## Documentation
Learn more about *Pyxel* in its offical [blog](https://esa.gitlab.io/pyxel) and its official documentation at [https://esa.gitlab.io/pyxel/doc](https://esa.gitlab.io/pyxel/doc).
## Quickstart Setup
The best way to get started and learn Pyxel are the [Tutorials and Examples](https://esa.gitlab.io/pyxel/doc/stable/tutorials/examples.html).
For convenience we provide a pre-defined conda environment file,
so you can get additional useful packages together with Pyxel in a virtual isolated environment.
For more information check the [Quickstart Setup](https://esa.gitlab.io/pyxel/doc/stable/tutorials/overview.html#quickstart-setup) instructions.
## Installation
[Installation instructions](https://esa.gitlab.io/pyxel/doc/stable/tutorials/install.html) can be found in the tutorials.
## Examples
Example notebooks of Pyxel can be found in a separate public repository [Pyxel Data](https://gitlab.com/esa/pyxel-data). Examples can either be downloaded and run locally or run in the cloud using Binder, by clicking on the badge above.
## Getting Help
* Report bugs, suggest features or view the source code on [GitLab](https://gitlab.com/esa/pyxel).
* For less well-defined questions or ideas, or to announce other projets of interest to Pyxel users, use the *Pyxel* [mailing list](https://groups.google.com/g/pyxel-detector-framework).
## Discussion and Development
Most development discussion is taking place on GitLab in this repo.
Further, the *Pyxel* [mailing list](https://groups.google.com/g/pyxel-detector-framework) can also be used for specialized discussions or design issues, and a [Gitter channel](https://gitter.im/pyxel-framework/community) is available for quick development related questions.
## Citing Pyxel
If you use *Pyxel*, please cite the paper we published in [SPIE Digital Library](https://www.spiedigitallibrary.org/journals/Journal-of-Astronomical-Telescopes-Instruments-and-Systems/volume-8/issue-04/048002/Pyxel-10--an-open-source-Python-framework-for-detector/10.1117/1.JATIS.8.4.048002.full?SSO=1).
## Contributing to *Pyxel*
All contributions, bug reports, bug fixes, documentation improvements, enhancements and ideas are welcome.
A detailed overview on how to contribute to *Pyxel* can be found in the
[**contributing guide**](https://esa.gitlab.io/pyxel/doc/stable/references/contributing.html).
There is also an [overview](.gitlab/CONTRIBUTING.md) on GitLab.
If you are simply looking to start working with the *Pyxel* codebase, navigate to the
[GitLab "issues" tab](https://gitlab.com/esa/pyxel/issues) and start looking through interesting issues.
There are a number of issues listed under [Docs](https://gitlab.com/esa/pyxel/issues?label_name%5B%5D=documentation) and [good first issue](https://gitlab.com/esa/pyxel/issues?label_name%5B%5D=good+first+issue) where you could start out.
Or maybe through using *Pyxel* you have an idea of your own or are looking for something in the documentation and thinking 'this can be improved'... you can do something about it !
Feel free to ask questions on the [mailing list](https://groups.google.com/g/pyxel-detector-framework) or on [Gitter](https://gitter.im/pyxel-framework/community).
## Changelog
The [detailed changelog](https://esa.gitlab.io/pyxel/doc/stable/references/changelog.html) is available on the website.
## License
*Pyxel* is released under [MIT license](https://gitlab.com/esa/pyxel/blob/master/LICENSE.txt).

%package -n python3-pyxel-sim
Summary:	Pyxel detector simulation framework.
Provides:	python-pyxel-sim
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pyxel-sim
[![doi](https://zenodo.org/badge/DOI/10.1117/1.JATIS.8.4.048002.svg)](https://doi.org/10.1117/1.JATIS.8.4.048002)
[![ASCL](https://img.shields.io/badge/ascl-2301.002-blue.svg?colorB=262255)](https://ascl.net/2301.002)
[![docs](https://esa.gitlab.io/pyxel/documentation.svg)](https://esa.gitlab.io/pyxel/doc)
[![gitter](https://badges.gitter.im/pyxel-framework/community.svg)](https://gitter.im/pyxel-framework/community)
[![Google Group](https://img.shields.io/badge/Google%20Group-Pyxel%20Detector%20Framework-blue.svg)](https://groups.google.com/g/pyxel-detector-framework)
[![License](https://img.shields.io/badge/license-MIT-green.svg)](https://gitlab.com/esa/pyxel/blob/master/LICENSE.txt)
[![PyPI version](https://badge.fury.io/py/pyxel-sim.svg)](https://badge.fury.io/py/pyxel-sim)
[![conda](https://img.shields.io/conda/vn/conda-forge/pyxel-sim.svg)](https://anaconda.org/conda-forge/pyxel-sim)
[![Binder](https://mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gl/esa%2Fpyxel-data/HEAD?urlpath=lab)
[![pipeline status](https://gitlab.com/esa/pyxel/badges/master/pipeline.svg)](https://gitlab.com/esa/pyxel/-/pipelines)
[![coverage report](https://gitlab.com/esa/pyxel/badges/master/coverage.svg)](https://gitlab.com/esa/pyxel/-/commits/master)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![JSON Schema](https://img.shields.io/badge/JSON%20Schema-draft--07-green)](https://esa.gitlab.io/pyxel/pyxel_schema.json)
## What is it?
*Pyxel* is a general detector simulation framework.
An easy-to-use framework that can simulate a variety of imaging detector
effects combined on images (e.g. radiation and optical effects, noises)
made by CCD or CMOS-based detectors.
*Pyxel* is tested on Python 3.8+.
If you'd like to contribute to *Pyxel* you're most welcome.
Please read [the little guide](https://esa.gitlab.io/pyxel/doc/stable/references/contributing.html) to get you started.
## Documentation
Learn more about *Pyxel* in its offical [blog](https://esa.gitlab.io/pyxel) and its official documentation at [https://esa.gitlab.io/pyxel/doc](https://esa.gitlab.io/pyxel/doc).
## Quickstart Setup
The best way to get started and learn Pyxel are the [Tutorials and Examples](https://esa.gitlab.io/pyxel/doc/stable/tutorials/examples.html).
For convenience we provide a pre-defined conda environment file,
so you can get additional useful packages together with Pyxel in a virtual isolated environment.
For more information check the [Quickstart Setup](https://esa.gitlab.io/pyxel/doc/stable/tutorials/overview.html#quickstart-setup) instructions.
## Installation
[Installation instructions](https://esa.gitlab.io/pyxel/doc/stable/tutorials/install.html) can be found in the tutorials.
## Examples
Example notebooks of Pyxel can be found in a separate public repository [Pyxel Data](https://gitlab.com/esa/pyxel-data). Examples can either be downloaded and run locally or run in the cloud using Binder, by clicking on the badge above.
## Getting Help
* Report bugs, suggest features or view the source code on [GitLab](https://gitlab.com/esa/pyxel).
* For less well-defined questions or ideas, or to announce other projets of interest to Pyxel users, use the *Pyxel* [mailing list](https://groups.google.com/g/pyxel-detector-framework).
## Discussion and Development
Most development discussion is taking place on GitLab in this repo.
Further, the *Pyxel* [mailing list](https://groups.google.com/g/pyxel-detector-framework) can also be used for specialized discussions or design issues, and a [Gitter channel](https://gitter.im/pyxel-framework/community) is available for quick development related questions.
## Citing Pyxel
If you use *Pyxel*, please cite the paper we published in [SPIE Digital Library](https://www.spiedigitallibrary.org/journals/Journal-of-Astronomical-Telescopes-Instruments-and-Systems/volume-8/issue-04/048002/Pyxel-10--an-open-source-Python-framework-for-detector/10.1117/1.JATIS.8.4.048002.full?SSO=1).
## Contributing to *Pyxel*
All contributions, bug reports, bug fixes, documentation improvements, enhancements and ideas are welcome.
A detailed overview on how to contribute to *Pyxel* can be found in the
[**contributing guide**](https://esa.gitlab.io/pyxel/doc/stable/references/contributing.html).
There is also an [overview](.gitlab/CONTRIBUTING.md) on GitLab.
If you are simply looking to start working with the *Pyxel* codebase, navigate to the
[GitLab "issues" tab](https://gitlab.com/esa/pyxel/issues) and start looking through interesting issues.
There are a number of issues listed under [Docs](https://gitlab.com/esa/pyxel/issues?label_name%5B%5D=documentation) and [good first issue](https://gitlab.com/esa/pyxel/issues?label_name%5B%5D=good+first+issue) where you could start out.
Or maybe through using *Pyxel* you have an idea of your own or are looking for something in the documentation and thinking 'this can be improved'... you can do something about it !
Feel free to ask questions on the [mailing list](https://groups.google.com/g/pyxel-detector-framework) or on [Gitter](https://gitter.im/pyxel-framework/community).
## Changelog
The [detailed changelog](https://esa.gitlab.io/pyxel/doc/stable/references/changelog.html) is available on the website.
## License
*Pyxel* is released under [MIT license](https://gitlab.com/esa/pyxel/blob/master/LICENSE.txt).

%package help
Summary:	Development documents and examples for pyxel-sim
Provides:	python3-pyxel-sim-doc
%description help
[![doi](https://zenodo.org/badge/DOI/10.1117/1.JATIS.8.4.048002.svg)](https://doi.org/10.1117/1.JATIS.8.4.048002)
[![ASCL](https://img.shields.io/badge/ascl-2301.002-blue.svg?colorB=262255)](https://ascl.net/2301.002)
[![docs](https://esa.gitlab.io/pyxel/documentation.svg)](https://esa.gitlab.io/pyxel/doc)
[![gitter](https://badges.gitter.im/pyxel-framework/community.svg)](https://gitter.im/pyxel-framework/community)
[![Google Group](https://img.shields.io/badge/Google%20Group-Pyxel%20Detector%20Framework-blue.svg)](https://groups.google.com/g/pyxel-detector-framework)
[![License](https://img.shields.io/badge/license-MIT-green.svg)](https://gitlab.com/esa/pyxel/blob/master/LICENSE.txt)
[![PyPI version](https://badge.fury.io/py/pyxel-sim.svg)](https://badge.fury.io/py/pyxel-sim)
[![conda](https://img.shields.io/conda/vn/conda-forge/pyxel-sim.svg)](https://anaconda.org/conda-forge/pyxel-sim)
[![Binder](https://mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gl/esa%2Fpyxel-data/HEAD?urlpath=lab)
[![pipeline status](https://gitlab.com/esa/pyxel/badges/master/pipeline.svg)](https://gitlab.com/esa/pyxel/-/pipelines)
[![coverage report](https://gitlab.com/esa/pyxel/badges/master/coverage.svg)](https://gitlab.com/esa/pyxel/-/commits/master)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![JSON Schema](https://img.shields.io/badge/JSON%20Schema-draft--07-green)](https://esa.gitlab.io/pyxel/pyxel_schema.json)
## What is it?
*Pyxel* is a general detector simulation framework.
An easy-to-use framework that can simulate a variety of imaging detector
effects combined on images (e.g. radiation and optical effects, noises)
made by CCD or CMOS-based detectors.
*Pyxel* is tested on Python 3.8+.
If you'd like to contribute to *Pyxel* you're most welcome.
Please read [the little guide](https://esa.gitlab.io/pyxel/doc/stable/references/contributing.html) to get you started.
## Documentation
Learn more about *Pyxel* in its offical [blog](https://esa.gitlab.io/pyxel) and its official documentation at [https://esa.gitlab.io/pyxel/doc](https://esa.gitlab.io/pyxel/doc).
## Quickstart Setup
The best way to get started and learn Pyxel are the [Tutorials and Examples](https://esa.gitlab.io/pyxel/doc/stable/tutorials/examples.html).
For convenience we provide a pre-defined conda environment file,
so you can get additional useful packages together with Pyxel in a virtual isolated environment.
For more information check the [Quickstart Setup](https://esa.gitlab.io/pyxel/doc/stable/tutorials/overview.html#quickstart-setup) instructions.
## Installation
[Installation instructions](https://esa.gitlab.io/pyxel/doc/stable/tutorials/install.html) can be found in the tutorials.
## Examples
Example notebooks of Pyxel can be found in a separate public repository [Pyxel Data](https://gitlab.com/esa/pyxel-data). Examples can either be downloaded and run locally or run in the cloud using Binder, by clicking on the badge above.
## Getting Help
* Report bugs, suggest features or view the source code on [GitLab](https://gitlab.com/esa/pyxel).
* For less well-defined questions or ideas, or to announce other projets of interest to Pyxel users, use the *Pyxel* [mailing list](https://groups.google.com/g/pyxel-detector-framework).
## Discussion and Development
Most development discussion is taking place on GitLab in this repo.
Further, the *Pyxel* [mailing list](https://groups.google.com/g/pyxel-detector-framework) can also be used for specialized discussions or design issues, and a [Gitter channel](https://gitter.im/pyxel-framework/community) is available for quick development related questions.
## Citing Pyxel
If you use *Pyxel*, please cite the paper we published in [SPIE Digital Library](https://www.spiedigitallibrary.org/journals/Journal-of-Astronomical-Telescopes-Instruments-and-Systems/volume-8/issue-04/048002/Pyxel-10--an-open-source-Python-framework-for-detector/10.1117/1.JATIS.8.4.048002.full?SSO=1).
## Contributing to *Pyxel*
All contributions, bug reports, bug fixes, documentation improvements, enhancements and ideas are welcome.
A detailed overview on how to contribute to *Pyxel* can be found in the
[**contributing guide**](https://esa.gitlab.io/pyxel/doc/stable/references/contributing.html).
There is also an [overview](.gitlab/CONTRIBUTING.md) on GitLab.
If you are simply looking to start working with the *Pyxel* codebase, navigate to the
[GitLab "issues" tab](https://gitlab.com/esa/pyxel/issues) and start looking through interesting issues.
There are a number of issues listed under [Docs](https://gitlab.com/esa/pyxel/issues?label_name%5B%5D=documentation) and [good first issue](https://gitlab.com/esa/pyxel/issues?label_name%5B%5D=good+first+issue) where you could start out.
Or maybe through using *Pyxel* you have an idea of your own or are looking for something in the documentation and thinking 'this can be improved'... you can do something about it !
Feel free to ask questions on the [mailing list](https://groups.google.com/g/pyxel-detector-framework) or on [Gitter](https://gitter.im/pyxel-framework/community).
## Changelog
The [detailed changelog](https://esa.gitlab.io/pyxel/doc/stable/references/changelog.html) is available on the website.
## License
*Pyxel* is released under [MIT license](https://gitlab.com/esa/pyxel/blob/master/LICENSE.txt).

%prep
%autosetup -n pyxel-sim-1.8

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pyxel-sim -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 1.8-1
- Package Spec generated