%global _empty_manifest_terminate_build 0
Name: python-image-slicer
Version: 2.1.1
Release: 1
Summary: Split images into tiles. Join the tiles back together.
License: MIT license
URL: https://github.com/samdobson/image_slicer
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/17/72/e1afeef7cf8bf441c1471abbc2565314fca1144fa819b1b04fdd85f2953a/image_slicer-2.1.1.tar.gz
BuildArch: noarch
Requires: python3-Pillow
Requires: python3-Pillow
Requires: python3-pytest-runner
Requires: python3-wheel
Requires: python3-black
Requires: python3-codecov
Requires: python3-flake8
Requires: python3-flake8-debugger
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-raises
Requires: python3-bumpversion
Requires: python3-coverage
Requires: python3-ipython
Requires: python3-m2r
Requires: python3-Sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-tox
Requires: python3-twine
Requires: python3-wheel
Requires: python3-pytest-runner
Requires: python3-wheel
Requires: python3-black
Requires: python3-codecov
Requires: python3-flake8
Requires: python3-flake8-debugger
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-raises
Requires: python3-bumpversion
Requires: python3-coverage
Requires: python3-ipython
Requires: python3-m2r
Requires: python3-Sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-tox
Requires: python3-twine
Requires: python3-wheel
Requires: python3-pytest-runner
Requires: python3-wheel
Requires: python3-black
Requires: python3-codecov
Requires: python3-flake8
Requires: python3-flake8-debugger
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-raises
%description
## Installation
**Latest Stable Release:** `pip install image_slicer`
**Current Development Head:** `pip install git+https://github.com/samdobson/image_slicer.git`
## Quick Start
Slice your images either with the command line utility:
```bash
$ slice-image cake.png 4
```
```python
from image_slicer import slice
slice('cake.png', 4)
```
## Documentation
For full package documentation please visit [samdobson.github.io/image_slicer](https://samdobson.github.io/image_slicer).
## Development
See [CONTRIBUTING.md](CONTRIBUTING.md) for details.
%package -n python3-image-slicer
Summary: Split images into tiles. Join the tiles back together.
Provides: python-image-slicer
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-image-slicer
## Installation
**Latest Stable Release:** `pip install image_slicer`
**Current Development Head:** `pip install git+https://github.com/samdobson/image_slicer.git`
## Quick Start
Slice your images either with the command line utility:
```bash
$ slice-image cake.png 4
```
```python
from image_slicer import slice
slice('cake.png', 4)
```
## Documentation
For full package documentation please visit [samdobson.github.io/image_slicer](https://samdobson.github.io/image_slicer).
## Development
See [CONTRIBUTING.md](CONTRIBUTING.md) for details.
%package help
Summary: Development documents and examples for image-slicer
Provides: python3-image-slicer-doc
%description help
## Installation
**Latest Stable Release:** `pip install image_slicer`
**Current Development Head:** `pip install git+https://github.com/samdobson/image_slicer.git`
## Quick Start
Slice your images either with the command line utility:
```bash
$ slice-image cake.png 4
```
```python
from image_slicer import slice
slice('cake.png', 4)
```
## Documentation
For full package documentation please visit [samdobson.github.io/image_slicer](https://samdobson.github.io/image_slicer).
## Development
See [CONTRIBUTING.md](CONTRIBUTING.md) for details.
%prep
%autosetup -n image-slicer-2.1.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-image-slicer -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 2.1.1-1
- Package Spec generated