%global _empty_manifest_terminate_build 0
Name: python-aflow
Version: 0.0.11
Release: 1
Summary: Python API for searching AFLOW database.
License: MIT
URL: https://github.com/rosenbrockc/aflow
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f8/c7/5a18ad3ad2ccae3886d9150e8fc03900072f2211437ad268347cd21f50fc/aflow-0.0.11.tar.gz
BuildArch: noarch
Requires: python3-termcolor
Requires: python3-numpy
Requires: python3-six
Requires: python3-jinja2
Requires: python3-beautifulsoup4
Requires: python3-ase
%description
Python API wrapping the AFLUX API language for AFLOW library. *Note:*
This is not an official repo of the AFLOW consortium and is not
maintained by them. `API
Documentation `__.
If you use this package, please cite it:
@ARTICLE{2017arXiv171000813R,
author = {{Rosenbrock}, C.~W.},
title = "{A Practical Python API for Querying AFLOWLIB}",
journal = {ArXiv e-prints},
archivePrefix = "arXiv",
eprint = {1710.00813},
primaryClass = "cs.DB",
keywords = {Computer Science - Databases},
year = 2017,
month = sep,
adsurl = {http://adsabs.harvard.edu/abs/2017arXiv171000813R},
adsnote = {Provided by the SAO/NASA Astrophysics Data System}
}
%package -n python3-aflow
Summary: Python API for searching AFLOW database.
Provides: python-aflow
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-aflow
Python API wrapping the AFLUX API language for AFLOW library. *Note:*
This is not an official repo of the AFLOW consortium and is not
maintained by them. `API
Documentation `__.
If you use this package, please cite it:
@ARTICLE{2017arXiv171000813R,
author = {{Rosenbrock}, C.~W.},
title = "{A Practical Python API for Querying AFLOWLIB}",
journal = {ArXiv e-prints},
archivePrefix = "arXiv",
eprint = {1710.00813},
primaryClass = "cs.DB",
keywords = {Computer Science - Databases},
year = 2017,
month = sep,
adsurl = {http://adsabs.harvard.edu/abs/2017arXiv171000813R},
adsnote = {Provided by the SAO/NASA Astrophysics Data System}
}
%package help
Summary: Development documents and examples for aflow
Provides: python3-aflow-doc
%description help
Python API wrapping the AFLUX API language for AFLOW library. *Note:*
This is not an official repo of the AFLOW consortium and is not
maintained by them. `API
Documentation `__.
If you use this package, please cite it:
@ARTICLE{2017arXiv171000813R,
author = {{Rosenbrock}, C.~W.},
title = "{A Practical Python API for Querying AFLOWLIB}",
journal = {ArXiv e-prints},
archivePrefix = "arXiv",
eprint = {1710.00813},
primaryClass = "cs.DB",
keywords = {Computer Science - Databases},
year = 2017,
month = sep,
adsurl = {http://adsabs.harvard.edu/abs/2017arXiv171000813R},
adsnote = {Provided by the SAO/NASA Astrophysics Data System}
}
%prep
%autosetup -n aflow-0.0.11
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-aflow -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.0.11-1
- Package Spec generated