%global _empty_manifest_terminate_build 0
Name: python-jupyterlab-hide-code
Version: 3.6.3
Release: 1
Summary: A JupyterLab extension to run and hide source code.
License: BSD-3-Clause
URL: https://github.com/osscar-org/jupyterlab-hide-code
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fd/3b/5cf90d661c693db77a68669f08b389b8502b77350edddcde6262c66ec504/jupyterlab_hide_code-3.6.3.tar.gz
BuildArch: noarch
%description
# **jupyterlab-hide-code**: A JupyterLab Extension to Run and Hide Source Code
![Build](https://github.com/osscar-org/jupyterlab-hide-code/workflows/Build/badge.svg)
[![PyPI version](https://badge.fury.io/py/jupyterlab-hide-code.svg)](https://badge.fury.io/py/jupyterlab-hide-code)
A button in JupyterLab to run the code cells and then to hide the code cells.
This JupyterLab extension was inspired by the
[jlab-hide-code](https://github.com/AixViPMaP/jlab-hide-code) JupyterLab
extension from Aachen (Aix) Virtual Platform for Materials Processing.
![demo](./docs/hide-input.gif)
## Requirements
- JupyterLab >= 3.0
## Install
```bash
pip install jupyterlab-hide-code
```
## Uninstall
```bash
pip uninstall jupyterlab-hide-code
```
## Contributing
### Build
The `jlpm` command is JupyterLab's pinned version of
[yarn](https://yarnpkg.com/) that is installed with JupyterLab. You may use
`yarn` or `npm` in lieu of `jlpm` below.
```bash
# Clone the repo to your local environment
# Move to jupyterlab-hide-code directory
# Install dependencies
jlpm
# Build Typescript source
jlpm build
# Link your development version of the extension with JupyterLab
jupyter labextension link .
# Rebuild Typescript source after making changes
jlpm build
# Rebuild JupyterLab after making any changes
jupyter lab build
```
You can watch the source directory and run JupyterLab in watch mode to watch for changes in the extension's source and automatically rebuild the extension and application.
```bash
# Watch the source directory in another terminal tab
jlpm watch
# Run jupyterlab in watch mode in one terminal tab
jupyter lab --watch
```
## Acknowlegements
We acknowledge support from the EPFL Open Science Fund via the [OSSCAR](http://www.osscar.org) project.
%package -n python3-jupyterlab-hide-code
Summary: A JupyterLab extension to run and hide source code.
Provides: python-jupyterlab-hide-code
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-jupyterlab-hide-code
# **jupyterlab-hide-code**: A JupyterLab Extension to Run and Hide Source Code
![Build](https://github.com/osscar-org/jupyterlab-hide-code/workflows/Build/badge.svg)
[![PyPI version](https://badge.fury.io/py/jupyterlab-hide-code.svg)](https://badge.fury.io/py/jupyterlab-hide-code)
A button in JupyterLab to run the code cells and then to hide the code cells.
This JupyterLab extension was inspired by the
[jlab-hide-code](https://github.com/AixViPMaP/jlab-hide-code) JupyterLab
extension from Aachen (Aix) Virtual Platform for Materials Processing.
![demo](./docs/hide-input.gif)
## Requirements
- JupyterLab >= 3.0
## Install
```bash
pip install jupyterlab-hide-code
```
## Uninstall
```bash
pip uninstall jupyterlab-hide-code
```
## Contributing
### Build
The `jlpm` command is JupyterLab's pinned version of
[yarn](https://yarnpkg.com/) that is installed with JupyterLab. You may use
`yarn` or `npm` in lieu of `jlpm` below.
```bash
# Clone the repo to your local environment
# Move to jupyterlab-hide-code directory
# Install dependencies
jlpm
# Build Typescript source
jlpm build
# Link your development version of the extension with JupyterLab
jupyter labextension link .
# Rebuild Typescript source after making changes
jlpm build
# Rebuild JupyterLab after making any changes
jupyter lab build
```
You can watch the source directory and run JupyterLab in watch mode to watch for changes in the extension's source and automatically rebuild the extension and application.
```bash
# Watch the source directory in another terminal tab
jlpm watch
# Run jupyterlab in watch mode in one terminal tab
jupyter lab --watch
```
## Acknowlegements
We acknowledge support from the EPFL Open Science Fund via the [OSSCAR](http://www.osscar.org) project.
%package help
Summary: Development documents and examples for jupyterlab-hide-code
Provides: python3-jupyterlab-hide-code-doc
%description help
# **jupyterlab-hide-code**: A JupyterLab Extension to Run and Hide Source Code
![Build](https://github.com/osscar-org/jupyterlab-hide-code/workflows/Build/badge.svg)
[![PyPI version](https://badge.fury.io/py/jupyterlab-hide-code.svg)](https://badge.fury.io/py/jupyterlab-hide-code)
A button in JupyterLab to run the code cells and then to hide the code cells.
This JupyterLab extension was inspired by the
[jlab-hide-code](https://github.com/AixViPMaP/jlab-hide-code) JupyterLab
extension from Aachen (Aix) Virtual Platform for Materials Processing.
![demo](./docs/hide-input.gif)
## Requirements
- JupyterLab >= 3.0
## Install
```bash
pip install jupyterlab-hide-code
```
## Uninstall
```bash
pip uninstall jupyterlab-hide-code
```
## Contributing
### Build
The `jlpm` command is JupyterLab's pinned version of
[yarn](https://yarnpkg.com/) that is installed with JupyterLab. You may use
`yarn` or `npm` in lieu of `jlpm` below.
```bash
# Clone the repo to your local environment
# Move to jupyterlab-hide-code directory
# Install dependencies
jlpm
# Build Typescript source
jlpm build
# Link your development version of the extension with JupyterLab
jupyter labextension link .
# Rebuild Typescript source after making changes
jlpm build
# Rebuild JupyterLab after making any changes
jupyter lab build
```
You can watch the source directory and run JupyterLab in watch mode to watch for changes in the extension's source and automatically rebuild the extension and application.
```bash
# Watch the source directory in another terminal tab
jlpm watch
# Run jupyterlab in watch mode in one terminal tab
jupyter lab --watch
```
## Acknowlegements
We acknowledge support from the EPFL Open Science Fund via the [OSSCAR](http://www.osscar.org) project.
%prep
%autosetup -n jupyterlab-hide-code-3.6.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-jupyterlab-hide-code -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 3.6.3-1
- Package Spec generated