%global _empty_manifest_terminate_build 0
Name: python-pyhelpers
Version: 1.4.6
Release: 1
Summary: An open-source toolkit for facilitating Python users' data manipulation tasks.
License: GPLv3+
URL: https://github.com/mikeqfu/pyhelpers
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/32/89/bfd29ec05df7108de086c4fb27b70b4cc4cc897268dc8fe618af877d7307/pyhelpers-1.4.6.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-pyproj
Requires: python3-Shapely
Requires: python3-pandas
Requires: python3-requests
Requires: python3-SQLAlchemy
Requires: python3-psycopg2
%description
#########
PyHelpers
#########
|Python| |Documentation| |License| |Codacy grade| |DOI|
.. |Python| image:: https://img.shields.io/pypi/pyversions/pyhelpers
:alt: Python version
:target: https://docs.python.org/3/
.. |Documentation| image:: https://readthedocs.org/projects/pyhelpers/badge/?version=latest
:alt: Documentation status
:target: https://pyhelpers.readthedocs.io/en/latest/?badge=latest
.. |License| image:: https://img.shields.io/pypi/l/pyhelpers
:alt: License
:target: https://github.com/mikeqfu/pyhelpers/blob/master/LICENSE
.. |Codacy grade| image:: https://app.codacy.com/project/badge/Grade/c3ed8571c494450da12cb0c4d3c8c7e9
:alt: Codacy grade (Code quality)
:target: https://www.codacy.com/gh/mikeqfu/pyhelpers/dashboard?utm_source=github.com&utm_medium=referral&utm_content=mikeqfu/pyhelpers&utm_campaign=Badge_Grade
.. |DOI| image:: https://zenodo.org/badge/173177909.svg
:alt: Zenodo - DOI
:target: https://zenodo.org/badge/latestdoi/173177909
PyHelpers is an open-source Python package designed as a lite toolkit for facilitating data (pre)processing. It offers a miscellaneous collection of handy utilities, which could assist us in performing many common data manipulation tasks, such as reading/writing of file-like objects, handling of various types of data (e.g. geographical data and textual data) and communication with relational databases (e.g. PostgreSQL and Microsoft SQL Server).
Installation
############
To install the latest release of pyhelpers from `PyPI `_ via `pip `_:
.. code-block:: bash
pip install --upgrade pyhelpers
For more information, please refer to `Installation `_.
Documentation
#############
The full PyHelpers documentation (including detailed examples and a quick-start tutorial) is hosted on `ReadTheDocs `_: [`HTML `_] [`PDF `_].
License
#######
PyHelpers is licensed under `GNU General Public License v3 `_ or later (GPLv3+).
Cite as
#######
Fu, Q. (2020). PyHelpers: an open-source toolkit for facilitating Python users' data manipulation tasks. Zenodo. `doi:10.5281/zenodo.4017438 `_
.. code-block:: bibtex
@software{qian_fu_pyhelpers_4017438,
author = {Qian Fu},
title = {{PyHelpers: an open-source toolkit for facilitating
Python users' data manipulation tasks}},
year = 2020,
publisher = {Zenodo},
doi = {10.5281/zenodo.4017438},
url = {https://doi.org/10.5281/zenodo.4017438}
}
**Note:** Please also refer to the export options from `Zenodo `_ to reference the specific version of PyHelpers as appropriate.
%package -n python3-pyhelpers
Summary: An open-source toolkit for facilitating Python users' data manipulation tasks.
Provides: python-pyhelpers
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyhelpers
#########
PyHelpers
#########
|Python| |Documentation| |License| |Codacy grade| |DOI|
.. |Python| image:: https://img.shields.io/pypi/pyversions/pyhelpers
:alt: Python version
:target: https://docs.python.org/3/
.. |Documentation| image:: https://readthedocs.org/projects/pyhelpers/badge/?version=latest
:alt: Documentation status
:target: https://pyhelpers.readthedocs.io/en/latest/?badge=latest
.. |License| image:: https://img.shields.io/pypi/l/pyhelpers
:alt: License
:target: https://github.com/mikeqfu/pyhelpers/blob/master/LICENSE
.. |Codacy grade| image:: https://app.codacy.com/project/badge/Grade/c3ed8571c494450da12cb0c4d3c8c7e9
:alt: Codacy grade (Code quality)
:target: https://www.codacy.com/gh/mikeqfu/pyhelpers/dashboard?utm_source=github.com&utm_medium=referral&utm_content=mikeqfu/pyhelpers&utm_campaign=Badge_Grade
.. |DOI| image:: https://zenodo.org/badge/173177909.svg
:alt: Zenodo - DOI
:target: https://zenodo.org/badge/latestdoi/173177909
PyHelpers is an open-source Python package designed as a lite toolkit for facilitating data (pre)processing. It offers a miscellaneous collection of handy utilities, which could assist us in performing many common data manipulation tasks, such as reading/writing of file-like objects, handling of various types of data (e.g. geographical data and textual data) and communication with relational databases (e.g. PostgreSQL and Microsoft SQL Server).
Installation
############
To install the latest release of pyhelpers from `PyPI `_ via `pip `_:
.. code-block:: bash
pip install --upgrade pyhelpers
For more information, please refer to `Installation `_.
Documentation
#############
The full PyHelpers documentation (including detailed examples and a quick-start tutorial) is hosted on `ReadTheDocs `_: [`HTML `_] [`PDF `_].
License
#######
PyHelpers is licensed under `GNU General Public License v3 `_ or later (GPLv3+).
Cite as
#######
Fu, Q. (2020). PyHelpers: an open-source toolkit for facilitating Python users' data manipulation tasks. Zenodo. `doi:10.5281/zenodo.4017438 `_
.. code-block:: bibtex
@software{qian_fu_pyhelpers_4017438,
author = {Qian Fu},
title = {{PyHelpers: an open-source toolkit for facilitating
Python users' data manipulation tasks}},
year = 2020,
publisher = {Zenodo},
doi = {10.5281/zenodo.4017438},
url = {https://doi.org/10.5281/zenodo.4017438}
}
**Note:** Please also refer to the export options from `Zenodo `_ to reference the specific version of PyHelpers as appropriate.
%package help
Summary: Development documents and examples for pyhelpers
Provides: python3-pyhelpers-doc
%description help
#########
PyHelpers
#########
|Python| |Documentation| |License| |Codacy grade| |DOI|
.. |Python| image:: https://img.shields.io/pypi/pyversions/pyhelpers
:alt: Python version
:target: https://docs.python.org/3/
.. |Documentation| image:: https://readthedocs.org/projects/pyhelpers/badge/?version=latest
:alt: Documentation status
:target: https://pyhelpers.readthedocs.io/en/latest/?badge=latest
.. |License| image:: https://img.shields.io/pypi/l/pyhelpers
:alt: License
:target: https://github.com/mikeqfu/pyhelpers/blob/master/LICENSE
.. |Codacy grade| image:: https://app.codacy.com/project/badge/Grade/c3ed8571c494450da12cb0c4d3c8c7e9
:alt: Codacy grade (Code quality)
:target: https://www.codacy.com/gh/mikeqfu/pyhelpers/dashboard?utm_source=github.com&utm_medium=referral&utm_content=mikeqfu/pyhelpers&utm_campaign=Badge_Grade
.. |DOI| image:: https://zenodo.org/badge/173177909.svg
:alt: Zenodo - DOI
:target: https://zenodo.org/badge/latestdoi/173177909
PyHelpers is an open-source Python package designed as a lite toolkit for facilitating data (pre)processing. It offers a miscellaneous collection of handy utilities, which could assist us in performing many common data manipulation tasks, such as reading/writing of file-like objects, handling of various types of data (e.g. geographical data and textual data) and communication with relational databases (e.g. PostgreSQL and Microsoft SQL Server).
Installation
############
To install the latest release of pyhelpers from `PyPI `_ via `pip `_:
.. code-block:: bash
pip install --upgrade pyhelpers
For more information, please refer to `Installation `_.
Documentation
#############
The full PyHelpers documentation (including detailed examples and a quick-start tutorial) is hosted on `ReadTheDocs `_: [`HTML `_] [`PDF `_].
License
#######
PyHelpers is licensed under `GNU General Public License v3 `_ or later (GPLv3+).
Cite as
#######
Fu, Q. (2020). PyHelpers: an open-source toolkit for facilitating Python users' data manipulation tasks. Zenodo. `doi:10.5281/zenodo.4017438 `_
.. code-block:: bibtex
@software{qian_fu_pyhelpers_4017438,
author = {Qian Fu},
title = {{PyHelpers: an open-source toolkit for facilitating
Python users' data manipulation tasks}},
year = 2020,
publisher = {Zenodo},
doi = {10.5281/zenodo.4017438},
url = {https://doi.org/10.5281/zenodo.4017438}
}
**Note:** Please also refer to the export options from `Zenodo `_ to reference the specific version of PyHelpers as appropriate.
%prep
%autosetup -n pyhelpers-1.4.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyhelpers -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 1.4.6-1
- Package Spec generated