%global _empty_manifest_terminate_build 0
Name:		python-champ
Version:	2.1.1
Release:	1
Summary:	Modularity based networks partition selection tool
License:	GPLv3+
URL:		http://github.com/wweir827/champ
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/e6/5f/d6a8bddcc4a436a6e6104166aa627e97a3aae1fbee7352426e9b44d97e3b/champ-2.1.1.tar.gz
BuildArch:	noarch

Requires:	python3-matplotlib
Requires:	python3-future
Requires:	python3-numpy
Requires:	python3-h5py
Requires:	python3-scipy
Requires:	python3-scikit-learn
Requires:	python3-louvain
Requires:	python3-leidenalg
Requires:	python3-igraph
Requires:	python3-seaborn
Requires:	python3-tqdm

%description


%package -n python3-champ
Summary:	Modularity based networks partition selection tool
Provides:	python-champ
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-champ


%package help
Summary:	Development documents and examples for champ
Provides:	python3-champ-doc
%description help


%prep
%autosetup -n champ-2.1.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-champ -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.1-1
- Package Spec generated