%global _empty_manifest_terminate_build 0
Name:		python-pdfme
Version:	0.4.11
Release:	1
Summary:	Create PDFs easily
License:	MIT License
URL:		https://github.com/aFelipeSP/pdfme
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/90/50/ef171d9bad261938ec0182ff013d906831144915ec4a08184c75f71be001/pdfme-0.4.11.tar.gz
BuildArch:	noarch


%description
# pdfme

This is a powerful library to create PDF documents easily.

The way you create a PDF document with pdfme is very similar to how you create
documents with LaTex: you just tell pdfme at a very high level what elements you
want to be in the document, without worrying about wrapping text in a box,
positioning every element inside the page, creating the lines of a table, or the
internals of the PDF Document Format. pdfme will put every element
below the last one, and when a page is full it will add a new page to keep
adding elements to the document, and will keep adding pages until all of the
elements are inside the document. It just works.

If you want the power to place elements wherever you want and mess with the PDF
Document Format internals, pdfme got you covered too. Give the docs a look to
check how you can do this.

## Main features

* You can create a document without having to worry about the position of each
  element in the document. But you have the possibility to place any element
  wherever you want too.
* You can add rich text paragraphs (paragraphs with text in different sizes,
  fonts, colors and styles).
* You can add tables and place whatever you want on their cells, span columns
  and rows, and change the fills and borders in the easiest way possible. 
* You can add content boxes, a multi-column element where you can add 
  paragraphs, images, tables and even content boxes themselves. The elements
  inside this content boxes are added from top to bottom and from left to right.
* You can add url links (to web pages), labels/references, footnotes and
  outlines anywhere in the document.
* You can add running sections, content boxes that will be included in every
  page you add to the document. Headers and footers are the most common running
  sections, but you can add running sections anywhere in the page.
## Installation

You can install using pip:
```
pip install pdfme
```

## Documentation

* Docs and examples: https://pdfme.readthedocs.io





%package -n python3-pdfme
Summary:	Create PDFs easily
Provides:	python-pdfme
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pdfme
# pdfme

This is a powerful library to create PDF documents easily.

The way you create a PDF document with pdfme is very similar to how you create
documents with LaTex: you just tell pdfme at a very high level what elements you
want to be in the document, without worrying about wrapping text in a box,
positioning every element inside the page, creating the lines of a table, or the
internals of the PDF Document Format. pdfme will put every element
below the last one, and when a page is full it will add a new page to keep
adding elements to the document, and will keep adding pages until all of the
elements are inside the document. It just works.

If you want the power to place elements wherever you want and mess with the PDF
Document Format internals, pdfme got you covered too. Give the docs a look to
check how you can do this.

## Main features

* You can create a document without having to worry about the position of each
  element in the document. But you have the possibility to place any element
  wherever you want too.
* You can add rich text paragraphs (paragraphs with text in different sizes,
  fonts, colors and styles).
* You can add tables and place whatever you want on their cells, span columns
  and rows, and change the fills and borders in the easiest way possible. 
* You can add content boxes, a multi-column element where you can add 
  paragraphs, images, tables and even content boxes themselves. The elements
  inside this content boxes are added from top to bottom and from left to right.
* You can add url links (to web pages), labels/references, footnotes and
  outlines anywhere in the document.
* You can add running sections, content boxes that will be included in every
  page you add to the document. Headers and footers are the most common running
  sections, but you can add running sections anywhere in the page.
## Installation

You can install using pip:
```
pip install pdfme
```

## Documentation

* Docs and examples: https://pdfme.readthedocs.io





%package help
Summary:	Development documents and examples for pdfme
Provides:	python3-pdfme-doc
%description help
# pdfme

This is a powerful library to create PDF documents easily.

The way you create a PDF document with pdfme is very similar to how you create
documents with LaTex: you just tell pdfme at a very high level what elements you
want to be in the document, without worrying about wrapping text in a box,
positioning every element inside the page, creating the lines of a table, or the
internals of the PDF Document Format. pdfme will put every element
below the last one, and when a page is full it will add a new page to keep
adding elements to the document, and will keep adding pages until all of the
elements are inside the document. It just works.

If you want the power to place elements wherever you want and mess with the PDF
Document Format internals, pdfme got you covered too. Give the docs a look to
check how you can do this.

## Main features

* You can create a document without having to worry about the position of each
  element in the document. But you have the possibility to place any element
  wherever you want too.
* You can add rich text paragraphs (paragraphs with text in different sizes,
  fonts, colors and styles).
* You can add tables and place whatever you want on their cells, span columns
  and rows, and change the fills and borders in the easiest way possible. 
* You can add content boxes, a multi-column element where you can add 
  paragraphs, images, tables and even content boxes themselves. The elements
  inside this content boxes are added from top to bottom and from left to right.
* You can add url links (to web pages), labels/references, footnotes and
  outlines anywhere in the document.
* You can add running sections, content boxes that will be included in every
  page you add to the document. Headers and footers are the most common running
  sections, but you can add running sections anywhere in the page.
## Installation

You can install using pip:
```
pip install pdfme
```

## Documentation

* Docs and examples: https://pdfme.readthedocs.io





%prep
%autosetup -n pdfme-0.4.11

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pdfme -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.11-1
- Package Spec generated