%global _empty_manifest_terminate_build 0
Name:		python-Flask-RESTy-Tenants
Version:	0.8.0
Release:	1
Summary:	Multitenant authorization for Flask-RESTy
License:	MIT
URL:		https://github.com/4Catalyzer/flask-resty-tenants
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/7c/48/6575bf52a57f65c4709cdb16f3114c6c28135fd268b2946a47f3892a3b69/Flask-RESTy-Tenants-0.8.0.tar.gz
BuildArch:	noarch

Requires:	python3-Flask
Requires:	python3-Flask-RESTy
Requires:	python3-SQLAlchemy

%description
# Flask-RESTy-Tenants [![Travis][build-badge]][build] [![PyPI][pypi-badge]][pypi]

Multitenant authorization for [Flask-RESTy](https://flask-resty.readthedocs.io/).

[![Codecov][codecov-badge]][codecov]

[build-badge]: https://img.shields.io/travis/4Catalyzer/flask-resty-tenants/master.svg
[build]: https://travis-ci.org/4Catalyzer/flask-resty-tenants
[pypi-badge]: https://img.shields.io/pypi/v/Flask-RESTy-Tenants.svg
[pypi]: https://pypi.python.org/pypi/Flask-RESTy-Tenants
[codecov-badge]: https://img.shields.io/codecov/c/github/4Catalyzer/flask-resty-tenants/master.svg
[codecov]: https://codecov.io/gh/4Catalyzer/flask-resty-tenants




%package -n python3-Flask-RESTy-Tenants
Summary:	Multitenant authorization for Flask-RESTy
Provides:	python-Flask-RESTy-Tenants
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Flask-RESTy-Tenants
# Flask-RESTy-Tenants [![Travis][build-badge]][build] [![PyPI][pypi-badge]][pypi]

Multitenant authorization for [Flask-RESTy](https://flask-resty.readthedocs.io/).

[![Codecov][codecov-badge]][codecov]

[build-badge]: https://img.shields.io/travis/4Catalyzer/flask-resty-tenants/master.svg
[build]: https://travis-ci.org/4Catalyzer/flask-resty-tenants
[pypi-badge]: https://img.shields.io/pypi/v/Flask-RESTy-Tenants.svg
[pypi]: https://pypi.python.org/pypi/Flask-RESTy-Tenants
[codecov-badge]: https://img.shields.io/codecov/c/github/4Catalyzer/flask-resty-tenants/master.svg
[codecov]: https://codecov.io/gh/4Catalyzer/flask-resty-tenants




%package help
Summary:	Development documents and examples for Flask-RESTy-Tenants
Provides:	python3-Flask-RESTy-Tenants-doc
%description help
# Flask-RESTy-Tenants [![Travis][build-badge]][build] [![PyPI][pypi-badge]][pypi]

Multitenant authorization for [Flask-RESTy](https://flask-resty.readthedocs.io/).

[![Codecov][codecov-badge]][codecov]

[build-badge]: https://img.shields.io/travis/4Catalyzer/flask-resty-tenants/master.svg
[build]: https://travis-ci.org/4Catalyzer/flask-resty-tenants
[pypi-badge]: https://img.shields.io/pypi/v/Flask-RESTy-Tenants.svg
[pypi]: https://pypi.python.org/pypi/Flask-RESTy-Tenants
[codecov-badge]: https://img.shields.io/codecov/c/github/4Catalyzer/flask-resty-tenants/master.svg
[codecov]: https://codecov.io/gh/4Catalyzer/flask-resty-tenants




%prep
%autosetup -n Flask-RESTy-Tenants-0.8.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Flask-RESTy-Tenants -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.0-1
- Package Spec generated