%global _empty_manifest_terminate_build 0
Name:		python-fourmat
Version:	0.11.1
Release:	1
Summary:	A library for batteries-included linting and autoformatting
License:	MIT
URL:		https://github.com/4Catalyzer/fourmat
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/25/33/7dc0ae2e98b3372388c819484d2f8dd3ea1d23b85c17b9ed1823a9054c6b/fourmat-0.11.1.tar.gz
BuildArch:	noarch

Requires:	python3-click
Requires:	python3-black
Requires:	python3-flake8-bugbear
Requires:	python3-flake8
Requires:	python3-isort

%description
# Fourmat

A library for batteries-included linting and autoformatting.

## Installation and Usage

Install fourmat through pip:

```sh
$ pip install fourmat
```

Create a `.fourmat` file to specify the directories and files to check.

```sh
$ fourmat check

$ fourmat fix
```

## Adding Fourmat as a pre-commit hook

Install the pre-commit package:

```sh
$ pip install pre-commit
```

Create a `.pre-commit-config.yaml` containing:

```yaml
repos:
- repo: https://github.com/4Catalyzer/fourmat
  rev: master  # or specify a version
  hooks:
    - id: fourmat
```

then install the hook:

```
$ pre-commit install
```




%package -n python3-fourmat
Summary:	A library for batteries-included linting and autoformatting
Provides:	python-fourmat
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-fourmat
# Fourmat

A library for batteries-included linting and autoformatting.

## Installation and Usage

Install fourmat through pip:

```sh
$ pip install fourmat
```

Create a `.fourmat` file to specify the directories and files to check.

```sh
$ fourmat check

$ fourmat fix
```

## Adding Fourmat as a pre-commit hook

Install the pre-commit package:

```sh
$ pip install pre-commit
```

Create a `.pre-commit-config.yaml` containing:

```yaml
repos:
- repo: https://github.com/4Catalyzer/fourmat
  rev: master  # or specify a version
  hooks:
    - id: fourmat
```

then install the hook:

```
$ pre-commit install
```




%package help
Summary:	Development documents and examples for fourmat
Provides:	python3-fourmat-doc
%description help
# Fourmat

A library for batteries-included linting and autoformatting.

## Installation and Usage

Install fourmat through pip:

```sh
$ pip install fourmat
```

Create a `.fourmat` file to specify the directories and files to check.

```sh
$ fourmat check

$ fourmat fix
```

## Adding Fourmat as a pre-commit hook

Install the pre-commit package:

```sh
$ pip install pre-commit
```

Create a `.pre-commit-config.yaml` containing:

```yaml
repos:
- repo: https://github.com/4Catalyzer/fourmat
  rev: master  # or specify a version
  hooks:
    - id: fourmat
```

then install the hook:

```
$ pre-commit install
```




%prep
%autosetup -n fourmat-0.11.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-fourmat -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.11.1-1
- Package Spec generated