%global _empty_manifest_terminate_build 0
Name: python-auklet
Version: 1.0.1
Release: 1
Summary: Auklet performance monitoring agent for Python IoT apps
License: Apache
URL: https://github.com/aukletio/Auklet-Agent-Python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b5/fa/2cc1b65cf574bbff6078efa8f97ee691842939dba9834c89023260e5694d/auklet-1.0.1.tar.gz
BuildArch: noarch
Requires: python3-six
Requires: python3-paho-mqtt
Requires: python3-psutil
Requires: python3-pidigits
Requires: python3-mock
Requires: python3-requests
Requires: python3-msgpack
%description
# Auklet for Python
This is the official Python agent for [Auklet][brochure_site]. It officially supports Python 2.7.9+ and 3.4-3.7, and runs on most POSIX-based operating systems (Debian, Ubuntu Core, Raspbian, QNX, etc).
## Features
- Automatic report of unhandled exceptions
- Automatic Function performance issue reporting
- Location, system architecture, and system metrics identification for all issues
- Ability to define data usage restriction
## Compliance
Auklet is an edge first application performance monitor; therefore, starting with version 1.0.0 we maintain the following compliance levels:
- Automotive Safety Integrity Level B (ASIL B)
If there are additional compliances that your industry requires please contact the team at .
## Quickstart
To install the agent with _pip_:
```bash
pip install auklet
```
To setup Auklet monitoring in your application:
```python
from auklet.monitoring import Monitoring
auklet_monitoring = Monitoring(
api_key="",
app_id="",
release=""
)
auklet_monitoring.start()
# Call your main function
main()
auklet_monitoring.stop()
```
### Authorization
To authorize your application you need to provide both an API key and app ID. These values are available in the connection settings of your application as well as during initial setup.
### Optional: Release Tracking
You can track releases and identify which devices are running what variant of code. To do this, you may provide the git commit hash of your deployed code and a version string you can modify. This release value should be passed into the constructor through the release argument, and your custom version should be passed via the version argument. The release value must be the git commit hash that represents the deployed version of your application. The version value is a string that you may set to whatever value you wish to define your versions. Please note that you can provide either a release value, version value, or both.
* Providing release enables code snippets to be shown for identified errors if you’ve linked your GitHub.
* Including version allows you to track what version of code had the issue.
```bash
curl -X POST https://api.auklet.io/v1/releases/ \
-H "Content-Type: application/json" \
-H "Authorization: JWT " \
-d '{"application": "", "release": "'$(git rev-parse HEAD)'", "version": ""}'
```
#### Get Release via Subprocess
If you package and deploy your entire Git repository (including the `.git` directory), and if you have `git` installed on your devices, you can get the commit hash via a subprocess:
```python
git_commit_hash = subprocess.check_output(['git', 'rev-parse', 'HEAD'])
.decode('utf8').strip('\n')
```
#### Get Release via Environment Variable
If you package your app and deploy it without access to `git`, you can pass the commit hash to your app using the environment variable `APPLICATION_GIT_COMMIT_HASH`:
```python
git_commit_hash = os.environ.get("APPLICATION_GIT_COMMIT_HASH")
```
#### Get Release via File
Lastly, if it is difficult or impossible to set an environment variable via your deployment platform, you can include a new file in your packaged deployment which contains the commit hash. You can read from this file and supply the value to the constructor.
At packaging time, write the commit hash to a file and then include it in your package:
```bash
git rev-parse HEAD > path/to/git_commit_hash.txt
```
At runtime, read the included file as follows:
```python
release_file = open("git_commit_hash.txt", "r")
git_commit_hash = release_file.read().decode('utf8').strip('\n')
```
#### Define Your Own Version
You can also provide your own version string in the constructor:
```python
from auklet.monitoring import Monitoring
auklet_monitoring = Monitoring(
api_key="",
app_id="",
release="",
version=""
)
```
## Resources
- [Auklet][brochure_site]
- [Python Documentation](https://docs.auklet.io/docs/python-integration)
- [Issue Tracker](https://github.com/aukletio/Auklet-Agent-Python/issues)
[brochure_site]: https://auklet.io
%package -n python3-auklet
Summary: Auklet performance monitoring agent for Python IoT apps
Provides: python-auklet
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-auklet
# Auklet for Python
This is the official Python agent for [Auklet][brochure_site]. It officially supports Python 2.7.9+ and 3.4-3.7, and runs on most POSIX-based operating systems (Debian, Ubuntu Core, Raspbian, QNX, etc).
## Features
- Automatic report of unhandled exceptions
- Automatic Function performance issue reporting
- Location, system architecture, and system metrics identification for all issues
- Ability to define data usage restriction
## Compliance
Auklet is an edge first application performance monitor; therefore, starting with version 1.0.0 we maintain the following compliance levels:
- Automotive Safety Integrity Level B (ASIL B)
If there are additional compliances that your industry requires please contact the team at .
## Quickstart
To install the agent with _pip_:
```bash
pip install auklet
```
To setup Auklet monitoring in your application:
```python
from auklet.monitoring import Monitoring
auklet_monitoring = Monitoring(
api_key="",
app_id="",
release=""
)
auklet_monitoring.start()
# Call your main function
main()
auklet_monitoring.stop()
```
### Authorization
To authorize your application you need to provide both an API key and app ID. These values are available in the connection settings of your application as well as during initial setup.
### Optional: Release Tracking
You can track releases and identify which devices are running what variant of code. To do this, you may provide the git commit hash of your deployed code and a version string you can modify. This release value should be passed into the constructor through the release argument, and your custom version should be passed via the version argument. The release value must be the git commit hash that represents the deployed version of your application. The version value is a string that you may set to whatever value you wish to define your versions. Please note that you can provide either a release value, version value, or both.
* Providing release enables code snippets to be shown for identified errors if you’ve linked your GitHub.
* Including version allows you to track what version of code had the issue.
```bash
curl -X POST https://api.auklet.io/v1/releases/ \
-H "Content-Type: application/json" \
-H "Authorization: JWT " \
-d '{"application": "", "release": "'$(git rev-parse HEAD)'", "version": ""}'
```
#### Get Release via Subprocess
If you package and deploy your entire Git repository (including the `.git` directory), and if you have `git` installed on your devices, you can get the commit hash via a subprocess:
```python
git_commit_hash = subprocess.check_output(['git', 'rev-parse', 'HEAD'])
.decode('utf8').strip('\n')
```
#### Get Release via Environment Variable
If you package your app and deploy it without access to `git`, you can pass the commit hash to your app using the environment variable `APPLICATION_GIT_COMMIT_HASH`:
```python
git_commit_hash = os.environ.get("APPLICATION_GIT_COMMIT_HASH")
```
#### Get Release via File
Lastly, if it is difficult or impossible to set an environment variable via your deployment platform, you can include a new file in your packaged deployment which contains the commit hash. You can read from this file and supply the value to the constructor.
At packaging time, write the commit hash to a file and then include it in your package:
```bash
git rev-parse HEAD > path/to/git_commit_hash.txt
```
At runtime, read the included file as follows:
```python
release_file = open("git_commit_hash.txt", "r")
git_commit_hash = release_file.read().decode('utf8').strip('\n')
```
#### Define Your Own Version
You can also provide your own version string in the constructor:
```python
from auklet.monitoring import Monitoring
auklet_monitoring = Monitoring(
api_key="",
app_id="",
release="",
version=""
)
```
## Resources
- [Auklet][brochure_site]
- [Python Documentation](https://docs.auklet.io/docs/python-integration)
- [Issue Tracker](https://github.com/aukletio/Auklet-Agent-Python/issues)
[brochure_site]: https://auklet.io
%package help
Summary: Development documents and examples for auklet
Provides: python3-auklet-doc
%description help
# Auklet for Python
This is the official Python agent for [Auklet][brochure_site]. It officially supports Python 2.7.9+ and 3.4-3.7, and runs on most POSIX-based operating systems (Debian, Ubuntu Core, Raspbian, QNX, etc).
## Features
- Automatic report of unhandled exceptions
- Automatic Function performance issue reporting
- Location, system architecture, and system metrics identification for all issues
- Ability to define data usage restriction
## Compliance
Auklet is an edge first application performance monitor; therefore, starting with version 1.0.0 we maintain the following compliance levels:
- Automotive Safety Integrity Level B (ASIL B)
If there are additional compliances that your industry requires please contact the team at .
## Quickstart
To install the agent with _pip_:
```bash
pip install auklet
```
To setup Auklet monitoring in your application:
```python
from auklet.monitoring import Monitoring
auklet_monitoring = Monitoring(
api_key="",
app_id="",
release=""
)
auklet_monitoring.start()
# Call your main function
main()
auklet_monitoring.stop()
```
### Authorization
To authorize your application you need to provide both an API key and app ID. These values are available in the connection settings of your application as well as during initial setup.
### Optional: Release Tracking
You can track releases and identify which devices are running what variant of code. To do this, you may provide the git commit hash of your deployed code and a version string you can modify. This release value should be passed into the constructor through the release argument, and your custom version should be passed via the version argument. The release value must be the git commit hash that represents the deployed version of your application. The version value is a string that you may set to whatever value you wish to define your versions. Please note that you can provide either a release value, version value, or both.
* Providing release enables code snippets to be shown for identified errors if you’ve linked your GitHub.
* Including version allows you to track what version of code had the issue.
```bash
curl -X POST https://api.auklet.io/v1/releases/ \
-H "Content-Type: application/json" \
-H "Authorization: JWT " \
-d '{"application": "", "release": "'$(git rev-parse HEAD)'", "version": ""}'
```
#### Get Release via Subprocess
If you package and deploy your entire Git repository (including the `.git` directory), and if you have `git` installed on your devices, you can get the commit hash via a subprocess:
```python
git_commit_hash = subprocess.check_output(['git', 'rev-parse', 'HEAD'])
.decode('utf8').strip('\n')
```
#### Get Release via Environment Variable
If you package your app and deploy it without access to `git`, you can pass the commit hash to your app using the environment variable `APPLICATION_GIT_COMMIT_HASH`:
```python
git_commit_hash = os.environ.get("APPLICATION_GIT_COMMIT_HASH")
```
#### Get Release via File
Lastly, if it is difficult or impossible to set an environment variable via your deployment platform, you can include a new file in your packaged deployment which contains the commit hash. You can read from this file and supply the value to the constructor.
At packaging time, write the commit hash to a file and then include it in your package:
```bash
git rev-parse HEAD > path/to/git_commit_hash.txt
```
At runtime, read the included file as follows:
```python
release_file = open("git_commit_hash.txt", "r")
git_commit_hash = release_file.read().decode('utf8').strip('\n')
```
#### Define Your Own Version
You can also provide your own version string in the constructor:
```python
from auklet.monitoring import Monitoring
auklet_monitoring = Monitoring(
api_key="",
app_id="",
release="",
version=""
)
```
## Resources
- [Auklet][brochure_site]
- [Python Documentation](https://docs.auklet.io/docs/python-integration)
- [Issue Tracker](https://github.com/aukletio/Auklet-Agent-Python/issues)
[brochure_site]: https://auklet.io
%prep
%autosetup -n auklet-1.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-auklet -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.0.1-1
- Package Spec generated