%global _empty_manifest_terminate_build 0
Name:		python-eox-core
Version:	8.1.0
Release:	1
Summary:	eduNEXT Openedx extensions
License:	AGPL
URL:		https://github.com/eduNEXT/eox-core
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/95/95/1bd897d6c90c5a5a56b0e8f331c8e18cd789a52d8c203e73a9d6308d84d7/eox-core-8.1.0.tar.gz
BuildArch:	noarch

Requires:	python3-django-oauth2-provider
Requires:	python3-django-oauth-toolkit
Requires:	python3-djangorestframework
Requires:	python3-django-waffle
Requires:	python3-django
Requires:	python3-edx-opaque-keys[django]
Requires:	python3-openedx-events
Requires:	python3-click
Requires:	python3-celery
Requires:	python3-edx-api-doc-tools
Requires:	python3-django-filter
Requires:	python3-six
Requires:	python3-edx-proctoring
Requires:	python3-eox-audit-model
Requires:	python3-sentry-sdk
Requires:	python3-social-auth-core[openidconnect]

%description


%package -n python3-eox-core
Summary:	eduNEXT Openedx extensions
Provides:	python-eox-core
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-eox-core


%package help
Summary:	Development documents and examples for eox-core
Provides:	python3-eox-core-doc
%description help


%prep
%autosetup -n eox-core-8.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-eox-core -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 8.1.0-1
- Package Spec generated