%global _empty_manifest_terminate_build 0
Name:		python-venn
Version:	0.1.3
Release:	1
Summary:	Venn diagrams for 2, 3, 4, 5, 6 sets
License:	GPLv3
URL:		https://pypi.org/project/venn/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/04/84/f80b26b286ed899a71ea5350f17416e67201081bafae8058c98c00e09577/venn-0.1.3.tar.gz
BuildArch:	noarch


%description
# pyvenn: Venn diagrams for 2, 3, 4, 5, 6 sets

Please refer to the Jupyter notebook for demos and a brief explanation of the
interface; a more complete documentation is in the works as the project keeps
evolving:  
https://github.com/LankyCyril/pyvenn/blob/master/pyvenn-demo.ipynb

This library is an evolution of tctianchi's pyvenn package (see fork URL).  
Their liberal license (Unlicense) allowed me to fork the repository,
change the license to GPLv3, modify the package's interface and, hopefully,
significantly contribute to and improve the library, and make it installable
from PyPI.

The main methods in this version are different from the ones in tctianchi's
implementation, but the original methods are still provided for backwards
compatibility, and I would like to emphasize the importance of tctianchi's work
that allowed for this library to exist (among other things, figuring out the
coordinates best fit for plotting the diagrams' shapes and petals' labels).

This iteration of the library implements two main functions:
* `venn(dataset_dict, **kwargs)` which plots true Venn diagrams for any number
of sets between 2 and 5 using ellipses, and for 6 sets using triangles
* `pseudovenn(dataset_dict, **kwargs)` which plots a Venn-like intersection of
six circles (not all intersections are present in such a plot, but many are).

%package -n python3-venn
Summary:	Venn diagrams for 2, 3, 4, 5, 6 sets
Provides:	python-venn
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-venn
# pyvenn: Venn diagrams for 2, 3, 4, 5, 6 sets

Please refer to the Jupyter notebook for demos and a brief explanation of the
interface; a more complete documentation is in the works as the project keeps
evolving:  
https://github.com/LankyCyril/pyvenn/blob/master/pyvenn-demo.ipynb

This library is an evolution of tctianchi's pyvenn package (see fork URL).  
Their liberal license (Unlicense) allowed me to fork the repository,
change the license to GPLv3, modify the package's interface and, hopefully,
significantly contribute to and improve the library, and make it installable
from PyPI.

The main methods in this version are different from the ones in tctianchi's
implementation, but the original methods are still provided for backwards
compatibility, and I would like to emphasize the importance of tctianchi's work
that allowed for this library to exist (among other things, figuring out the
coordinates best fit for plotting the diagrams' shapes and petals' labels).

This iteration of the library implements two main functions:
* `venn(dataset_dict, **kwargs)` which plots true Venn diagrams for any number
of sets between 2 and 5 using ellipses, and for 6 sets using triangles
* `pseudovenn(dataset_dict, **kwargs)` which plots a Venn-like intersection of
six circles (not all intersections are present in such a plot, but many are).

%package help
Summary:	Development documents and examples for venn
Provides:	python3-venn-doc
%description help
# pyvenn: Venn diagrams for 2, 3, 4, 5, 6 sets

Please refer to the Jupyter notebook for demos and a brief explanation of the
interface; a more complete documentation is in the works as the project keeps
evolving:  
https://github.com/LankyCyril/pyvenn/blob/master/pyvenn-demo.ipynb

This library is an evolution of tctianchi's pyvenn package (see fork URL).  
Their liberal license (Unlicense) allowed me to fork the repository,
change the license to GPLv3, modify the package's interface and, hopefully,
significantly contribute to and improve the library, and make it installable
from PyPI.

The main methods in this version are different from the ones in tctianchi's
implementation, but the original methods are still provided for backwards
compatibility, and I would like to emphasize the importance of tctianchi's work
that allowed for this library to exist (among other things, figuring out the
coordinates best fit for plotting the diagrams' shapes and petals' labels).

This iteration of the library implements two main functions:
* `venn(dataset_dict, **kwargs)` which plots true Venn diagrams for any number
of sets between 2 and 5 using ellipses, and for 6 sets using triangles
* `pseudovenn(dataset_dict, **kwargs)` which plots a Venn-like intersection of
six circles (not all intersections are present in such a plot, but many are).

%prep
%autosetup -n venn-0.1.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-venn -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.3-1
- Package Spec generated