%global _empty_manifest_terminate_build 0
Name:		python-Aerate
Version:	0.0.2.dev0
Release:	1
Summary:	Aerate REST APIs: falcons with swagger.
License:	BSD
URL:		http://aerate.arable.com
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/8d/81/32bee5136c71c6d466c70ce2c575438afba76fe41e27b2608229a74d8bc3/Aerate-0.0.2.dev0.tar.gz
BuildArch:	noarch


%description
Aerate is an open source Python REST API framework built on top of falcon and based on swagger.io specifications
Aerate can be used to build and deploy highly customizable, fully featured
RESTful Web Services that conform to swagger specifications. 
Aerate is powered by Falcon and offers support for MongoDB backends.
The codebase is thoroughly tested under Python 2.6, 2.7, 3.3, 3.4 and PyPy.

%package -n python3-Aerate
Summary:	Aerate REST APIs: falcons with swagger.
Provides:	python-Aerate
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Aerate
Aerate is an open source Python REST API framework built on top of falcon and based on swagger.io specifications
Aerate can be used to build and deploy highly customizable, fully featured
RESTful Web Services that conform to swagger specifications. 
Aerate is powered by Falcon and offers support for MongoDB backends.
The codebase is thoroughly tested under Python 2.6, 2.7, 3.3, 3.4 and PyPy.

%package help
Summary:	Development documents and examples for Aerate
Provides:	python3-Aerate-doc
%description help
Aerate is an open source Python REST API framework built on top of falcon and based on swagger.io specifications
Aerate can be used to build and deploy highly customizable, fully featured
RESTful Web Services that conform to swagger specifications. 
Aerate is powered by Falcon and offers support for MongoDB backends.
The codebase is thoroughly tested under Python 2.6, 2.7, 3.3, 3.4 and PyPy.

%prep
%autosetup -n Aerate-0.0.2.dev0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Aerate -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.2.dev0-1
- Package Spec generated